SharpCap Pro Not Slewing Mount Correctly using Celestron Starsense

A place to report problems and bugs in SharpCap
Forum rules
Please read about Troubleshooting USB Issues before posting.

*** Please do not post license keys - please report any problems with licensing to 'admin' by PM ***

Please include the following details in any bug report:

* Version of SharpCap
* Camera and other hardware being user
* Operating system version
* Contents of the SharpCap log after the problem has occurred.
[If SharpCap crashes, please send the bug report when prompted instead of including the log]
Post Reply
User avatar
Rocket_Guy
Posts: 16
Joined: Mon Jan 22, 2018 4:12 pm
Location: Huntsville, Alabama USA

SharpCap Pro Not Slewing Mount Correctly using Celestron Starsense

Post by Rocket_Guy » Thu Sep 19, 2019 3:50 pm

SharpCap Pro Not Slewing Mount Correctly using Celestron Starsense

Hello. I am currently using SharpCap to control an Orion Sirius mount (Skywatcher/SynScan) using the Celestron StarSense alignment accessory with the SynScan adapter (as a consequence, I'm also using the Celestron mount driver). The telescope slews correctly when I use the floating hand control display, however, when I try to slew the mount using the scope controls in SharpCap, the North/South contols operate correctly but the East/West controls do not. When using the east/west controls, the mount does not move (or moves imperceptibly slowly ... hard to tell). If I use the original SynScan hand control, everything works properly though. Don't know if it matter, but I'm also using the ZWO ASI290MC camera. Basically, all I did in the log file was to open up everything and then slew the mount using the North-East-South-West arrow keys in that order. Thank you. Bill

Info: 23:06:19.9427546 Thread:#1 SharpCap.Program.Main() :: Starting...
Info: 23:06:20.6920944 Thread:#1 SharpCap.Program.SetupNBUG() :: Setting up bug reporting.
Info: 23:06:20.8620949 Thread:#1 SharpCap.LogSystemInfo.Run() :: Starting thread to log system info
Info: 23:06:20.8920949 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: SharpCap Version 3.2.6101.0
Info: 23:06:20.8920949 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: GC Memory 118Mb
Info: 23:06:20.8920949 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: Process Memory 149Mb
Info: 23:06:20.8920949 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: Total Physical Memory 32659Mb
Info: 23:06:20.8920949 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: Available Physical Memory 27957Mb
Info: 23:06:20.8920949 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: Operating System : Microsoft Windows NT 6.2.9200.0
Info: 23:06:21.0820604 Thread:#1 SharpCap.Program.RunApp(Boolean showSplash) :: Setting up application
Info: 23:06:21.0820604 Thread:#1 SharpCap.Program.RunApp(Boolean showSplash) :: Initializing WPF
Debug: 23:06:21.1920600 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Started
Info: 23:06:21.3321014 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type BaslerDeviceEnumerator
Info: 23:06:21.3321014 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type QHYDeviceEnumerator
Info: 23:06:21.3321014 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type ASIDeviceEnumerator
Info: 23:06:21.3321014 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AltairDeviceEnumerator
Info: 23:06:21.4220945 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type PointGreyDeviceEnumerator
Info: 23:06:21.4220945 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type SxDeviceEnumerator
Info: 23:06:21.4321000 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Altair.dll
Info: 23:06:21.4420662 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.ASCOMCamera.dll
Info: 23:06:21.4420662 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.ASI.dll
Info: 23:06:21.4420662 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Basler.dll
Info: 23:06:21.4420662 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Celestron.dll
Info: 23:06:21.4520589 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.DS3.dll
Info: 23:06:21.4520589 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Fake.dll
Info: 23:06:21.4620675 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.INova.dll
Info: 23:06:21.4720613 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Moravian.dll
Info: 23:06:21.4720613 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.NewDirectShow.dll
Info: 23:06:21.4720613 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.PointGrey.dll
Info: 23:06:21.4720613 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.QHY.dll
Info: 23:06:21.4720613 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.SVBony.dll
Info: 23:06:21.4720613 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.SX.dll
Info: 23:06:21.4720613 Thread:#1 SharpCap.MultiCaptureProvider.AddProvidersByReflection(String[] providerNames) :: Added device enumerator of type CelestronDeviceEnumerator
Info: 23:06:21.4720613 Thread:#1 SharpCap.MultiCaptureProvider.AddProvidersByReflection(String[] providerNames) :: Added device enumerator of type iNovaDeviceEnumerator
Info: 23:06:21.4720613 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type MoravianDeviceEnumerator
Info: 23:06:21.4720613 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type SVBonyDeviceEnumerator
Info: 23:06:21.4720613 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type DS3DeviceEnumerator
Info: 23:06:21.4720613 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AscomDeviceEnumerator
Info: 23:06:21.4720613 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type FolderMonitorDeviceEnumerator
Info: 23:06:21.4720613 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type FakeDeviceEnumerator
Info: 23:06:21.6321009 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.WheelProxy.ASCOM.WheelFactory
Info: 23:06:21.7224202 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device ZWO FilterWheel (1)
Info: 23:06:21.7224202 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device ZWO FilterWheel (2)
Info: 23:06:21.7224202 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Filter Wheel Simulator [.Net]
Info: 23:06:21.7224202 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Simulator
Info: 23:06:21.7324253 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.WheelProxy.ZWO.WheelFactory
Info: 23:06:21.7523846 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.WheelProxy.ZWO.ManualWheelFactory
Info: 23:06:21.7623924 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Manual Filter Wheel
Info: 23:06:21.8523915 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.MountProxy.ASCOM.MountFactory
Info: 23:06:21.8624208 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Celestron Telescope Driver
Info: 23:06:21.8624208 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Telescope Simulator for .NET
Info: 23:06:21.8624208 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device SkyWatcher Telescope
Info: 23:06:21.8624208 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device ASCOM Dome Control
Info: 23:06:21.8624208 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Generic Hub
Info: 23:06:21.8624208 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Pipe diagnostic tool
Info: 23:06:21.8624208 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device POTH Hub
Info: 23:06:21.8624208 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Simulator
Info: 23:06:22.0923835 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: CPU : Intel(R) Core(TM) i7-6820HQ CPU @ 2.70GHz with 8 cores.
Info: 23:06:22.7700233 Thread:#1 SharpCap.Base.Utilities.Logger.LogStackTrace(LogLevel level, String msg) :: Parent being changed on PreviewPanel
at SharpCap.UI.ScrollZoomForm.OnParentChanged(Object sender, EventArgs eventArgs)

Debug: 23:06:23.4713510 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Ended
Debug: 23:06:23.8348581 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Started
Debug: 23:06:23.9363576 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Ended
Debug: 23:06:24.0004992 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Started
Debug: 23:06:24.0917401 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Timebomb checked
Info: 23:06:24.1048040 Thread:#1 SharpCap.Models.Application.get_Cameras() :: Starting scan for cameras
Debug: 23:06:24.1147994 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Started
Info: 23:06:24.1389011 Thread:#1 SharpCap.SharpCapApp.get_ForceSoftwareRendering() :: WPF Rendering tier is 2
Debug: 23:06:24.3378576 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Ended
Info: 23:06:24.7990808 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: QHYCameraFinder - found 0 cameras
Info: 23:06:24.9524539 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: Found ZWO ASI290MC
Info: 23:06:24.9534552 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: FindCameras - found 1 cameras
Info: 23:06:24.9534552 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: ZWO ASI290MC (ZWO ASI Cameras)
Verbose: 23:06:27.3912132 Thread:#1 SharpCap.Cameras.SVBony.SVBonyDLLImpl.SVBGetNumOfConnectedCameras :: Starting SVBGetNumOfConnectedCameras()
Verbose: 23:06:27.4012037 Thread:#1 SharpCap.Cameras.SVBony.SVBonyDLLImpl.SVBGetNumOfConnectedCameras :: Completed (returned 0) SVBGetNumOfConnectedCameras()
Info: 23:06:27.4834340 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Integrated Webcam (DirectShow Cameras)
Info: 23:06:27.5004788 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Camera V2 simulator (ASCOM Cameras)
Info: 23:06:27.5014820 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Folder Monitor Camera (Virtual Cameras)
Debug: 23:06:27.5034877 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Started
Debug: 23:06:27.5034877 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Ended
Info: 23:06:27.5034877 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 1 (Deep Sky) (Test Cameras)
Info: 23:06:27.5034877 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 2 (High Speed) (Test Cameras)
Info: 23:06:27.5586338 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: CameraListUpdated event received in UI thread
Debug: 23:06:27.8364817 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Docking setup
Debug: 23:06:28.5164403 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Startup scripts (if any) run
Debug: 23:06:28.5164403 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Menu updated
Debug: 23:06:28.7164397 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Splash and tips done
Verbose: 23:06:29.8513022 Thread:#1 SharpCap.FrameTransforms.LiveStacking.LiveStackTransform.ShouldSendImageUpdateRequest() :: Ignoring image update request because : _info=, _processor=
Verbose: 23:06:30.2179273 Thread:#1 SharpCap.FrameTransforms.LiveStacking.LiveStackTransform.ShouldSendImageUpdateRequest() :: Ignoring image update request because : _info=, _processor=
Info: 23:06:35.1815568 Thread:#1 SharpCap.PythonScripting.RunPythonScriptFile(String scriptFileName) :: Running Python script C:\Emrich\Other Programs\Telescope\SharpCap\LRGBH.py
Info: 23:06:36.5015526 Thread:#23 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: UpdateMenu event received in non-UI thread, dispatching to UI thread
Info: 23:06:36.5015526 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: UpdateMenu event received in UI thread
Debug: 23:06:50.7712214 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Ended
Info: 23:07:00.3432234 Thread:#1 SharpCap.ImageProcessing.AstroTortillaPlateSolver.AutodetectCygwinBinPath() :: Found Astrotortilla plate solver found at C:\cygwin\bin

User avatar
admin
Site Admin
Posts: 3175
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SharpCap Pro Not Slewing Mount Correctly using Celestron Starsense

Post by admin » Thu Sep 19, 2019 6:25 pm

Hi,

The next version of SharpCap that I put out will have additional logging in for control of Ascom mounts – when that comes out please retest and also turn on the option to log extra info (bottom of the first page of the settings) before opening the camera. That should give a much longer log file with much more information about the communication between SharpCap and the mount. Hopefully that will let us work out what's going on and if anything can be done about it.

Cheers, Robin

User avatar
Rocket_Guy
Posts: 16
Joined: Mon Jan 22, 2018 4:12 pm
Location: Huntsville, Alabama USA

Re: SharpCap Pro Not Slewing Mount Correctly using Celestron Starsense

Post by Rocket_Guy » Sat Sep 21, 2019 6:27 pm

With the new version of SharpCap, the problem has gone away! Thanks!

User avatar
admin
Site Admin
Posts: 3175
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SharpCap Pro Not Slewing Mount Correctly using Celestron Starsense

Post by admin » Sat Sep 21, 2019 8:18 pm

Hi,

Well that's even better!

Cheers, Robin

User avatar
Rocket_Guy
Posts: 16
Joined: Mon Jan 22, 2018 4:12 pm
Location: Huntsville, Alabama USA

Re: SharpCap Pro Not Slewing Mount Correctly using Celestron Starsense

Post by Rocket_Guy » Sat Oct 19, 2019 2:19 am

Hello Robin,

It seems that the problem has reappeared. I have no idea why. Attached is the extended log file that you requested earlier. Hopefully, it will help track down the problem. The procedure I followed was the same as before, that is I connected to the the mount and then slewed the mount north-east-south-west. I do appreciate all your help! Thanks.

Bill
Attachments
Sharpcap Log.txt
(291.34 KiB) Downloaded 6 times

User avatar
admin
Site Admin
Posts: 3175
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SharpCap Pro Not Slewing Mount Correctly using Celestron Starsense

Post by admin » Sat Oct 19, 2019 8:08 pm

Hi,

I have looked through the log file and I can see that you tried moving in different directions and each time SharpCap was sending a command to move at a rate of approximately 2° per second to the mount (search through the log file for MoveAxis to find this). This all looks correct.

What I do note is that you were very close to the north celestial pole when you are running these tests – in that area movement in the RA axis has much less effect on the field of view than it would moving the same number of degrees when you are pointing close to the equator – that's because a rotation in RA is effectively going around a much smaller circle in the sky when you are close to the pole. I suspect that this may be causing the effect that you have noticed.

Hope this helps, Robin

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests