64 bit SC Crashes

A place to report problems and bugs in SharpCap
Forum rules
Please read about Troubleshooting USB Issues before posting.

*** Please do not post license keys - please report any problems with licensing to 'admin' by PM ***

Please include the following details in any bug report:

* Version of SharpCap
* Camera and other hardware being user
* Operating system version
* Contents of the SharpCap log after the problem has occurred.
[If SharpCap crashes, please send the bug report when prompted instead of including the log]
calaban
Posts: 23
Joined: Thu May 09, 2019 4:23 pm

64 bit SC Crashes

Post by calaban » Mon Dec 02, 2019 10:28 pm

Guys

Me too.

Fist opened SC for ASI017MC imaging and ascom focuser, rough focus. Then another SC for QHY5L-III 178 for guiding, manual focus and centred to imaging. Then finder QHY-II to manual rough focus and centre.

Closed finder and guider. Switched to PHD2 for guiding. Back to imaging and Focus Assistant and Zoom to really focus in on star. Fatal Error.

Tried a few times. Restarted computer. I think even tried a repair of SC and back to an old version (or at least it seemed I had 64bit and another version installed). Uninstalled the newer one.

Anyway - finsished the night with numerous 15min subs as the night was about proving my tracking. Focus was all manual "by eye" on screen. Shame as this was a breakthrough night for my tracking.

Point is; sevearal fatal attempts with SC on Focus A [lus Zoom.

Regards Richard
Attachments
Log_2019-12-01T19_39_28-7572.log
(120.88 KiB) Downloaded 1 time
Log_2019-12-01T19_33_01-10928.log
(36.2 KiB) Downloaded 2 times
DllNotFoundException at SharpCap.Base.OpenCVImageUtils.OpenCVGaussianBlur(Int32, Int32, IntPtr, Int32, Int32, Single, Int32)_#11563.error.zip
(14.78 KiB) Downloaded 3 times

calaban
Posts: 23
Joined: Thu May 09, 2019 4:23 pm

Re: SC Crashes After Update

Post by calaban » Tue Dec 03, 2019 12:05 am

Some more logs, seems its 3 at a time. Have a few more if you would like them, cheers Richard
Attachments
Log_2019-12-01T20_38_21-5880.log
(48.16 KiB) Downloaded 2 times
Log_2019-12-01T20_32_00-2092.log
(60.43 KiB) Downloaded 1 time
Log_2019-12-01T20_26_10-10440.log
(94.37 KiB) Downloaded 1 time

User avatar
admin
Site Admin
Posts: 3289
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SC Crashes After Update

Post by admin » Tue Dec 03, 2019 6:52 pm

Hi Richard,

You have a second issue that is separate to Craig's issue.

It looks like you are running SharpCap 3.2 on Windows 8, which is unsupported. You need to update your computer to Windows 8.1 or go back to using either the 32-bit version of SharpCap if that works or SharpCap 3.0 which is the last officially supported version for windows 8.

Hope this helps, Robin

calaban
Posts: 23
Joined: Thu May 09, 2019 4:23 pm

Re: SC Crashes After Update

Post by calaban » Tue Dec 03, 2019 8:21 pm

Hi Robin

I’m running Win 10 64 bit.

Cheers

User avatar
admin
Site Admin
Posts: 3289
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SC Crashes After Update

Post by admin » Wed Dec 04, 2019 7:46 pm

calaban wrote:
Tue Dec 03, 2019 8:21 pm
Hi Robin

I’m running Win 10 64 bit.

Cheers
Well, in that case one of the questions I need to ask myself is how come SharpCap is logging the wrong Windows version?!!!

Code: Select all

Info:	20:38:22.3373949 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: Operating System : Microsoft Windows NT 6.2.9200.0
Is coming from your log files and that version number belongs to Windows 8. I've just seen that it happens on my machine as well!

I will have to think more about why the star detector DLL is crushing on your machine. Would you be prepared to do some tests if I can work out ways to track down the problem? In the meantime did the 32-bit version work any better?

Cheers, Robin

User avatar
admin
Site Admin
Posts: 3289
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: 64 bit SC Crashes

Post by admin » Wed Dec 04, 2019 8:33 pm

Hi,

Right, I've split this issue off into a separate thread. If you have some time to look into this further please could you download procdump from this page https://docs.microsoft.com/en-us/sysint ... s/procdump, unpack it and then do the following:

1. Start SharpCap as usual
2. From a command prompt, run procdump with these arguments

Code: Select all

procdump -e 1 -f "" sharpcap
3. Make SharpCap crash by selecting the focus tools – you can probably do this with the test camera rather than needing a real camera and clear sky
4. See if any output is printed in the procdump window when SharpCap crashes - if it is then please post it here.

Thanks, Robin

calaban
Posts: 23
Joined: Thu May 09, 2019 4:23 pm

Re: 64 bit SC Crashes

Post by calaban » Thu Dec 05, 2019 10:40 pm

Hi Robin

Tried a couple of times. Procdump seems to run OK but then is times out and closes Sharpcap before I can do anything.

Attached a couple of screen shots which I hope help. Am I doing something wrong??

Cheers Richard
Attachments
Snap15-40.jpg
Snap15-40.jpg (242.79 KiB) Viewed 89 times
Snap16-40.jpg
Snap16-40.jpg (243.4 KiB) Viewed 89 times

calaban
Posts: 23
Joined: Thu May 09, 2019 4:23 pm

Re: 64 bit SC Crashes

Post by calaban » Thu Dec 05, 2019 11:14 pm

I've tried rolling back the two ZWO drivers - camera and Ascom. Tried QHY camera. Same result when I open Focus Assistant. I didn't get to Zoom.

User avatar
admin
Site Admin
Posts: 3289
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: 64 bit SC Crashes

Post by admin » Fri Dec 06, 2019 8:00 pm

Hi Richard,

I think it is sulking because you have two copies of SharpCap running and it doesn't know which one of the two you want it to monitor. I think it should be okay if you only have one running.

I'm not expecting rolling back any other software to help – this is likely something to do with the state of the system itself somehow conflicting with one of the parts of the SharpCap application.

Cheers, Robin

calaban
Posts: 23
Joined: Thu May 09, 2019 4:23 pm

Re: 64 bit SC Crashes

Post by calaban » Fri Dec 06, 2019 9:33 pm

Hi Robin

I ran Procdump and it simply closed SC. I ran it again and it then thought two copies of SC were open.

Will try again.

Cheers
Attachments
Snap16-40a.jpg
Snap16-40a.jpg (202.88 KiB) Viewed 63 times

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests