SharpCap not responding when connecting to mount

A place to report problems and bugs in SharpCap
Forum rules
Please read about Troubleshooting USB Issues before posting.

*** Please do not post license keys - please report any problems with licensing to 'admin' by PM ***

Please include the following details in any bug report:

* Version of SharpCap
* Camera and other hardware being user
* Operating system version
* Contents of the SharpCap log after the problem has occurred.
[If SharpCap crashes, please send the bug report when prompted instead of including the log]
Post Reply
Ejp
Posts: 4
Joined: Wed Dec 04, 2019 4:00 pm

SharpCap not responding when connecting to mount

Post by Ejp » Wed Dec 04, 2019 4:11 pm

Windows 10 Version 1809
Sharpcap versions 3.2.6137.0 and 3.2.6128.0
Altair Astro GPCAM2 290M Mono
Skywatcher HEQ5 Pro mount

When connecting to the mount both of the above versions of Sharpcap launch EQMOD, but then the software becomes unresponsive. A message to that effect is displayed with the option to quit, which I do. EQMOD is not exited.

I am now using a previous version of Sharpcap, version 3.2.6121.0 which works without any problems.

Here is a copy of the log.

Info: 14:59:05.4117950 Thread:#1 SharpCap.Program.Main() :: Starting...
Info: 14:59:05.7555285 Thread:#1 SharpCap.Program.SetupNBUG() :: Setting up bug reporting.
Info: 14:59:05.8648953 Thread:#1 SharpCap.LogSystemInfo.Run() :: Starting thread to log system info
Info: 14:59:05.8805195 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: SharpCap Version 3.2.6128.0
Info: 14:59:05.8805195 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: GC Memory 116Mb
Info: 14:59:05.8805195 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: Process Memory 148Mb
Info: 14:59:05.8805195 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: Total Physical Memory 3978Mb
Info: 14:59:05.8805195 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: Available Physical Memory 1741Mb
Info: 14:59:05.8805195 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: Operating System : Microsoft Windows NT 6.2.9200.0
Info: 14:59:06.1148801 Thread:#1 SharpCap.Program.RunApp(Boolean showSplash) :: Setting up application
Info: 14:59:06.1305074 Thread:#1 SharpCap.Program.RunApp(Boolean showSplash) :: Initializing WPF
Debug: 14:59:06.2086259 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Started
Info: 14:59:06.2998101 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type BaslerDeviceEnumerator
Info: 14:59:06.2998101 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type QHYDeviceEnumerator
Info: 14:59:06.2998101 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type ASIDeviceEnumerator
Info: 14:59:06.2998101 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AltairDeviceEnumerator
Info: 14:59:06.3623063 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type PointGreyDeviceEnumerator
Info: 14:59:06.3623063 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type SxDeviceEnumerator
Info: 14:59:06.3779307 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Altair.dll
Info: 14:59:06.3779307 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.ASCOMCamera.dll
Info: 14:59:06.3779307 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.ASI.dll
Info: 14:59:06.3779307 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Basler.dll
Info: 14:59:06.3779307 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Celestron.dll
Info: 14:59:06.3935526 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.DS3.dll
Info: 14:59:06.3935526 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Fake.dll
Info: 14:59:06.3935526 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.INova.dll
Info: 14:59:06.4091790 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Moravian.dll
Info: 14:59:06.4091790 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.NewDirectShow.dll
Info: 14:59:06.4091790 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.PointGrey.dll
Info: 14:59:06.4091790 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.QHY.dll
Info: 14:59:06.4091790 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.SVBony.dll
Info: 14:59:06.4091790 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.SX.dll
Info: 14:59:06.4091790 Thread:#1 SharpCap.MultiCaptureProvider.AddProvidersByReflection(String[] providerNames) :: Added device enumerator of type CelestronDeviceEnumerator
Info: 14:59:06.4091790 Thread:#1 SharpCap.MultiCaptureProvider.AddProvidersByReflection(String[] providerNames) :: Added device enumerator of type iNovaDeviceEnumerator
Info: 14:59:06.4091790 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type MoravianDeviceEnumerator
Info: 14:59:06.4091790 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type SVBonyDeviceEnumerator
Info: 14:59:06.4091790 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type DS3DeviceEnumerator
Info: 14:59:06.4091790 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AscomDeviceEnumerator
Info: 14:59:06.4091790 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type FolderMonitorDeviceEnumerator
Info: 14:59:06.4091790 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type FakeDeviceEnumerator
Info: 14:59:06.5341712 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.WheelProxy.ASCOM.WheelFactory
Info: 14:59:06.5966668 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Filter Wheel Simulator [.Net]
Info: 14:59:06.6122924 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Simulator
Info: 14:59:06.6122924 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.WheelProxy.ZWO.WheelFactory
Info: 14:59:06.6435412 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.WheelProxy.ZWO.ManualWheelFactory
Info: 14:59:06.6435412 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Manual Filter Wheel
Info: 14:59:06.7216633 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.MountProxy.ASCOM.MountFactory
Info: 14:59:06.7216633 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Telescope Simulator for .NET
Info: 14:59:06.7216633 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device ASCOM Dome Control
Info: 14:59:06.7216633 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device EQMOD ASCOM HEQ5/6
Info: 14:59:06.7216633 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device EQMOD ASCOM Simulator
Info: 14:59:06.7216633 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Generic Hub
Info: 14:59:06.7216633 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Pipe diagnostic tool
Info: 14:59:06.7216633 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device POTH Hub
Info: 14:59:06.7216633 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Simulator
Info: 14:59:07.4403722 Thread:#1 SharpCap.Base.Utilities.Logger.LogStackTrace(LogLevel level, String msg) :: Parent being changed on PreviewPanel
at SharpCap.UI.ScrollZoomForm.OnParentChanged(Object sender, EventArgs eventArgs)

Debug: 14:59:08.0809582 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Ended
Debug: 14:59:08.3607886 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Started
Debug: 14:59:08.3637894 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Ended
Debug: 14:59:08.4187850 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Started
Debug: 14:59:08.4737788 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Timebomb checked
Info: 14:59:08.4847774 Thread:#1 SharpCap.Models.Application.get_Cameras() :: Starting scan for cameras
Debug: 14:59:08.4927781 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Started
Info: 14:59:08.4987771 Thread:LogInfo Thread#9 SharpCap.LogSystemInfo.ThreadProc() :: CPU : Intel(R) Celeron(R) CPU N2830 @ 2.16GHz with 2 cores.
Debug: 14:59:08.5177760 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Ended
Info: 14:59:08.7387600 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: QHYCameraFinder - found 0 cameras
Info: 14:59:08.8207574 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: FindCameras - found 0 cameras
Info: 14:59:08.8527527 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: ALTAIRGP290M (Altair Cameras)
Info: 14:59:09.7069166 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: TOSHIBA Web Camera - HD (DirectShow Cameras)
Info: 14:59:09.7079147 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: AltairCam (DirectShow Cameras)
Info: 14:59:09.7199144 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Altair Astro Camera ASCOM Driver (ASCOM Cameras)
Info: 14:59:09.7199144 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Altair Astro Camera ASCOM Driver 2 (ASCOM Cameras)
Info: 14:59:09.7199144 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Camera V2 simulator (ASCOM Cameras)
Info: 14:59:09.7209176 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Folder Monitor Camera (Virtual Cameras)
Debug: 14:59:09.7219174 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Started
Debug: 14:59:09.7219174 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Ended
Info: 14:59:09.7229178 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 1 (Deep Sky) (Test Cameras)
Info: 14:59:09.7229178 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 2 (High Speed) (Test Cameras)
Info: 14:59:09.7689101 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: CameraListUpdated event received in UI thread
Debug: 14:59:09.9961529 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Docking setup
Debug: 14:59:09.9961529 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Startup scripts (if any) run
Debug: 14:59:09.9961529 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Menu updated
Debug: 14:59:10.1211449 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Splash and tips done
Debug: 14:59:10.2617630 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Ended
Info: 14:59:10.2773861 Thread:#1 SharpCap.SharpCapApp.get_ForceSoftwareRendering() :: WPF Rendering tier is 2


Eric.

User avatar
admin
Site Admin
Posts: 3289
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SharpCap not responding when connecting to mount

Post by admin » Wed Dec 04, 2019 7:58 pm

Hi,

Your log file unfortunately doesn't show any information beyond the initial start-up and camera detection, so it's not telling me anything about why the Ascom mount connection might have gone wrong sadly. You may find that you have more complete log files saved in this folder

Code: Select all

C:\Users\<your user name>\AppData\Local\SharpCap\logs
I did make some changes to how the mount connection is handled between those two versions (6121 and 6128) to try to deal with a crash with iOptron mounts. I have been running EQMOD with the newer versions without any issues however.

Once SharpCap has started EQMOD, can you use the EQMOD UI to correctly control the telescope (ignoring the fact that SharpCap is frozen)?


Cheers, Robin

Ejp
Posts: 4
Joined: Wed Dec 04, 2019 4:00 pm

Re: SharpCap not responding when connecting to mount

Post by Ejp » Thu Dec 05, 2019 9:31 am

Thanks for your reply.

I've had a look but don't seem to have the AppData folder under my user name.

After SharpCap freezes I can still control the scope using EQMOD.

I have investigated a little further. I use the Hitecastro DC focus controller, and when it isn't connected, SharpCap starts up fine. So it seems to be an issue with Hitecastro and not EQMOD.

Hope this helps.

Many thanks,

Eric.

User avatar
turfpit
Posts: 890
Joined: Mon Feb 13, 2017 8:13 pm
Location: UK
Contact:

Re: SharpCap not responding when connecting to mount

Post by turfpit » Thu Dec 05, 2019 11:45 am

Eric

AppData is a hidden folder. In File Explorer under the View tab, you need to check Hidden items.

reveal-AppData-folder.JPG
reveal-AppData-folder.JPG (28.42 KiB) Viewed 85 times

Dave

Ejp
Posts: 4
Joined: Wed Dec 04, 2019 4:00 pm

Re: SharpCap not responding when connecting to mount

Post by Ejp » Thu Dec 05, 2019 2:02 pm

Hi Robin.

Thanks for pointing that out. Log attached.

Eric.
Attachments
Log_2019-12-05T13_52_24-8844.log
(19.78 KiB) Downloaded 1 time

User avatar
admin
Site Admin
Posts: 3289
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SharpCap not responding when connecting to mount

Post by admin » Thu Dec 05, 2019 8:51 pm

Hi,

Thanks for the update. Interesting that it seems to be related to the focus controller rather than the mount. One thing that may be worth trying is going into the hardware settings and deselecting the option that connects the hardware automatically when you open the camera. Once you've done that you can open the camera and the mount and focuser controls will appear but will be disabled because SharpCap won't have connected to them yet. You can then connect to them one at a time by ticking the 'connected' checkboxes and see if either of them because the problem or if perhaps this turns out to be a way around the problem.

If you can still make the problem happen when you connect one of the devices in this manner then we will dig further into what is causing SharpCap to hang when connecting to that device.

Cheers, Robin

Ejp
Posts: 4
Joined: Wed Dec 04, 2019 4:00 pm

Re: SharpCap not responding when connecting to mount

Post by Ejp » Fri Dec 06, 2019 11:00 am

Hi Robin.

Thanks for your suggestion, it works. I connected one at a time with the mount first, then the focuser and they both worked. Then I connected the focuser first followed by the mount and that works as well.

Thanks for sorting this out.

Eric.

User avatar
admin
Site Admin
Posts: 3289
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SharpCap not responding when connecting to mount

Post by admin » Fri Dec 06, 2019 8:09 pm

Hi Eric,

Good to hear that you have it working.

Cheers, Robin

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests