SC Crashes After Update

A place to report problems and bugs in SharpCap
Forum rules
Please read about Troubleshooting USB Issues before posting.

*** Please do not post license keys - please report any problems with licensing to 'admin' by PM ***

Please include the following details in any bug report:

* Version of SharpCap
* Camera and other hardware being user
* Operating system version
* Contents of the SharpCap log after the problem has occurred.
[If SharpCap crashes, please send the bug report when prompted instead of including the log]
Post Reply
CraigG
Posts: 13
Joined: Thu Nov 29, 2018 11:37 pm

SC Crashes After Update

Post by CraigG » Mon Dec 02, 2019 10:50 am

Hello!
I downloaded the latest update over the weekend. Although previous versions of SC worked fine as recently as last week, I am getting continuous crash messages when starting up the latest version. I used the "Send and Quit" option multiple times earlier today...not sure how that gets uploaded...but I've attached a screen shot of one of the events to help identify mine in the bug archive.

I did delete the latest version and rolled back to a August 2019 version but I still experience the continuous crashes.

My camera is the Atik Horizon mono communicating to SC via ASCOM and the camera continues to work with the native Atik sofware.

Thanks for the assistance as always!
Craig Goble
Bear Lake, MI
Screenshot (39)(1).png
Screenshot (39)(1).png (226.61 KiB) Viewed 134 times

User avatar
admin
Site Admin
Posts: 3289
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SC Crashes After Update

Post by admin » Mon Dec 02, 2019 6:37 pm

Hi,

The error that you are seeing indicates that the Ascom software for the horizon camera has stopped responding to requests from SharpCap. It's not something I would expect to happen as a result SharpCap update, but it's worth trying to go back to an older version to see if that does fix it.

I do have an Atik camera sitting on my desk right now, so I'm hoping to have support without needing to use the Ascom driver in the not-too-distant future.

Cheers, Robin

CraigG
Posts: 13
Joined: Thu Nov 29, 2018 11:37 pm

Re: SC Crashes After Update

Post by CraigG » Mon Dec 02, 2019 7:33 pm

Hi Robin!

Thanks for your response! The crashes just really surprise me since SC ran perfectly during a session just last week. I did roll back to a SC version from August and unfortunately I'm still getting the same crash reports. I'll dive into ASCOM some more to see what may be amiss.

Wow, if you could add direct support for the Horizon camera, that would be WONDERFUL! I know that you could draw in many Horizon users to the SC fold if that were were to happen. Although I love my two Atik Horizons, in the short time that I've had my Pro license, I find that I rarely use the Atik Infinity software anymore as SC offers me more features at this point...dark subtraction being at the top of my list. When everything is up and running, the Horizon/SC combo is a marvelous, stable imaging platform. Please let me know if I can help you in any way Robin!

Best Wishes,
Craig

CraigG
Posts: 13
Joined: Thu Nov 29, 2018 11:37 pm

Re: SC Crashes After Update

Post by CraigG » Tue Dec 03, 2019 8:35 pm

Good news!

After numerous attempts to delete and reload the ASCOM drivers, the latest Atik software, and rolling back to a previous SC version on my Dell imaging PC, I was still getting the RPC error crash message. On a whim, I downloaded the latest version of the Atik software and the SC ver 3.2.6086 on another PC that I have and everything worked perfectly! So I apparently have an issue with the Dell PC itself that is not allowing communication with SC via ASCOM. I have no reason to believe now that the latest SC release has anything to do the issue that I have on that PC.

Anyway, I'm happy to be back in business! Thanks..

Craig

User avatar
admin
Site Admin
Posts: 3289
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SC Crashes After Update

Post by admin » Wed Dec 04, 2019 7:47 pm

CraigG wrote:
Tue Dec 03, 2019 8:35 pm
Good news!

After numerous attempts to delete and reload the ASCOM drivers, the latest Atik software, and rolling back to a previous SC version on my Dell imaging PC, I was still getting the RPC error crash message. On a whim, I downloaded the latest version of the Atik software and the SC ver 3.2.6086 on another PC that I have and everything worked perfectly! So I apparently have an issue with the Dell PC itself that is not allowing communication with SC via ASCOM. I have no reason to believe now that the latest SC release has anything to do the issue that I have on that PC.

Anyway, I'm happy to be back in business! Thanks..

Craig
Hi,

I have seen issues (more often with mounts than with cameras) where if the Ascom driver gets started by an application is running as administrator then non-administrator applications can't talk to it. Could that be related?

Cheers, Robin

CraigG
Posts: 13
Joined: Thu Nov 29, 2018 11:37 pm

Re: SC Crashes After Update

Post by CraigG » Thu Dec 05, 2019 6:51 pm

Hi Robin!

Thanks for the suggestion. I just went ahead and did a PC reset on the Dell since I didn't have much loaded on it. I downloaded Atik's core package, ASCOM, and SC 3.2.6086.0 which I know works for my set set up and all seems to work now. The only issue I'm having since all this has happened is as I'm trying to rebuild my dark files, I find that the dark capture output is only in a PNG format and not FITs? I've tried different settings in the Output section, saved to both Dark Library and Capture files with no luck. I was able to save darks FITs without a second thought before the meltdown so not sure what I'm doing wrong. I've attached a screenshot to illustrate.
Screenshot (5).png
Screenshot (5).png (241.53 KiB) Viewed 51 times
Thanks for your good counsel Robin!
Craig

User avatar
admin
Site Admin
Posts: 3289
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SC Crashes After Update

Post by admin » Thu Dec 05, 2019 8:52 pm

Hi Craig,

I think that you need to change your preferred still image format to fits in the settings for the dark files to be created in fits format.

Cheers, Robin

CraigG
Posts: 13
Joined: Thu Nov 29, 2018 11:37 pm

Re: SC Crashes After Update

Post by CraigG » Thu Dec 05, 2019 8:59 pm

Aw geez! That would probably help...sorry for not thinking about that. :roll:

Best wishes,
Craig

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest