Initial Support for Moravian Instruments Cameras

Official SharpCap and Forum announcements
User avatar
admin
Site Admin
Posts: 2866
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Initial Support for Moravian Instruments Cameras

Post by admin » Fri May 17, 2019 5:30 pm

Hi,

The latest version of SharpCap 3.2 (currently 3.2.6020) is the first version to contain experimental support for Moravian instruments CMOS cameras (USB only). If any SharpCap users have these cameras, please feel free to test this latest version and feedback here on any issues that you might find.

The following features should work:

* Setting the exposure
* choosing between 8 and 16 bit mode
* taking exposures of up to a few seconds
* reading the sensor temperature from the camera
* getting correct colours from colour cameras in raw mode

These other features are not yet implemented:

* Binning or region of interest
* controlling the cooler on a cooled camera
* adjusting the gain on CMOS cameras (not yet available in SDK)
* controlling built-in filter wheels
* controlling the output of the auto guide port

If you have a Moravian instrument camera with any of the above features (including CCD models) and will be interested in helping test new versions of SharpCap with your camera, please let me know.

Thanks, Robin

radinsky
Posts: 12
Joined: Tue Dec 04, 2018 6:07 am

Re: Initial Support for Moravian Instruments Cameras

Post by radinsky » Mon May 27, 2019 7:39 am

Hi Robin.

I have Moravian Instruments CCD camera G1-1200.

The Sharpcap can connect to it but whole software freezes. It takes time till Camera Control Panel become available and once it's available none of the controls working. Totally it freeze.
I need to unplug the camera then I get error message: The application has crashed......

Also my licence just expired and I want to renew Sharpcap and there was lifetime licence available not that long ago, how can I find it.

I was looking for it but it seams it's not available any more.

Thanks

Rado

User avatar
admin
Site Admin
Posts: 2866
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Initial Support for Moravian Instruments Cameras

Post by admin » Mon May 27, 2019 8:41 pm

Hi,

Do you know how long your CCD takes to transfer a frame from the camera to the computer? I think it's likely that if that's quite a long time (several seconds for instance) then the SharpCap UI might lock up during the download for frame if you try and change any of the controls. Basically SharpCap can't send another message to the camera while the frame is downloading, but it needs to send messages to adjust settings or read the sensor temperature. I'll look into ways to reduce the effect of this in a future version.

I'm sorry to say that permanent licences are no longer available at the moment. Sorry for any disappointment.

Cheers, Robin

radinsky
Posts: 12
Joined: Tue Dec 04, 2018 6:07 am

Re: Initial Support for Moravian Instruments Cameras

Post by radinsky » Wed May 29, 2019 8:05 am

Robin, I don't have a clue how long CCD takes to transfer a frame from the camera to the computer.
I don't know how to find that out.
Even when Sharpcap is frozen previewing frames are counted about every second.
I takes about 10 to 15 seconds till frames start counting but it takes about 30 seconds till image and control panel are available when I connect camera to Sharpcap.
And after that all stops working.

Don't worry about not having lifetime licence available any more. The price for Sharpcap is very reasonable, at least for me.

Rado

radinsky
Posts: 12
Joined: Tue Dec 04, 2018 6:07 am

Re: Initial Support for Moravian Instruments Cameras

Post by radinsky » Thu Jun 06, 2019 9:22 am

Mate, you're a legend.

After this update camera works almost perfect.

Only two problems I found.

- as soon as I change exposure to more that one second the program crashes but anything below one second exposure it works fine.

-fan doesn't move in fast exposure 0.13ms or around but as I increase exposure it speeds up gradually

Rado

User avatar
admin
Site Admin
Posts: 2866
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Initial Support for Moravian Instruments Cameras

Post by admin » Thu Jun 06, 2019 8:53 pm

Hi,

Glad to hear that we are getting there. When the programme crashed because of taking exposures longer than one second, did you submit the bug reports from the crashes? I just had a look and can't see any uploaded bug reports that match your description, but it would be nice to have them as it might let me work out what is going wrong in that particular case.

The current code uses a different method to grab the frame when the exposure is above one second – the longer exposure version of the code gives me the option to cancel the frame if necessary and seems to work with the cameras I have here but is most likely what is causing the issue you are seeing some reason.

Cheers, Robin

radinsky
Posts: 12
Joined: Tue Dec 04, 2018 6:07 am

Re: Initial Support for Moravian Instruments Cameras

Post by radinsky » Fri Jun 07, 2019 9:52 am

I submitted the bug report, today.

User avatar
admin
Site Admin
Posts: 2866
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Initial Support for Moravian Instruments Cameras

Post by admin » Fri Jun 07, 2019 8:36 pm

Thank you,

I can see where the problem is occurring and I have an idea that might be a possible fix which I will try the next update.

Cheers, Robin

radinsky
Posts: 12
Joined: Tue Dec 04, 2018 6:07 am

Re: Initial Support for Moravian Instruments Cameras

Post by radinsky » Thu Jun 20, 2019 12:08 pm

Hi Robin.

We getting there. Thanks so much.

There is no more problem with longer exposure setting.

It works perfect, now I have only two problems.

I attached picture taken with same exposure of the moon.

One is by original software from Moravian and the second picture taken with Sharpcap.

With Sharpcap my picture is very grainy with any exposure time selected.

I can't even get clear picture of the moon .

Not sure what it is or what needs to be adjusted, there is no gain control available.

Second problem is the fan only works on long exposures it doesn't work on short exposures.

Rado
Attachments
moon sharpcap.jpg
moon sharpcap.jpg (1022.35 KiB) Viewed 403 times
moon.jpg
moon.jpg (53.29 KiB) Viewed 403 times

User avatar
admin
Site Admin
Posts: 2866
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Initial Support for Moravian Instruments Cameras

Post by admin » Thu Jun 20, 2019 8:04 pm

Hi,

It almost looks like the data is being byte swapped with the low and high byte of each pixel being transposed. Could you grab an image in fits format and share it with me as that would give me a chance to look at the data in detail and see if I can confirm that suspicion.

Cheers, Robin

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests