SharpCap does not recognise Flee3 cameras

Post Reply
rincewind
Posts: 5
Joined: Sun Apr 23, 2017 6:10 pm

SharpCap does not recognise Flee3 cameras

Post by rincewind » Sun Apr 23, 2017 6:22 pm

I have downloaded the prerequisite file for Point Grey cameras and I have tried 2.10 and 3.0 beta they both provide the following error message

Object reference not set to an instance of an object

I have restarted to Camera and SharpCap but still the same. I checked with Fire capture and it works OK

User avatar
admin
Site Admin
Posts: 2074
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SharpCap does not recognise Flee3 cameras

Post by admin » Sun Apr 23, 2017 7:40 pm

Ah, interesting...

looking over the log from your bug report I can see this entry near the top

Code: Select all

FlyCapture2Managed.FC2Exception: Unsupported Hardware Interface.
That's telling me that SharpCap isn't able to talk to your PointGrey camera directly, so you are ending up using the camera via the DirectShow driver. So... We have two bugs to work out

1) Why can't SharpCap talk to your PGR camera directly?
2) Why does the Directshow driver crash when talking to it.

I think I know the answer to bug 2) and will attempt to fix it.

Bug 1) is more interesting. Can you share the exact model number of your camera and check the version of the Point Grey camera drivers you have installed? I think that SharpCap will need drivers 2.4.3 or newer (according to this https://www.ptgrey.com/KB/10275). Also there are two Point Grey programming SDKs and SharpCap only supports one of them (FlyCapture). If your camera only supports the other (Spinnaker) then this might cause problem 1).

thanks,

Robin

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests