SharpCap 4.1 - Laggy Live View, issue vanishes when using SharpCap 4.0 or FireCapture

A place to report problems and bugs in SharpCap
Forum rules


If you have a problem or question, please check the FAQ to see if it already has an answer : https://www.sharpcap.co.uk/sharpcap-faqs

Please also read about Troubleshooting USB Issues before posting.

*** Please do not post license keys - please report any problems with licensing to 'admin' by private message ***

Please include the following details in any bug report:

* Version of SharpCap
* Camera and other hardware being user
* Operating system version
* Contents of the SharpCap log after the problem has occurred.
[If SharpCap crashes, please send the bug report when prompted instead of including the log]
Post Reply
SerApollyon
Posts: 2
Joined: Tue Jun 11, 2024 6:17 am

SharpCap 4.1 - Laggy Live View, issue vanishes when using SharpCap 4.0 or FireCapture

#1

Post by SerApollyon »

Hello everyone!

first of all I apologize if this isn't the correct part of the forum to put this in.
I'm currently getting into solar photography with SharpCap 4.1, and I seem to be having one particular issue.

The "live view" in 4.1 is being very laggy and stuttery, and sometimes freezing up to 1-2 seconds even though it says I'm having ~65.5fps.
Example: https://www.youtube.com/watch?v=YbDRdX5v_p0

First of all my specs:
PC
Beelink Mini S12 Pro
Intel Alder Lake-N100
16GB DDR4 RAM
500GB M.2 SSD

Camera & Co
ZWO ASI 174MM, connected via USB 3.0

SharpCap 4.1
v4.1.12243, 64 bit
Both "High Speed Frame Cache" and "Live Stacking & Display" have around 4GB allocated (8GB in total)


The things I've tried so far that were unsuccessful:
- I tested around with allocating more or less RAM to the two settings mentioned above (1GB:8GB, 8GB:1GB, etc.)
- Removed all settings from the "Preprocessing" option
- Changed the Capture Area to the smallest setting and the Colour Space to MONO8
- Connected the camera via ASCOM to SharpCap (even though that makes it slower, not faster)
- Played around with the "High Speed Mode"; turning it off, turning it on, setting it to every number from 0 to 100
- Switched the USB 3.0 cable from a port of my Pegasus Powerbox Advance to a 3.0 port of my mini PC
- Connected all my equipment directly to a laptop, to rule out that Windows Remote Desktop is causing the issue
- "Repaired" SharpCap via the function that pops up when you try to uninstall it
- Uninstalled and reinstalled SharpCap
- Uninstalled and reinstalled my camera drivers
- I held "CTRL" while connecting the camera to connect it with the default settings

Things I've tried that were sort of successful but not really:
- Using FireCapture v2.6.08, 64 bit instead
In FireCapture the Live View seems to have no issues at all, which I think rules out my hardware being the issue.
Example: https://youtu.be/3NE3ur24wzA

- Using SharpCap 4.0, v4.0.9571, 64 bit instead
This actually did fix the stuttering and freezing, even though it's still a bit jittery.
Example: https://youtu.be/9_mM90YQLO4

Since it seems to work fine in both SharpCap 4.0 and FireCapture, I'd assume it's an issue with SharpCap 4.1?
I'm not quite sure honestly, so I hope somebody else could share some insight or advice.

If any other specifications or files (like logs for example) are needed, please let me know. (:

I've only now seen the forum post "Troubleshooting USB Issues" which I will give a shot once I have time to do so.
If I see any improvements or fixes from applying those tips I'll update this post.
User avatar
admin
Site Admin
Posts: 13710
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: SharpCap 4.1 - Laggy Live View, issue vanishes when using SharpCap 4.0 or FireCapture

#2

Post by admin »

Hi,

sounds like you have already made a good job of trying to track down the cause of the issue. I suspect that it may be to do with the graphics card/drivers on your PC, so there are some things to check...

*) Check the graphics drivers are installed and up to date. The source for the latest version for you will probably be Intel, since you will be using the on CPU built in graphics of the N100 processor (I think). In particular, if you have never installed graphics drivers, you may have the 'Microsoft Basic' graphics driver, which will need replacing with the Intel one

*) Test SharpCap with both settings for 'Use Graphics card acceleration' in the first page of the settings. Usually better to have this on, but if the graphics drivers are causing issues, having it turned off may actually help.

*) Test without remote desktop initially to keep things simple - go back to remote desktop if you get a good improvement with an actual monitor attached to check that remote desktop is also improved

*) Test using the SharpCap 'Test Camera 2 (High Speed)'. This simulated camera will remove any possibility of it being related to the performance of your real camera. You can turn on 'Random Offset' to make the Jupiter image jump around a bit so you can see how often it updates. If you turn down the exposure the frame rate should rise abouve the default 20fps (turn up gain to keep the image bright enough to see).

Things that are unlikely to cause this sort of problem : memory settings, problems with the SharpCap install, camera drivers, etc.

Hope that the steps above help you find out a bit more about what is going wrong.

cheers,

Robin
SerApollyon
Posts: 2
Joined: Tue Jun 11, 2024 6:17 am

Re: SharpCap 4.1 - Laggy Live View, issue vanishes when using SharpCap 4.0 or FireCapture

#3

Post by SerApollyon »

Hello Robin,

thank you so much for the suggestions!

I will try these tips, including the ones in the "Troubleshooting USB Issues" post, once I get some imaging time again.
Hopefully some of those will fix the issue. :D
Post Reply