Issue with 64bit Version (Crash after starting the Program)

A place to report problems and bugs in SharpCap
Forum rules


If you have a problem or question, please check the FAQ to see if it already has an answer : https://www.sharpcap.co.uk/sharpcap-faqs

Please also read about Troubleshooting USB Issues before posting.

*** Please do not post license keys - please report any problems with licensing to 'admin' by private message ***

Please include the following details in any bug report:

* Version of SharpCap
* Camera and other hardware being user
* Operating system version
* Contents of the SharpCap log after the problem has occurred.
[If SharpCap crashes, please send the bug report when prompted instead of including the log]
mhedenus
Posts: 6
Joined: Sun Jan 21, 2024 3:36 pm

Re: Issue with 64bit Version (Crash after starting the Program)

#11

Post by mhedenus »

Dear Robin,

sorry - it still does not work. I tried SharpCapInstall-4.1.11757.0.exe (32 bit) but it crashed. I created a full crash dump:

https://www.hedenus.de/astro/sharpcap/S ... 58.dmp.zip

Also, I do not have a second computer to test on.


Greetings

Michael
Seginus
Posts: 6
Joined: Mon Nov 13, 2023 8:46 pm

Re: Issue with 64bit Version (Crash after starting the Program)

#12

Post by Seginus »

Dear Robin

I just come back to this older post. In the meantime I tried various things, but unfortunaltely the issue with the 64bit version is still not solved.

As you wrote in the last message, I have deleted all the DLL's you listed and run SharpCap directly from the installation folder. Unfortunately this did not solve the problem. I also completely unistalled SC and removed also some remaining files and reinstalled everything (also earlier v4.1 versions) but the 64-bit program is still crashing after the start.

To summarize the situation:

- Version 4.1.12174.0 (64-bit) (the latest Version): is crashing after startup
- Version 4.1.10970.0 (64-bit) (the first 4.1 Version): is crashing after startup
- Version 4.0.9571.0 (64-bit) (the last 4.0 Version): is crashing after startup

- Version 4.1.12174.0 (32-bit) (the latest Version): is working

If I start first the 32-bit version, which is working, close it and start then the 4.0 64-bit version, the program will not crash immediately after the startup. I can do a few "clicks" in the program until it also crashes.

Any idea, what can be done to further narrow down this problem?

Regards,
Stefan
User avatar
admin
Site Admin
Posts: 13529
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Issue with 64bit Version (Crash after starting the Program)

#13

Post by admin »

Hi Stefan,

this is a tricky one now, since we have already determined that something is corrupting memory not long after SharpCap starts, and that corruption is eventually killing SharpCap (but only the 64 bit version).

Since it is not an issue that is happening widely, it's going to be something specific to your system that is the underlying cause of the issue - this could, in theory, be either hardware or software.

Hardware seems unlikely - in theory glitchy memory could cause this, but it would happen to other programs and it would be strange for it to only affect the 64 bit version.

Software is much more likely - some applications helpfully put their code into every program that runs on Windows (security software like antivirus often does this, but other software can too). Any small mistakes in the code of the application that is doing this can cause seemingly random crashes in applications like SharpCap - the crash depends on whether the code in SharpCap performs actions that trigger the bug in the security software.

The way I would attack a problem like this is to try to get two systems set up - one that breaks and one that works (maybe using a second PC if you have one). Then gradually change the working PC to make the software installed on it more and more similar to the broken PC, testing each time. If there is a software clash then at some point you will install the software that clashes with SharpCap and the next time you test, SharpCap will crash on the 'good PC'. Unfortunately that's a long-winded approach and not even guaranteed to work (you might get different, newer versions of the software on the second PC which might not cause the issue).

cheers,

Robin
Post Reply