Artifacts with dark frame subtraction

Discussion of using SharpCap for Deep Sky Imaging
User avatar
admin
Site Admin
Posts: 1879
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Artifacts with dark frame subtraction

Post by admin » Wed Aug 15, 2018 6:18 am

Hi,

thanks for those! When I load the M92 image into the SharpCap test camera and then subtract the dark I only see one oddly coloured (blue) pixel. I think I understand the cause of the blue pixel - it is a bug in the way that the hot pixel correction works when you use the camera in RGB mode, so I can correct that in a future version of SharpCap. What I am not seeing is the long lines of oddly coloured pixels that show in your M15 image - do you have sample frames and darks from that?

For now, using the camera in RAW mode should avoid the oddly coloured hot pixel problem, but may not avoid the lines of oddly coloured pixel problem.

thanks,

Robin

RickEvans10473
Posts: 10
Joined: Mon Mar 26, 2018 1:35 pm

Re: Artifacts with dark frame subtraction

Post by RickEvans10473 » Wed Aug 15, 2018 1:57 pm

Hi Brian,

"It appears that the artifacts are only happening on the brightest stars. Perhaps the camera's pixel scale and the telescope's focal length have led to severe undersampling. SC could be misinterpreting stars as hot pixels. The pixel size is 4.63 um so if the telescope is relatively short this could explain it. Is there a setting in the dialog to turn off hot pixel detection?"

The problem images were acquired at ~F/7(1400 mm) Prior to acquiring the ASI294MC Pro I had an ASI174MC-COOL which died twice under warranty. I acquired the ASI294MC Pro thanks to a credit issued by the vendor. Even with its larger 4.86 um pixels, 2x2 binning and often imaging at ~F/4(800 mm), I never encountered these artifacts imaging with the ASI174 and using live dark frame subtraction. That said, I was using SharpCap 2.9 which unfortunately did not recognize the ASI294 :(

Rick

User avatar
oopfan
Posts: 299
Joined: Sat Jul 08, 2017 2:37 pm
Location: New York
Contact:

Re: Artifacts with dark frame subtraction

Post by oopfan » Wed Aug 15, 2018 3:18 pm

Hi Rick,

"The problem images were acquired at ~F/7(1400 mm)" -- undersampling is definitely not a problem.

Sorry to hear about your broken ZWO cameras. My first camera was an ASI120MC. It lasted all of 6 months. I still use it for PA but it hangs if left on for more than 30 minutes. Now I've got an uncooled Altair 290M as my imaging camera. Good quality but it doesn't have a built-in temperature sensor. I've tried various methods of acquiring dark frames before and after lights and then mixing them together in the master dark but with these warm summertime temperatures you can get a wide swing during the course of a night. When I was using the ASI120 for imaging it had a temperature sensor so I was able to build a dark library that I would carefully match against the temperature of my lights. It was additional work but I got some very good results. I don't want to give up on my Altair camera yet. I just finished building an Arduino-based high precision temperature logger. I am in the process now of acquiring a darks library. The weather has been terrible for over a month so not much imaging going on.

Brian

User avatar
turfpit
Posts: 312
Joined: Mon Feb 13, 2017 8:13 pm
Location: UK
Contact:

Re: Artifacts with dark frame subtraction

Post by turfpit » Wed Aug 15, 2018 3:37 pm

I have found the CCD Suitability Calculator at astronomy.tools useful.

Dave

User avatar
admin
Site Admin
Posts: 1879
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Artifacts with dark frame subtraction

Post by admin » Wed Aug 15, 2018 8:44 pm

Hi,

please retest with 3.2.5696 when you have a chance - I have made significant changes to the dark subtraction code that I think will reduce or eliminate this type of artifact. There are a lot of different cases to cover in the dark subtraction, so I hope I (a) found them all and (b) changed them all correctly!

cheers,

Robin

RickEvans10473
Posts: 10
Joined: Mon Mar 26, 2018 1:35 pm

Re: Artifacts with dark frame subtraction

Post by RickEvans10473 » Thu Aug 16, 2018 3:33 pm

"Hi,
please retest with 3.2.5696 when you have a chance - I have made significant changes to the dark subtraction code that I think will reduce or eliminate this type of artifact. There are a lot of different cases to cover in the dark subtraction, so I hope I (a) found them all and (b) changed them all correctly!"

Hi Robin,

I tried the 3.2.5696 beta last night with mixed results due to my possible error. The error is I used an R=60 B=60 dark frame for R=55 B=55 light frames. Even with that there are no artifacts. Before celebrating I want to do more testing when I catch a rare clear night during this period of East Coast humid, hazy, wet East Coast weather.

M29
22_49_g3_ap32.jpg
22_49_g3_ap32.jpg (579.12 KiB) Viewed 162 times

User avatar
admin
Site Admin
Posts: 1879
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Artifacts with dark frame subtraction

Post by admin » Thu Aug 16, 2018 4:15 pm

Well, that looks promising - good luck getting some clear skies and do let me know of any glitches/problems that you come across.

thanks,

Robin

RickEvans10473
Posts: 10
Joined: Mon Mar 26, 2018 1:35 pm

Update Re: Artifacts with dark frame subtraction

Post by RickEvans10473 » Thu Aug 23, 2018 1:47 pm

Hi Robin,

For the first time since since last posting I got a clear, albeit moon lit, night here in the US Mid Atlantic States. I was able to test the dark frame subtraction on M13 and M27 in RGB24 mode using Version 3.2 The good news is there were no artifacts when using Version 3.2 .To be sure I used the same settings and dark frame using Version 3.1 and the artifacts were present demonstrating the efficacy of your fixes.

I have not tested with RAW16 but plan to once I refamiliarize myself with the extra-processing steps.

User avatar
admin
Site Admin
Posts: 1879
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Artifacts with dark frame subtraction

Post by admin » Thu Aug 23, 2018 5:38 pm

Hurrah! Glad it worked for you :)

Robin

RickEvans10473
Posts: 10
Joined: Mon Mar 26, 2018 1:35 pm

Re: Artifacts with dark frame subtraction

Post by RickEvans10473 » Sun Aug 26, 2018 10:00 pm

Hi Robin,

As promised I tested dark frame subtraction using the Raw16 color space and there were no artifacts.

I have not had a chance to play with the live flat frame subtraction but did use SharpCap to generate.

I have a few questions about version 3.2.

I see it's beta and expires on September 30. I have a paid for license that expires in 2019. Does the 9/30 expiration date mean it won't expire or is there a stable version of the product with all the bug fixes that I'm missing.

Rick Evans

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest