Images Deleted

A place to report problems and bugs in SharpCap
Forum rules
Please read about Troubleshooting USB Issues before posting.

*** Please do not post license keys - please report any problems with licensing to 'admin' by PM ***

Please include the following details in any bug report:

* Version of SharpCap
* Camera and other hardware being user
* Operating system version
* Contents of the SharpCap log after the problem has occurred.
[If SharpCap crashes, please send the bug report when prompted instead of including the log]
Post Reply
Graham6846
Posts: 1
Joined: Thu Jul 06, 2017 8:22 am

Images Deleted

Post by Graham6846 » Thu Jul 06, 2017 8:36 am

Hi Guys
Help Req. Taking some single shots of M57 , took 12 shots all PNG files , viewed then didn't like one so deleted that one , noticed I was just using Laptop Batt. so plugged in mains
Next time tried to view files ALL gone including support txt files .
Not in recycling but earlier deleted file was
Searched entire laptop -- can't see them anywhere
The capture folder still there but all 11 files gone ?

Kind Regards Graham

User avatar
admin
Site Admin
Posts: 3098
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Images Deleted

Post by admin » Thu Jul 06, 2017 5:33 pm

Hi Graham,

Ian at Altair Astro passed on your issue to me earlier today and I had a look at the code and did indeed find a bug with the use of the 'Delete Last Capture' option in the 'Capture' menu which could cause a whole folder of captures to be deleted if it was used after taking multiple snapshots. However, I'd expect that to have deleted the folder too and I understand that you didn't use that function in this case but deleted the one file using Windows Explorer.

If you used the 'delete last capture' option and it deleted all your images then I can only apologize. I will be fixing this issue and releasing an updated build ASAP to make sure it doesn't happen to anyone else.

If you deleted the one file with Windows explorer and all the rest vanished then I am very confused and I don't really have any ideas that might help - it seems that you have checked the recycle bin and elsewhere on the laptop hard disk without any success. There may still be utilities available that can undelete (recover) deleted files - there certainly used to be back in MSDOS days, but I don't know if there still are. It may be worth looking into, but I have not used such a thing for 20 odd years...

cheers,

Robin

felipesg
Posts: 16
Joined: Mon Jun 19, 2017 10:29 pm

Re: Images Deleted

Post by felipesg » Thu Jul 06, 2017 5:51 pm

Hi Graham,

You can try with Recuva, its a free utility from Piriform to "try" to recover deleted files.

There is a portable version.

https://www.piriform.com/recuva/feature ... le-version

Cheers

User avatar
admin
Site Admin
Posts: 3098
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Images Deleted

Post by admin » Thu Jul 06, 2017 9:42 pm

The "Delete Last Capture" bug is fixed in build 3.0.4002

cheers,

Robin

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests