Sharpcap 3.1 -3.2 vs 2.9 low performances

A place to report problems and bugs in SharpCap
Forum rules
Please read about Troubleshooting USB Issues before posting.

*** Please do not post license keys - please report any problems with licensing to 'admin' by PM ***

Please include the following details in any bug report:

* Version of SharpCap
* Camera and other hardware being user
* Operating system version
* Contents of the SharpCap log after the problem has occurred.
[If SharpCap crashes, please send the bug report when prompted instead of including the log]
Post Reply
Fabioibirru
Posts: 2
Joined: Fri Sep 21, 2018 2:49 pm

Sharpcap 3.1 -3.2 vs 2.9 low performances

Post by Fabioibirru » Fri Sep 21, 2018 9:52 pm

Dear all,
I use in the field a Lattepanda win 10 mini pc 4/64 Gb.

Using sharpcap 2.9 I can achieve 78-80 fps, (8 bit, 1936x1020) using an ASI 174 MM. Using USB3 and a 2 Gb ramdisk

Using sharpcap 2.9 I can achieve 42 fps, (16 bit, 1936x1020) using an ASI 174 MM. Using USB3 and a 2 Gb ramdisk

Using sharpcap 3.1-3.2 I can achieve just 30 fps, (8 bit, 1936x1020) using an ASI 174 MM. Using USB3 and a 2 Gb ramdisk

Using sharpcap 2.9 I can achieve just 24 fps, (16 bit, 1936x1020) using an ASI 174 MM. Using USB3 and a 2 Gb ramdisk

Any idea about?

Thanks

User avatar
admin
Site Admin
Posts: 2009
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Sharpcap 3.1 -3.2 vs 2.9 low performances

Post by admin » Sat Sep 22, 2018 2:42 pm

Hi,

I don't have a machine of similar spec to test on, but on a normal desktop machine I get the expected high frame rates with the ASI174MC - previewing at 150fps and capturing at 140fps+ to SSD. This makes it likely that the slowdown you are seeing is due to the lower specs of your mini PC.

I think it is most likely that you are hitting problems with memory exhaustion with the newer versions of SharpCap - they use a more sophisticated way to allocate memory for frames and can use up to 2Gb of memory in the default settings on 64 bit windows. Add to that your 2Gb ram disk and you are not leaving any left over for the operating system.

Try changing SharpCap back to the 'classic' memory management mode and see if that helps - https://docs.sharpcap.co.uk/3.2/#Memory%20Tab

Also, I'm not sure that capturing to a ram disk is a good test of performance - particularly on a machine with moderately low memory. Unless your actual use case for imaging involves capturing to ram disk and then copying later that is. Note that SharpCap 3.0 and later versions are more aggressive at using system memory to keep frames cached while waiting for them to be written to disk, so a slow SSD/Hard Disk causes less dropped frames (at least until the in-memory cache fills up).

hope this helps,

Robin

Fabioibirru
Posts: 2
Joined: Fri Sep 21, 2018 2:49 pm

Re: Sharpcap 3.1 -3.2 vs 2.9 low performances

Post by Fabioibirru » Tue Sep 25, 2018 12:22 pm

Thanks Robin,

I will try and report back my experience

Fabio

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest