Sync issues after Plate Solving

A place to report problems and bugs in SharpCap
Forum rules
Please read about Troubleshooting USB Issues before posting.

*** Please do not post license keys - please report any problems with licensing to 'admin' by PM ***

Please include the following details in any bug report:

* Version of SharpCap
* Camera and other hardware being user
* Operating system version
* Contents of the SharpCap log after the problem has occurred.
[If SharpCap crashes, please send the bug report when prompted instead of including the log]
nm1213
Posts: 33
Joined: Mon Feb 19, 2018 1:47 am

Re: Sync issues after Plate Solving

Post by nm1213 » Sat Sep 08, 2018 7:42 am

Sure, thanks Robin. Will do.

Any chance you can relax the near plate solving parameters beyond 15 degrees for this test? It will allow me to blind solve and sync with photos from previous sessions, and also test during the day. The monsoons have started, so it now rains most nights.

N.

nm1213
Posts: 33
Joined: Mon Feb 19, 2018 1:47 am

Re: Sync issues after Plate Solving

Post by nm1213 » Mon Sep 10, 2018 12:31 am

Hi Robin,

I've tried the latest beta against the mount. There are two firmware versions, one of which allows EQ and Alt-AZ, and another that only allows Alt-AZ. The firmware loaded here is exclusively for Alt-AZ. The log files show the following:

Debug: 08:22:15.0029126 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Started
Info: 08:22:15.0029126 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Creating ASCOM Telescope mount of type ASCOM.SynScanMobile.Telescope ('SynScanMobile Telescope')
Debug: 08:22:15.3565218 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Ended
Info: 08:22:15.3575216 Thread:#1 SharpCap.Models.ConnectableHardware.OnConnectedChanged() :: Mount 'SynScanMobile Telescope' now Conneted:True
Info: 08:22:20.9750127 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.TryConnect() :: The mount claims to be SynScanMobile Telescope, SynScanMobile Telescope 1.2.2, SynScanMobile Telescope, 1.2.2
Info: 08:22:21.0089629 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.TryConnect() :: The mount reports an alignment mode of algAltAz

I think that's what you were looking for. However, here is the full log:

Info: 08:21:51.5296630 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: SharpCap Version 3.2.5747.0
Info: 08:21:51.5296630 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: GC Memory 116Mb
Info: 08:21:51.5452873 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Process Memory 148Mb
Info: 08:21:51.5452873 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Total Physical Memory 3994Mb
Info: 08:21:51.5452873 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Available Physical Memory 383Mb
Info: 08:21:51.5452873 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Operating System : Microsoft Windows NT 6.2.9200.0
Debug: 08:21:51.7484255 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Started
Info: 08:21:51.8734393 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type BaslerDeviceEnumerator
Info: 08:21:51.8734393 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type QHYDeviceEnumerator
Info: 08:21:51.8734393 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type ASIDeviceEnumerator
Info: 08:21:51.8734393 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AltairDeviceEnumerator
Info: 08:21:52.0140710 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type PointGreyDeviceEnumerator
Info: 08:21:52.0140710 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type SxDeviceEnumerator
Info: 08:21:52.0297017 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Altair.dll
Info: 08:21:52.0297017 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.ASCOMCamera.dll
Info: 08:21:52.0297017 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.ASI.dll
Info: 08:21:52.0297017 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Basler.dll
Info: 08:21:52.0297017 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Celestron.dll
Info: 08:21:52.0453232 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.DS3.dll
Info: 08:21:52.0453232 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Fake.dll
Info: 08:21:52.0453232 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.INova.dll
Info: 08:21:52.0453232 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.NewDirectShow.dll
Info: 08:21:52.0453232 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.PointGrey.dll
Info: 08:21:52.0453232 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.QHY.dll
Info: 08:21:52.0609511 Thread:#1 SharpCap.MultiCaptureProvider.AddProvidersByReflection(String[] providerNames) :: Added device enumerator of type CelestronDeviceEnumerator
Info: 08:21:52.0609511 Thread:#1 SharpCap.MultiCaptureProvider.AddProvidersByReflection(String[] providerNames) :: Added device enumerator of type iNovaDeviceEnumerator
Info: 08:21:52.0609511 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type DS3DeviceEnumerator
Info: 08:21:52.0609511 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AscomDeviceEnumerator
Info: 08:21:52.0609511 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type FolderMonitorDeviceEnumerator
Info: 08:21:52.0609511 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type FakeDeviceEnumerator
Info: 08:21:52.7172473 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: CPU : Intel(R) Atom(TM) x5-Z8350 CPU @ 1.44GHz with 4 cores.
Info: 08:21:53.2172810 Thread:#1 SharpCap.Base.Utilities.Logger.LogStackTrace(LogLevel level, String msg) :: Parent being changed on PreviewPanel
at SharpCap.UI.ScrollZoomForm.OnParentChanged(Object sender, EventArgs eventArgs)

Debug: 08:21:54.0454619 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Ended
Debug: 08:21:54.4245659 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Started
Debug: 08:21:54.4275648 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Ended
Debug: 08:21:54.4975787 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Started
Info: 08:21:54.7295897 Thread:#1 SharpCap.SharpCapApp.get_ForceSoftwareRendering() :: WPF Rendering tier is 0
Debug: 08:21:57.3584511 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Timebomb checked
Debug: 08:21:57.3740704 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Started
Debug: 08:21:57.4053205 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Ended
Info: 08:21:57.6553352 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: QHYCameraFinder - found 0 cameras
Info: 08:21:57.7334661 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: FindCameras - found 0 cameras
Info: 08:21:58.8585446 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: ASI Camera (1) (ASCOM Cameras)
Info: 08:21:58.8585446 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: ASI Camera (2) (ASCOM Cameras)
Info: 08:21:58.8585446 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Camera V2 simulator (ASCOM Cameras)
Info: 08:21:58.8585446 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Folder Monitor Camera (Virtual Cameras)
Debug: 08:21:58.8741739 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Started
Debug: 08:21:58.8741739 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Ended
Info: 08:21:58.8741739 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 1 (Deep Sky) (Test Cameras)
Info: 08:21:58.8741739 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 2 (High Speed) (Test Cameras)
Debug: 08:21:59.1085629 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Docking setup
Debug: 08:21:59.1085629 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Startup scripts (if any) run
Debug: 08:21:59.1085629 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Menu updated
Debug: 08:22:04.5777022 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Splash and tips done
Debug: 08:22:04.7964690 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Ended
Error: 08:22:04.8120926 Thread:#1 SharpCap.Base.Utilities.Logger.Error(Exception e, String action, String additionalInfo, Boolean stackTrace) :: Exception from Downloading license update list : The remote name could not be resolved: 'downloads.sharpcap.co.uk'
Info: 08:22:13.9846094 Thread:#1 SharpCap.Models.Application+<>c__DisplayClass39_0.<set_SelectedCamera>b__0() :: Changing camera from none to Test Camera 1 (Deep Sky)
Info: 08:22:14.0939925 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: OpeningDevice event received in UI thread
Debug: 08:22:14.1096175 Thread:#1 SharpCap.MultiCaptureProvider.OpenDevice(DeviceTagData deviceTag) :: Opening device : Test Camera 1 (Deep Sky) (via Test Cameras)
Info: 08:22:14.1252433 Thread:#1 SharpCap.Base.CaptureProviderBase`1.OpenDevice(DeviceTagData dtd) :: Started
Debug: 08:22:14.1252433 Thread:#1 SharpCap.Base.SimpleCaptureProvider.SetupDevice(DeviceTagData dtd) :: Started
Debug: 08:22:14.1408761 Thread:#1 SharpCap.Base.SimpleCaptureProvider.SetupDevice(DeviceTagData dtd) :: Ended
Info: 08:22:14.1564947 Thread:#1 SharpCap.Base.CaptureProviderBase`1.CreateCaptureControl() :: Started
Debug: 08:22:14.1564947 Thread:#1 SharpCap.Base.SimpleCaptureProvider.GetControls() :: Started
Info: 08:22:14.2033741 Thread:#1 SharpCap.Base.ColourSpacePropertyControl..ctor(IEnumFeature mainFeature, List`1 colourSpaces, IPreviewControl previewControl) :: Colour space RGB32 is valid.
Info: 08:22:14.2033741 Thread:#1 SharpCap.Base.ColourSpacePropertyControl..ctor(IEnumFeature mainFeature, List`1 colourSpaces, IPreviewControl previewControl) :: Colour space MONO8 is valid.
Info: 08:22:14.2033741 Thread:#1 SharpCap.Base.ColourSpacePropertyControl..ctor(IEnumFeature mainFeature, List`1 colourSpaces, IPreviewControl previewControl) :: Colour space MONO16 is valid.
Info: 08:22:14.2033741 Thread:#1 SharpCap.Base.ColourSpacePropertyControl..ctor(IEnumFeature mainFeature, List`1 colourSpaces, IPreviewControl previewControl) :: Colour space RAW16 is valid.
Info: 08:22:14.2033741 Thread:#1 SharpCap.Base.ColourSpacePropertyControl..ctor(IEnumFeature mainFeature, List`1 colourSpaces, IPreviewControl previewControl) :: Colour space RAW8 is valid.
Info: 08:22:14.4377667 Thread:#1 SharpCap.Base.Memory.Allocator.NumberOfMegabytesToMap() :: Paged memory disabled by user option
Info: 08:22:14.6409056 Thread:#1 SharpCap.Base.CaptureProviderBase`1.CreateCaptureControl() :: Ended
Info: 08:22:14.6409056 Thread:#1 SharpCap.Base.CaptureProviderBase`1.OpenDevice(DeviceTagData dtd) :: Ended
Debug: 08:22:14.6409056 Thread:#1 SharpCap.Models.Camera.ApplyDefaultProfile() :: Started
Info: 08:22:14.7346629 Thread:#1 SharpCap.MultiCaptureProvider.StartPreview() :: Starting preview on Test Camera 1 (Deep Sky)
Info: 08:22:14.7482932 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StartPreview() :: Started
Info: 08:22:14.7709066 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StartPreview() :: Starting Preview on Test Camera 1 (Deep Sky), 1936x1096, Mono, 8bits
Debug: 08:22:14.7849081 Thread:#1 SharpCap.Base.BaseImageProvider.Start() :: Started
Debug: 08:22:14.8119070 Thread:#1 SharpCap.Base.CameraProxyBase.StartPreview() :: Started
Debug: 08:22:14.8199073 Thread:Grab Thread#20 SharpCap.Base.CameraProxyBase.GrabThreadProc() :: Started
Debug: 08:22:14.9619129 Thread:#1 SharpCap.Base.CameraProxyBase.StartPreview() :: Ended
Debug: 08:22:14.9659201 Thread:#1 SharpCap.Base.BaseImageProvider.Start() :: Ended
Info: 08:22:14.9749117 Thread:#1 SharpCap.MultiCaptureProvider.SendCaptureEvent(Object sender, CaptureEventArgs e) :: Capture Event : StartPreview
Debug: 08:22:15.0029126 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Started
Info: 08:22:15.0029126 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Creating ASCOM Telescope mount of type ASCOM.SynScanMobile.Telescope ('SynScanMobile Telescope')
Debug: 08:22:15.3565218 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Ended
Info: 08:22:15.3575216 Thread:#1 SharpCap.Models.ConnectableHardware.OnConnectedChanged() :: Mount 'SynScanMobile Telescope' now Conneted:True
Info: 08:22:20.9750127 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.TryConnect() :: The mount claims to be SynScanMobile Telescope, SynScanMobile Telescope 1.2.2, SynScanMobile Telescope, 1.2.2
Info: 08:22:21.0089629 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.TryConnect() :: The mount reports an alignment mode of algAltAz
Debug: 08:22:21.0299663 Thread:#1 SharpCap.UI.WPFControlForm.InitControls(CaptureControl captureControl, String deviceName) :: Started
Debug: 08:22:21.1329640 Thread:#1 SharpCap.UI.WPFControlForm.InitControls(CaptureControl captureControl, String deviceName) :: Ended
Info: 08:22:21.3889744 Thread:#1 SharpCap.Models.Transforms.set_SelectedTransform(Transform value) :: Selecting transform None
Info: 08:22:21.4039743 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: StartPreview event received in UI thread
Info: 08:22:21.4159733 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StartPreview() :: Ended
Info: 08:22:21.9050862 Thread:#1 SharpCap.Base.PropertyControls.BasePropertyControl`2.BeforeValueChange(Object newValue) :: Stopping preview to change Capture Area from 1936x1096 to 1936x1096
Info: 08:22:21.9080893 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StopPreview() :: Started
Debug: 08:22:21.9110896 Thread:#1 SharpCap.Base.BaseImageProvider.Stop() :: Started
Debug: 08:22:21.9120894 Thread:#1 SharpCap.Base.CameraProxyBase.StopPreview() :: Started
Debug: 08:22:21.9130893 Thread:Grab Thread#20 SharpCap.Base.CameraProxyBase.GrabThreadProc() :: Ended
Debug: 08:22:21.9150904 Thread:#1 SharpCap.Base.CameraProxyBase.StopPreview() :: Ended
Debug: 08:22:22.1660993 Thread:#1 SharpCap.UI.Hardware.MountControl..ctor(Mount model) :: Started
Debug: 08:22:22.1780969 Thread:#1 SharpCap.ViewModels.MountViewModel..ctor(Mount model) :: Started
Info: 08:22:22.2241008 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Axis 0 has 1 slew rates.
Info: 08:22:22.2281002 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Slew rates are : 0-960
Info: 08:22:22.2320997 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Axis 1 has 1 slew rates.
Info: 08:22:22.2331009 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Slew rates are : 0-960
Info: 08:22:22.2671017 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRates() :: Testing slew rates for availability : 1, 4, 16, 60, 120, 240, 480, 720, 960, 1920, 4800, 9600, 12000
Info: 08:22:22.2781015 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 1920 is not allowed for axis 0
Info: 08:22:22.2800998 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 4800 is not allowed for axis 0
Info: 08:22:22.2810996 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 9600 is not allowed for axis 0
Info: 08:22:22.2821002 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 12000 is not allowed for axis 0
Info: 08:22:22.2840999 Thread:#1 SharpCap.ViewModels.MountViewModel.CreateRates() :: SynScanMobile Telescope has 9 available slew rates.
Info: 08:22:22.3501017 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Axis 0 has 1 slew rates.
Info: 08:22:22.3511015 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Slew rates are : 0-960
Info: 08:22:22.3551016 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Axis 1 has 1 slew rates.
Info: 08:22:22.3561015 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Slew rates are : 0-960
Info: 08:22:22.3581040 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRates() :: Testing slew rates for availability : 1, 4, 16, 60, 120, 240, 480, 720, 960, 1920, 4800, 9600, 12000
Info: 08:22:22.3591046 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 1920 is not allowed for axis 0
Info: 08:22:22.3601045 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 4800 is not allowed for axis 0
Info: 08:22:22.3611050 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 9600 is not allowed for axis 0
Info: 08:22:22.3621042 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 12000 is not allowed for axis 0
Info: 08:22:22.3631033 Thread:#1 SharpCap.ViewModels.MountViewModel.CreateRates() :: SynScanMobile Telescope has 9 available slew rates.
Debug: 08:22:22.4141058 Thread:#1 SharpCap.ViewModels.MountViewModel..ctor(Mount model) :: Ended
Debug: 08:22:22.6709162 Thread:#1 SharpCap.Base.BaseImageProvider.Stop() :: Ended
Info: 08:22:22.6739207 Thread:#1 SharpCap.MultiCaptureProvider.SendCaptureEvent(Object sender, CaptureEventArgs e) :: Capture Event : StopPreview
Info: 08:22:22.6749199 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: StopPreview event received in UI thread
Info: 08:22:23.1494247 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StopPreview() :: Ended
Info: 08:22:23.1529746 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StartPreview() :: Started
Info: 08:22:23.1569769 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StartPreview() :: Starting Preview on Test Camera 1 (Deep Sky), 1936x1096, Mono, 8bits
Debug: 08:22:23.1579760 Thread:#1 SharpCap.Base.BaseImageProvider.Start() :: Started
Debug: 08:22:23.1599772 Thread:#1 SharpCap.Base.CameraProxyBase.StartPreview() :: Started
Debug: 08:22:23.1609763 Thread:Grab Thread#25 SharpCap.Base.CameraProxyBase.GrabThreadProc() :: Started
Debug: 08:22:23.3419833 Thread:#1 SharpCap.Base.CameraProxyBase.StartPreview() :: Ended
Debug: 08:22:23.3449794 Thread:#1 SharpCap.Base.BaseImageProvider.Start() :: Ended
Info: 08:22:23.3469869 Thread:#1 SharpCap.MultiCaptureProvider.SendCaptureEvent(Object sender, CaptureEventArgs e) :: Capture Event : StartPreview
Debug: 08:22:23.3529817 Thread:#1 SharpCap.UI.WPFControlForm.InitControls(CaptureControl captureControl, String deviceName) :: Started
Debug: 08:22:23.3629831 Thread:#1 SharpCap.UI.WPFControlForm.InitControls(CaptureControl captureControl, String deviceName) :: Ended
Info: 08:22:23.3629831 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: StartPreview event received in UI thread
Info: 08:22:23.3669847 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StartPreview() :: Ended
Debug: 08:22:23.3739830 Thread:#1 SharpCap.Models.Camera.ApplyDefaultProfile() :: Ended (Profile applied)
Debug: 08:22:23.6799931 Thread:#1 SharpCap.UI.Hardware.MountControl..ctor(Mount model) :: Started
Debug: 08:22:23.6809922 Thread:#1 SharpCap.ViewModels.MountViewModel..ctor(Mount model) :: Started
Info: 08:22:23.6849902 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Axis 0 has 1 slew rates.
Info: 08:22:23.6859929 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Slew rates are : 0-960
Info: 08:22:23.6899973 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Axis 1 has 1 slew rates.
Info: 08:22:23.6909936 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Slew rates are : 0-960
Info: 08:22:23.6919935 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRates() :: Testing slew rates for availability : 1, 4, 16, 60, 120, 240, 480, 720, 960, 1920, 4800, 9600, 12000
Info: 08:22:23.6929990 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 1920 is not allowed for axis 0
Info: 08:22:23.6939967 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 4800 is not allowed for axis 0
Info: 08:22:23.6949980 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 9600 is not allowed for axis 0
Info: 08:22:23.6959972 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 12000 is not allowed for axis 0
Info: 08:22:23.6959972 Thread:#1 SharpCap.ViewModels.MountViewModel.CreateRates() :: SynScanMobile Telescope has 9 available slew rates.
Info: 08:22:23.7369955 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Axis 0 has 1 slew rates.
Info: 08:22:23.7379953 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Slew rates are : 0-960
Info: 08:22:23.7409963 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Axis 1 has 1 slew rates.
Info: 08:22:23.7419947 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRatesViaIndexing(Int32 axis) :: Slew rates are : 0-960
Info: 08:22:23.7429939 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.GetSlewRates() :: Testing slew rates for availability : 1, 4, 16, 60, 120, 240, 480, 720, 960, 1920, 4800, 9600, 12000
Info: 08:22:23.7439944 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 1920 is not allowed for axis 0
Info: 08:22:23.7439944 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 4800 is not allowed for axis 0
Info: 08:22:23.7449957 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 9600 is not allowed for axis 0
Info: 08:22:23.7459949 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.IsAllowed(Double d, Tuple`2[] axisRates, Int32 i) :: Slew rate of 12000 is not allowed for axis 0
Info: 08:22:23.7469947 Thread:#1 SharpCap.ViewModels.MountViewModel.CreateRates() :: SynScanMobile Telescope has 9 available slew rates.
Debug: 08:22:23.7749956 Thread:#1 SharpCap.ViewModels.MountViewModel..ctor(Mount model) :: Ended

nm1213
Posts: 33
Joined: Mon Feb 19, 2018 1:47 am

Re: Sync issues after Plate Solving

Post by nm1213 » Mon Sep 10, 2018 12:47 am

Robin,

I've changed the firmware to the version that supports both AZ and EQ.


This is with the mount in EQ mode:

Info: 08:35:55.9449438 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Creating ASCOM Telescope mount of type ASCOM.SynScanMobile.Telescope ('SynScanMobile Telescope')
Debug: 08:35:56.2665299 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Ended
Info: 08:35:56.2675312 Thread:#1 SharpCap.Models.ConnectableHardware.OnConnectedChanged() :: Mount 'SynScanMobile Telescope' now Conneted:True
Info: 08:36:01.6846652 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.TryConnect() :: The mount claims to be SynScanMobile Telescope, SynScanMobile Telescope 1.2.2, SynScanMobile Telescope, 1.2.2
Info: 08:36:01.7516576 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.TryConnect() :: The mount reports an alignment mode of algGermanPolar

This is with the mount in AZ mode:

Debug: 08:39:41.5769221 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Started
Info: 08:39:41.5779205 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Creating ASCOM Telescope mount of type ASCOM.SynScanMobile.Telescope ('SynScanMobile Telescope')
Debug: 08:39:41.8679316 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper..ctor(String deviceName, String progId) :: Ended
Info: 08:39:41.8689357 Thread:#1 SharpCap.Models.ConnectableHardware.OnConnectedChanged() :: Mount 'SynScanMobile Telescope' now Conneted:True
Info: 08:39:47.3999621 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.TryConnect() :: The mount claims to be SynScanMobile Telescope, SynScanMobile Telescope 1.2.2, SynScanMobile Telescope, 1.2.2
Info: 08:39:47.4439585 Thread:#1 SharpCap.MountProxy.ASCOM.MountWrapper.TryConnect() :: The mount reports an alignment mode of algAltAz

Seems like it is easy enough to identify which mode the mount is in. However, I have not had a chance to test plate solving as I don't have clear skies, and the previous captures I have won't solve due to being more than 15 degrees off. Could you enable blind solving and sync within Sharpcap? This will allow me to test sync during the day.

Thanks!

N.

nm1213
Posts: 33
Joined: Mon Feb 19, 2018 1:47 am

Re: Sync issues after Plate Solving

Post by nm1213 » Mon Sep 10, 2018 4:25 am

Robin,

I also just tried the following:

1. Set the mount in EQ mode.
2. Plate solve a known image with All Sky Solver and sync the mount (successful).
3. Load the same image in Sharpcap (replace m42_dim), and try to solve that.
4. For some reason it's solving to totally different co-ordinates, that is well beyond 15 degrees.

I'm not sure why this is happening, but it stops me from testing a solve+sync from within Sharpcap. Will fiddle around some more.

N.

User avatar
admin
Site Admin
Posts: 2143
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Sync issues after Plate Solving

Post by admin » Mon Sep 10, 2018 5:59 am

Hi,

I think options for both the sync mode and the solving area (15 degrees or larger) will be needed - as far as I can see there is nothing in that log that would let me spot the mount as being 'alt az but needs EQ sync' as opposed to 'alt az and accepts altaz sync'. The only thing I can think of would be to sent the alt az sync and then spot the position has not changed, but I'm not sure that will be reliable.

I will put this on the to-do list and see if I can squeeze it into 3.2

cheers,

Robin

nm1213
Posts: 33
Joined: Mon Feb 19, 2018 1:47 am

Re: Sync issues after Plate Solving

Post by nm1213 » Mon Sep 10, 2018 6:55 am

Thanks, much appreciated!

I saw in the logs that you record the position of the mount before sync, and then check it after sync. I suppose you can use this logic as follows:

1. Note the plate solved co-ordinates.
2. Note position of mount before sync.
3. Note position of mount after sync.
4. Position of mount hasn't changed pre/post sync. Yet the position post-sync attempt is different than the position of the plate solved co-ordinates.

If 4 is true, then assume that the sync wasn't successful. Then, repeat the sync with RA/DEC co-ordinates.

Would that work?

N.

User avatar
admin
Site Admin
Posts: 2143
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Sync issues after Plate Solving

Post by admin » Mon Sep 10, 2018 6:18 pm

Hi,

In theory it might, in practice I suspect there is at least one ASCOM driver out there that will break it, since ASCOM is not well defined as a standard. One of the things that is particularly badly defined is whether particular methods should be synchronous or asynchronous - in other words if you ask the mount to do something, should it not return until it has finished doing whatever you asked, or should it start doing what you asked and return straight away?

Experience has taught me to trust ASCOM drivers as little as possible, so I think a user option is probably the best :)

cheers,

Robin

nm1213
Posts: 33
Joined: Mon Feb 19, 2018 1:47 am

Re: Sync issues after Plate Solving

Post by nm1213 » Tue Sep 11, 2018 3:23 am

Robin,

I've just heard back from Synscan dev. There is something wrong with their implementation of SyncToAltAz. I'll provide logs to them as requested. SyncToRADec is functional.

N.

User avatar
admin
Site Admin
Posts: 2143
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Sync issues after Plate Solving

Post by admin » Tue Sep 11, 2018 6:47 am

Ah, good to hear that I don't need to work around that issue then! I will keep the larger solve area on the todo list.

cheers,

Robin

nm1213
Posts: 33
Joined: Mon Feb 19, 2018 1:47 am

Re: Sync issues after Plate Solving

Post by nm1213 » Wed Sep 12, 2018 12:42 am

Thanks Robin.

I've received a new build of Synscan to test synctoAltAz. I'll do that once I have a chance to fix the plate solver issues I'm having. Blind solves are failing in Sharpcap, where they worked fine a couple of days ago. All Sky Solver's stand-alone app works fine and solves correctly.

What might help is to allow some sort of command line interface where I can communicate with the mount, and manually invoke synctoAltAz or synctoRADEC with a specific set of co-ordinates. Would be useful to have some kind of troubleshooting console and a standardised syntax guide in a future release.

N.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest