Reduced frame-rate with SC 3.2.6482.0

A place to report problems and bugs in SharpCap
Forum rules


If you have a problem or question, please check the FAQ to see if it already has an answer : https://www.sharpcap.co.uk/sharpcap-faqs

Please also read about Troubleshooting USB Issues before posting.

*** Please do not post license keys - please report any problems with licensing to 'admin' by private message ***

Please include the following details in any bug report:

* Version of SharpCap
* Camera and other hardware being user
* Operating system version
* Contents of the SharpCap log after the problem has occurred.
[If SharpCap crashes, please send the bug report when prompted instead of including the log]
MatP
Posts: 4
Joined: Thu Jun 10, 2021 10:40 am

Reduced frame-rate with SC 3.2.6482.0

Post by MatP »

I recently updated to SharpCap 3.2.6482.0. Unfortunaltely I am unable to reach the full frame rate with my QHY183 camera.
Settings are:
5544x3684, MONO8, Binning 1x1
USB Traffic=0
DDR Buffer off
broadcast off
still mode off.
The maximum frame rate is 14fps. In 16 bit mode, I am able to reach 7.3 fps.

In previous release I had installed (SharpCap 3.2.6477.0), I could reach 18.5fps, which is a tad below the theoretical maximum of 19fps.

I observed this on my i5 scope computer as well as a brand new i7-11700k with plenty of resources. Both running Windows 10 Pro.
User avatar
admin
Site Admin
Posts: 6645
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Reduced frame-rate with SC 3.2.6482.0

Post by admin »

Hi,

between 6477 and 6480 there was an update to the QHY provided camera SDK - I suspect that this change may be causing the reduced frame rates. There was one other QHY related change in 6482, but I don't think that is likely to affect frame rates.

You could try 6480 just to confirm whether or not it was the SDK update or not.

I will check later to see if there are any further updates from QHY, which may fix up this issue.

cheers,

Robin
MatP
Posts: 4
Joined: Thu Jun 10, 2021 10:40 am

Re: Reduced frame-rate with SC 3.2.6482.0

Post by MatP »

Testet 6480:

After opening SharpCap, I got 14 fps. Then played around with camera settings, when switching DDR Buffer to ON and shortly after to OFF again, frame rate increased to 18fps.
So I got curious and did the same in 6482. Open SharpCap, connect QHY183M -> 14 fps. Toggle DDR Buffer (OFF -> ON -> OFF), now 6482 does 18 fps...
Seems to be correlated with some initalization of the camera.

If you feel, that SharpCap handles the QHY SDK properly, I will create a ticket with QHY.
(there seems to be some issue with the QHY183 anyway, as in several cases I got striped images when changing the capture area)
User avatar
admin
Site Admin
Posts: 6645
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Reduced frame-rate with SC 3.2.6482.0

Post by admin »

Thanks for that info.

I think that this problem may already be fixed in SharpCap 4.0 - in the new version I deliberately turn on DDR when starting a QHY camera in 'live video' mode, which I think will have the same effect as your on/off/on trick.

If you have a chance to try the 4.0 beta then please can you let me know if it seems to be fixed there or not.

cheers,

Robin
MatP
Posts: 4
Joined: Thu Jun 10, 2021 10:40 am

Re: Reduced frame-rate with SC 3.2.6482.0

Post by MatP »

I downloaded 4.0.7870.0.

Right after program launch, I got 6.8fps. Modifying the DDR did not change much.
I then jiggled the USB Traffic. When returned to 0, now frame rate is at 9fps.
No matter what control I play around, the fps stays at +/- 9fps maximum.

To be sure, retried the 3.2 version afterwards, which again reached 18fps after the DDR Buffer trick.
If there is anything I may test for you, let me know :-)

cheers MatP
User avatar
admin
Site Admin
Posts: 6645
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Reduced frame-rate with SC 3.2.6482.0

Post by admin »

Aargh...

the only modern (last couple of years) QHY camera I have here to test against is the 294PRO-C, and that performs spot on the advertised 16.5fps in SC 4.0. If I had a 183 here then I could spend a few hours tinkering and likely work out what the changes are between 3.2 and 4.0 that cause the frame rate difference. Unfortunately that sort of thing is nearly impossible to do without a camera to test with - in those hours I would perform literally dozens of tests with different SDK versions and different bits of the code changed one way and another.

I guess we have to narrow this down a bit...

3.2.6482 has QHY SDK version 21.2.1.10
latest 4.0 has QHY SDK version 21.3.13.17

If you copy the qhyccd.dll from SharpCap 4.0 into SharpCap 3.2, then run SharpCap 3.2 from 'sharpcap.exe' in that folder (if you run it from the desktop or start menu it may 'auto repair' and put the other version of the QHY SDK back). Then you can test to see if the SharpCap code in 3.2 along with the newer SDK can get the right frame rate (perhaps using your DDR trick). If you can't get the right frame rate with the newer SDK then we have an SDK bug (over to QHY). If you can then comes the fun of working out what has changed between 3.2 and 4.0 (sadly quite a lot for QHY cameras) and which of those changes has caused the problem.

cheers,

Robin
MatP
Posts: 4
Joined: Thu Jun 10, 2021 10:40 am

Re: Reduced frame-rate with SC 3.2.6482.0

Post by MatP »

Morning...

Swapping the DLL has the following effect:

qhyccd.dll 21.3.13.17, file date 2021-03-13 16:08 (from latest QHYSDK All-in-one System Pack)
- SharpCap 3.2 connects with 7fps.
- After DDR trick, 9fps.
- No other setting increases frame rate.
- switching to force still mode causes the camera to stall (no more frames arrive). Reconnect does nothing. Close camera and connect causes SharpCap to crash. No log file written.

qhyccd.dll 21.3.13.17, file date 2021-03-22 14:04 (from SharpCap 4)
- SharpCap 3.2 connects with 7fps.
- After DDR trick, 9fps.
- No other setting increases frame rate.

qhyccd.dll 21.2.1.10, file date 2021-02-17 12:50 (from SharpCap 3.2.6482)
- SharpCap 3.2 connects with 14fps.
- After DDR trick, 18fps.

qhyccd.dll (has no version tag), file date 2020-04-28 (from SharpCap 3.2.6322.0)
- SharpCap 3.2 connects with 14fps.
- After DDR trick, 18fps.
- same if I run ShaprCap 6322 or 6482

swapping the DLL in SC4 from 21.3.13.17 to 21.2.1.10
- SharpCap 3.2 connects with 14fps.
- After DDR trick, 18fps.

So this seems to be an issue with QHY... I will create a ticket with QHY.

I have a bunch of QHY cameras here. To be precise, I have QHY183M, QHY183C, QHY268M, QHY462C, QHY485C at hands. Plus a friend owns a QHY294M. So if you need to test issues with QHY cameras, or you even need debugging help, feel free to get in touch!


By the way (perhaps should be placed in a separate threads):
I once forgot to close the SC3.2 and tried to connect through a second instance. This causes both instances to not update frames! There is obviousely no code blocking access to one camera from different applications!
As I have several QHY cameras, I tried to connect with 2 instances of SharpCap to 2 different cameras. The first instance with QHY183M started properly with 18fps. When I connected the second instance with QHY183C, instance 1 dropped to 14fps but did no longer refresh frames (same in saved video). Second instance updated with 18fps.
I don't expect my computer to cause the issue, as CPU is below 60% and SSD below 30% use. Both cameras connected to different USB 3.2 SS10 ports. (running both cameras through one USB3 Hub completely fails)

MatP
User avatar
admin
Site Admin
Posts: 6645
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Reduced frame-rate with SC 3.2.6482.0

Post by admin »

Hi Mat,

thanks for doing such comprehensive testing- I agree that it does point the finger strongly at this being something that QHY have broken in the latest SDK release. I'm actually a bit surprised that we haven't seen a new update from them for the better part of 3 months - up until March there were quite a regular flow of updates.

Thanks also for the offer of testing with QHY cameras - as much as anything it would help if you could post details of any new issues you spot with a particular model of camera. Some brands are fairly good at hiding the differences between the models from application developers like me - if one model works then they all will. QHY have had problems in this department (perhaps due to the very wide range of models) - it's much more common to find glitches that affect a single model or a small range of models, so testing with as wide a range of models as possible is very useful.

I have seen the opening twice issue before - really I think the SDK should give an error when the second SharpCap tries to open the camera that is already in use, but sadly it doesn't. Oddly some people have put this to good use - finding ways to adjust settings in other applications by connecting a second application to the camera and changing a setting then closing it...

cheers,

Robin
lukenash707
Posts: 7
Joined: Thu Feb 25, 2021 3:42 am

Re: Reduced frame-rate with SC 3.2.6482.0

Post by lukenash707 »

Adding to this, I recently bought a qhy268m and am running the latest beta 64 bit of sharpcap with the newest sharp cap sdk drivers. I have two issues. No 1, the cooling control is very buggy. Sometimes, I set the temp to 0C in auto mode and it stays at 100% cooling even though the temperature has met the 0C and is still falling. I can fix it by playing with the manual cooling power. After turning it on/off a few times, the auto finally gets back to working.

The other issue is the frame rate for video recording. When I do live view at 8bit 800x600, it’s great, 50fps roughly. As soon as I start recording it drops to 4fps. Usb traffic is 0, ddr buffer on or off, no difference. Usb 3 cable to Pegasus power ultimate then to a intel mini pc . Total of about 6ft of cable. Hard drive is super fast on board ssd with 16gb ram and plenty of space. Any ideas?
User avatar
admin
Site Admin
Posts: 6645
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Reduced frame-rate with SC 3.2.6482.0

Post by admin »

Hi,

on the subject of cooling, there have been some issues like that in the past which we never really got to the bottom of - The cooling would run fine and then go crazy - details tracing of the communications between SharpCap and the QHY SDK didn't reveal much - all the messages sent to the SDK seemed sensible, but sometimes the results coming back were clearly indicating that the camera was not doing what it should. Various SDK updates seemed to resolve most of these issues.

You can turn on additional logging of all SharpCap<->Camera communications (https://docs.sharpcap.co.uk/4.0/#Logging%20Tab), if the problem happens while that logging is turned on then the log may reveal something. Note down the time that the problem happens as it helps find the right place in the log (which will be very long!).

Frame rates...

Check the log while capturing and see if anything gets logged about dropped frames - that would indicate a bottleneck within SharpCap, and hopefully hint at where it might be.

Also worth checking that you are really saving to one of the video formats (AVI or SER) - those are good for high performance writing, but still image file formats (FITS, TIFF, PNG, etc) are much slower to save (which doesn't matter when using them for long exposure work of course).

Finally, does the CPU load hit 100% when saving? Some mini PCs have quite slow processors, so you could imagine that the extra work of saving the data might mean that there are no longer CPU resources available to keep up with the camera.

cheers,

Robin
Post Reply