Problems with 64 bit beta

Discussions, Bug Reports and Issues related to Beta versions of SharpCap
stbkaiser
Posts: 24
Joined: Wed Aug 15, 2018 2:57 pm

Problems with 64 bit beta

Post by stbkaiser » Tue Mar 26, 2019 2:08 pm

Hi
New user of sharp cap
I downloaded 64bit beta version and trying it out.
I have pro license
It will not connect to my qhy247c camera in native mode.
I get
Error , qhyccd_error from call to camera.setresolution(x=0,y=0,width =6088, height=4052
I tried closing camera reconnecting.
Restarting sharpcap
Unplugging camera and plugging back in.
Camera does work through ascom connection
Also asi124mc guide camera connects ok.

Also if I try to use with phd2 I have no “guide” selection in menu bar.
Thanks
Steve

User avatar
admin
Site Admin
Posts: 2861
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Problems with 64 bit beta

Post by admin » Tue Mar 26, 2019 7:13 pm

Hi,

I think the problem you are seeing is a result of a bug in the latest qhy SDK where it is reporting the sensor size including the overscan area for some cameras rather than the effective sensor size. I have managed to put together a workaround for this problem (at least it seems to work on the 168C) which is in the very latest build that you can download now from the SharpCap download page.

I'm not quite sure what you're referring to with not seeing a guiding section with relation to PhD2. SharpCap only currently supports a connection to PhD2 guiding when using live stacking mode in which case there is a guiding tab in the live stacking controls.

Cheers, Robin

stbkaiser
Posts: 24
Joined: Wed Aug 15, 2018 2:57 pm

Re: Problems with 64 bit beta

Post by stbkaiser » Tue Mar 26, 2019 9:13 pm

Thanks Robin
I,ll give the QHY SDK a try and see if that fixes it.
As mentioned , this is my first use of sharpcap.
I did read through your user guide but failed to realize PHD2 only worked/was selectable in "Live-stacking" Mode
Thanks for your guidance.
A lot of features to take in.!
take care
steve

stbkaiser
Posts: 24
Joined: Wed Aug 15, 2018 2:57 pm

Re: Problems with 64 bit beta

Post by stbkaiser » Wed Mar 27, 2019 1:42 pm

Robin
I tried out your newer version software and it failed with the same error while trying to connect to my qhy camera.
I assumed from your message that you had a different sdk in this version or was I supposed to download a driver from qhy?
Thanks for your help.

Also if I download your non beta sw should this work ok with the camera? Or is it using the same drivers.
Take care
Steve

User avatar
admin
Site Admin
Posts: 2861
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Problems with 64 bit beta

Post by admin » Wed Mar 27, 2019 6:41 pm

Hi,

Sorry, are you actually using the old 64-bit beta builds that are linked somewhere on the forums here? Those are long outdated and you should be using the 64-bit builds that are now available from the normal SharpCap download page. I'm afraid I missed that in my first reply

Cheers, Robin

stbkaiser
Posts: 24
Joined: Wed Aug 15, 2018 2:57 pm

Re: Problems with 64 bit beta

Post by stbkaiser » Thu Mar 28, 2019 12:14 am

Robin
I am Using 3.2.5967.0 downloaded from sharpcap web site not from this forum.
Previous version I tried was 3.2.5964.0
Both are the 64bit versions
Running on new hp windows 10 64 bit professional, omen laptop, 32 gig ram, usb 3 ports.
As mentioned, the ascom interface works ok but was hoping to use more comprehensive sdk interface.
I have been using APT for photo work , but it only provides ascom interface for this camera.
Any other info you need on this?
Thanks for your help
Steve

User avatar
admin
Site Admin
Posts: 2861
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Problems with 64 bit beta

Post by admin » Thu Mar 28, 2019 6:34 pm

Hi Steve,

Please can you share the content of the SharpCap log after the problem has occurred and if possible a screenshot showing the problem too.

Thanks, Robin

stbkaiser
Posts: 24
Joined: Wed Aug 15, 2018 2:57 pm

Re: Problems with 64 bit beta

Post by stbkaiser » Thu Mar 28, 2019 11:42 pm

Robin
per your request here is a screen shot of the error when I try to connect to my QHY247C in native mode.
Also the log file from when I try to connect.
Hope this helps.
Let me know if there is anything else I can do to help on this.
Also
Should the 32 bit "standard" sharpcap be able to run with my camera, just not as effectively?
Can I have both versions loaded on my system without issues if I want to try the 32bit ?

Take care
Steve
Attachments
sharpcap error with QHY247C.jpg
Sharpcap beta error screen from QHY247C connection
sharpcap error with QHY247C.jpg (168.31 KiB) Viewed 615 times
sharpcap log.txt
sharpcap beta 64bit log from QHY247c connection
(49.11 KiB) Downloaded 25 times

User avatar
admin
Site Admin
Posts: 2861
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Problems with 64 bit beta

Post by admin » Fri Mar 29, 2019 8:37 pm

Hi,

I think I see what is happening now – the latest SDK seems to include the overscan area when it reports the size of the sensor, but then refuses to accept that area when trying to set the camera resolution. On some models I can ask the camera for its effective area which gives me the size of the sensor less the overscan, but it looks like that call is not giving me a useful result on your model of camera. I think it this is something that will need to be fixed by qhy.

Cheers, Robin

stbkaiser
Posts: 24
Joined: Wed Aug 15, 2018 2:57 pm

Re: Problems with 64 bit beta

Post by stbkaiser » Sat Mar 30, 2019 1:13 am

Hi robin
Thanks for looking into my problem.
So if I contact qhy and give them the problem description as you explained it, do you think this is enough information so they could formulate a fix?
Take care
Steve

Update:
after searching the QHY forum I found the following similar issue with a QHY 294c doesn't start in SharpCap .
QHY response was:
Hi,
It seem not the SDK issue,I set SharpCap 3.2 go back to V3.2.5949,it can work well with SDK V0.4.0.15.
Best Regards,
QinXiaoXu

So I will try this.
Thanks
Steve

Locked

Who is online

Users browsing this forum: No registered users and 1 guest