Crashing during live stacking

Discussions, Bug Reports and Issues related to Beta versions of SharpCap
Post Reply
saguaro
Posts: 43
Joined: Tue Feb 14, 2017 9:04 pm

Crashing during live stacking

Post by saguaro » Wed Oct 10, 2018 1:45 pm

I've been using the 3.2 Beta builds with no issues with my 290mm mono and 385MC color cameras. Last night was the first time I tried my ASI1600MC-Cool with the latest 3.2 Beta build.I've been using this camera with SharpCap 3.1 with no issues, but last night was the first time I tried using it with the 3.2 Beta.

At some point during live stacking, SharpCap crashes and displays a "System Exception" error message. Each time it crashed I did "Send and Quit" so hopefully you got the error reports. I also tried using two earlier Beta versions and also got the same crash during live stacking. The crash happens at different times: sometimes it happens after live-stacking for several minutes, and it also happened immediately after starting live stacking (before the first frame was captured). I was using a matching master dark and master flat.

Setup: Windows 10 Pro running on i7 laptop and ASI1600MC-Cool, latest 3.2 Beta version.
The attachment logs.zip is no longer available
The attachment Crash 1.JPG is no longer available
logs.zip
(150.09 KiB) Downloaded 4 times

saguaro
Posts: 43
Joined: Tue Feb 14, 2017 9:04 pm

Re: Crashing during live stacking

Post by saguaro » Wed Oct 10, 2018 1:46 pm

Here are screenshots of the crash message.
Crash 1.JPG
Crash 1.JPG (679.58 KiB) Viewed 234 times

saguaro
Posts: 43
Joined: Tue Feb 14, 2017 9:04 pm

Re: Crashing during live stacking

Post by saguaro » Wed Oct 10, 2018 1:47 pm

Crash 2.JPG
Crash 2.JPG (559.87 KiB) Viewed 234 times

User avatar
admin
Site Admin
Posts: 2010
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Crashing during live stacking

Post by admin » Wed Oct 10, 2018 7:02 pm

Hi,

the logs show that this is caused by memory running out while trying to perform the bilateral filter operation (which is more memory hungry than the simpler gaussian filtering).

I think I have run out of tricks for trying to keep the memory usage down and keep everything working in a single 32 bit version of SharpCap - I am going to have to introduce a 64 bit version which will keep this sort of error at bay. That's something down the line in either 3.3 or a later release of 3.2.

For now, try using binning (will reduce memory usage by a factor of 4) or turning off the bilateral filter. Actually turning down the radius of the bilateral filter may help - certainly worth a try.

cheers,

Robin

saguaro
Posts: 43
Joined: Tue Feb 14, 2017 9:04 pm

Re: Crashing during live stacking

Post by saguaro » Wed Oct 10, 2018 11:07 pm

I’d really prefer not to Bin my 1600, since I like to preserve the full resolution so I can zoom in to see more detail. One of the main reasons I like the 1600 camera is for its resolution.

If I just avoid using the Enhancement tab (keep Noise Reduction and Sharpening turned off) would that prevent the crashing? Thanks.

User avatar
admin
Site Admin
Posts: 2010
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Crashing during live stacking

Post by admin » Thu Oct 11, 2018 5:13 pm

Hi,

I think you will probably be OK if you stick to Unsharp mask and Gaussian noise reduction as they are much simpler, but if you still have trouble with those then keep clear of the Enhancement tab for now until I get the 64 bit version sorted.

cheers,

Robin

donboy
Posts: 81
Joined: Sat Mar 25, 2017 1:57 am

Re: Crashing during live stacking

Post by donboy » Sun Oct 14, 2018 10:44 pm

I don't crash in LiveStack using my ASI1600mmCool but drop frames. I have to uncheck the camera and recheck it. This happens everytime I use this camera and generally everything settles down after I repeat the the recovery process of uncheck and checking the camera by the third live stacking attempt. The dropped frames genral show up after a few stacks, typically 5 or 6 frames.

Don

saguaro
Posts: 43
Joined: Tue Feb 14, 2017 9:04 pm

Re: Crashing during live stacking

Post by saguaro » Mon Oct 15, 2018 2:43 pm

I've had issues with dropped frames in the past, but not with the 3.2 Beta builds so far.

I've increased the SC setting for paged memory during live stacking to the maximum for my system. I'll see if that helps eliminate the crashes next time.

saguaro
Posts: 43
Joined: Tue Feb 14, 2017 9:04 pm

Re: Crashing during live stacking

Post by saguaro » Wed Oct 17, 2018 3:11 pm

It appears there will soon be a 64-bit version of SC 3.2 available for testing. Thanks Robin!
See:
viewtopic.php?f=22&p=6020&sid=e9f52366d ... 1f8c#p6020

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest