Page 1 of 1

Issues with SV305 Pro

Posted: Wed Jan 13, 2021 7:18 pm
by MattZ
Hello all. I've been using a DSLR for over a year for some easier planetary and DSO imaging so I'm not a complete newbie. I received an SV305 a few days ago and after spending those days trying to get it to work properly all I've manged to obtain is what I hope is a temporary case of Tourette's syndrome. I realize this is a completely different ball game, but it shouldn't be this hard.
I'm running windows 10 with the latest updates. I've installed the windows driver from the Svbony site, and the 32 bit version of Sharpcap 3.2.6473.
I'm connecting to the camera in the 'Svbony cameras' section of cameras. I'm using a Celestron 5SE with the camera straight into the optical back, no diagonal. Here's what I'm experiencing:

1) Camera locking up: After playing with the settings I can see an image. I can close and reopen the camera, it can run for hours without locking up. If I try and change the colour space or the capture area it will always lock up the camera, whether it's been running for an hour or a minute. Previewing frame count in lower left stops incrementing, but the clock keeps running so the application is not stuck, I can change settings but they have no effect since the camera isn't sending images. If I close the camera and try to reconnect, I get an error saying 'SVB_ ERROR_INVALID_INDEX" from call to camera..ctor (ID=1). If I try and connect to the SV305 in the 'Directshow cameras' section I get an error saying 'This camera does not provide control over resolution and colour space. It cannot be used with this version of SharpCap'. I know I shouldn't use this instance of the camera but that may provide a clue to someone more knowledgeable. If I rescan cameras, the 'Svbony cameras' section and SV305 is gone, but the SV305 in the 'Direct show' section remains. No amount of rescanning or closing and reopening SharpCap will get it to return. The only solution is to unplug and replug the USB cable to the camera. Then rescan and it's back and I can connect to it again. I don't suspect the cable as the laptop plays a notification sound when the USB cable is removed or plugged in. I don't hear that sound when the camera locks up but I do hear it when I remove the USB cable and plug it back in to reset it. So I end up having to unplug and replug the USB cable to change colour space or capture area.

2) Image quality / settings: I'm trying to test the camera during the day, with a Celestron 5SE scope pointing at a house about a mile away. After spending 2 days messing with settings I can tell it's a house, but that's about it. No matter what I do I can't get the color even close to realistic (it's very green), or even get a clear focus. The autoexposure and auto white balance adjust don't seem to help. I've tried changing them manually as well but no joy. Neither does changing gamma, contrast, saturation or sharpness.
Regarding the focus, it will go from really fuzzy, to fuzzy, back to really fuzzy when moving in one direction so I don't think I'm out of focuser travel. I can get a super clear shot of the house with a DSLR.
I have the same color and focus issues when trying to get an image of a streetlight in front of the same house.

Any advice would be greatly appreciated, thanks in advance.

Re: Issues with SV305 Pro

Posted: Wed Jan 13, 2021 8:09 pm
by admin

I've got no signs of any freezing problems with that camera here. It might be worth checking what version of the SVBony driver you have installed on your computer – I seem to have
Capture.PNG (995.34 KiB) Viewed 543 times
If updating the driver doesn't help sort anything out then the next thing to do would be to send a copy of the SharpCap log captured after the problem has occurred. It sounds as though SharpCap isn't freezing up, so you should be able to get at the log once the camera started misbehaving. Some of the symptoms you describe sounds a little bit like what you might see if the camera disconnected from USB, so do check your USB connections and try making adjustments to the 'USB speed' control to see if that helps resolve the issue.

On the subject of focus, I think this is just down to the fact that SCT telescopes always seem to have issues with sharpness when you zoom into the pixel level – this is much more noticeable with a small sensor camera like the SVB one than with a large sensor like a DSLR. In this you've actually got something smeared across the sensor or the sensor window then it's very likely to be down to something optical (focus, collimation, tube currents and so on).

I tend to test with small C/CS thread lenses that can be picked up off of eBay for about £10 each – that was what I was using for the screenshot above. As you can see there's no obvious blurriness there.

Cheers, Robin

PS. kudos to anyone who can identify the make/model of my (now vintage I suppose) calculator from the screenshot above :)

Re: Issues with SV305 Pro

Posted: Sat Jan 16, 2021 11:04 pm
by MattZ
Hello Robin, thanks for the reply and the suggestions, I really appreciate it. I'm going to guess that's an old TI graphing calculator, but I have no idea of the model number.
I did get the focus issue figured out, it was self-inflicted. The focus point was out past the maximum step setting in my home made focuser. I just had to recalculate how far it could actually go and adjust that setting. Weird how it sort of focused in a spot 100k steps away. It's still a bit fuzzy but a massive improvement. I may try one of those C lenses to play around with.

It is still locking up though, although far less frequently. I agree it looks like a disconnected USB if the cable is disconnected after the camera is found. What makes me think it's not the cable is the fact I can recreate it regardless of how long the camera has been running. It never locks up if I just leave it running, only when changing colour space or capture area. I did notice it was more frequent when I tried the USB speed setting of 2 for a short time. I moved it back to 1 and it behaves better. In fact I've only been able to get it to lock up a couple times today but the log must have been quite long by then. I don't know what has changed but the improvement is drastic. The camera is plugged directly into a USB 3.0 port on a laptop, no hub in between. Oddly enough the camera is not recognized when plugged into a hub, but a DSLR and webcam are recognized when plugged into the same port. Maybe I will try a new cable. I have the same version of the driver as you - I'll keep messing around and see where I end up.
BTW, SharpCap is very impressive. The focus tools and spiral search will save a lot of time, and general functionally looks great. I can't imagine the time you've put into this.

Re: Issues with SV305 Pro

Posted: Sun Jan 17, 2021 1:38 pm
by admin
Hi Matt,

Glad to hear that you're getting the camera working better now. If you can, I'd suggest trying with a different computer to see if that shows any difference in how the camera behaves and how reliable it is. I've seen enough cases in the past where particular models of camera will work beautifully on most computers and then have a massive sulk when attached to a particular laptop that has (perhaps) an unusual USB chipset to make it worth checking the sort of things out.

You're right on the brand of calculator – Texas Instruments – it's actually an old non-graphing TI68 model that goes all the way back to my student days. Still a remarkably competent calculator and only beaten by more modern ones because they have multi-line screens.

Cheers, Robin