Page 3 of 4

Re: Atik Horizon

Posted: Tue Feb 19, 2019 9:59 pm
by admin
Hi,

Yes – gain controls are much rarer on CCD cameras than on CMOS cameras (although not unheard of). Using the display stretch controls is a good way to effectively apply a gain value to brighten the image on screen to make up for the fact that the camera doesn't allow you to do this in hardware (or at least that there is no way to control the camera to do this in hardware for the horizon camera).

Cheers, Robin

Re: Atik Horizon

Posted: Fri Mar 15, 2019 6:56 pm
by Noah4x4
Hi Robin,

I have an update...

Atik has now fixed the ASCOM driver so that in Sequence Generator Pro or Maxim you now get invited to select 'Atik Camera' listed under ASCOM options (as before). Then, in (ASCOM) settings it asks "which specific camera. If you select Atik Horizon it recognises that it is an Atik Horizon CMOS. It then invites you to select Low (x1), Medium (x5) or High (x30) Gain within the ASCOM settings. This now works fine in SG Pro.

Oddly, I can't get this to work in SharpCap, which offers me Atik Camera and Atik Camera 2, but then fails to connect to camera. It is here throwing up a "failed to connect to server" error message rather than inviting me to select which specific Atik camera. But I am not sure if that disconnected server is yours, ASCOMs or Atiks server? My Atik Horizon worked fine with SharpCap with the old driver except that Gain was not adjustable (all other Atik cameras are CCD, so didn't need ASCOM Gain controls), but now fails with the new driver.

Any thoughts about where a fix needs to be employed? Thanks.

Phil

Re: Atik Horizon

Posted: Fri Mar 15, 2019 9:47 pm
by admin
Hi,

Could you post your SharpCap log after trying to connect to the camera – maybe there will be something in there that will help narrow down what the problem is.

Cheers, Robin

Re: Atik Horizon

Posted: Sun Mar 17, 2019 11:34 am
by Noah4x4
Hi Robin,

I think I have identified the issue and have written to Atik Support as I think it is a problem with the new driver (released last week) that is designed to permit the setting of Gain through ASCOM. What now happens in (say) Sequence Generator Pro is that this dialogue box appears.
DialogueBox.jpg
DialogueBox.jpg (72.97 KiB) Viewed 705 times
I select the Horizon camera and that allows me to set Gain as above (low, medium or high). But in SharpCap I get an error message to say SharpCap is not responding to keyboard/mouse. Frankly, I think it is waiting for this new user input (select camera) that isn't opening to permit the user to respond. There is a perhaps related minor issue in SG Pro because this new dialogue box appears hidden behind the main window, but in Sharpcap it simply doesn't appear at all.

Then, touch any key and I then get another error message in Sharpcap to say that "The RPC server is not available" - which corresponds with this interesting line in the SharpCap Log;

Error: 10:42:16.8512963 Thread:#1 SharpCap.Cameras.ASCOM.NewCameraProxy.DetermineColourSpaceFromExposure() :: Exception of type COMException from Failed to complete ASCOM exposure to determine colour space - assuming MONO : The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)

Having spoken to them on Friday, I am aware of a problem with Atik's new DUSK software relating to the Horizon OSC. I suspect the line "Failed to complete ASCOM exposure to determine colour space - assuming MONO" is possibly highlighting the same 'bug'.

I know Atik are currently working to fix this, so unless you can throw more helpful light on this I think the ball is in their court. But whose server is the RPC? Is this at your end? Won't a Sharpcap user get the same exception if not connected to the Internet? Or is this perhaps some once only Internet command to pull something in from the ASCOM platform? Odd that it seems to work in SG Pro, but not yet in Dusk or Sharpcap.

EDIT - Just remembered, I am pretty sure that the selection of 'Colour' or 'Mono' is on a seperate tab within S G Pro. However, I suspect in DUSK/SharpCap the driver may need to address 'Atik Horizon OSC' or 'Atik Horizon Mono' in the ASCOM driver and raise the dialogue box. Anyhow, I think we are now on the right track to fix this. Suggest nobody with Atik cameras using SharpCap update their drivers for a few days, albeit this problem does seem isolated to CMOS/OSC.

Thanks - full log below. The route to find camera seems pretty tortuous!

Regards

Phil



Info: 10:40:39.9009936 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: SharpCap Version 3.2.5949.0
Info: 10:40:39.9009936 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: GC Memory 116Mb
Info: 10:40:39.9009936 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Process Memory 149Mb
Info: 10:40:39.9009936 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Total Physical Memory 3977Mb
Info: 10:40:39.9009936 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Available Physical Memory 1817Mb
Info: 10:40:39.9009936 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Operating System : Microsoft Windows NT 6.2.9200.0
Debug: 10:40:40.3227706 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Started
Info: 10:40:41.5256435 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type BaslerDeviceEnumerator
Info: 10:40:41.5256435 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type QHYDeviceEnumerator
Info: 10:40:41.5256435 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type ASIDeviceEnumerator
Info: 10:40:41.5256435 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AltairDeviceEnumerator
Info: 10:40:44.0562673 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type PointGreyDeviceEnumerator
Info: 10:40:44.0562673 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type SxDeviceEnumerator
Info: 10:40:44.0562673 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Altair.dll
Info: 10:40:44.0562673 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.ASCOMCamera.dll
Info: 10:40:44.0562673 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.ASI.dll
Info: 10:40:44.0562673 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Basler.dll
Info: 10:40:44.0562673 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Celestron.dll
Info: 10:40:44.1499943 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.DS3.dll
Info: 10:40:44.1499943 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.Fake.dll
Info: 10:40:44.1499943 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.INova.dll
Info: 10:40:44.1968608 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.NewDirectShow.dll
Info: 10:40:44.1968608 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.PointGrey.dll
Info: 10:40:44.1968608 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.QHY.dll
Info: 10:40:44.1968608 Thread:#1 SharpCap.Base.InterfaceFactory`2.ScanDll(String filename) :: Probing for camera providers : C:\Program Files (x86)\SharpCap 3.2\SharpCap.Cameras.SX.dll
Info: 10:40:44.1968608 Thread:#1 SharpCap.MultiCaptureProvider.AddProvidersByReflection(String[] providerNames) :: Added device enumerator of type CelestronDeviceEnumerator
Info: 10:40:44.1968608 Thread:#1 SharpCap.MultiCaptureProvider.AddProvidersByReflection(String[] providerNames) :: Added device enumerator of type iNovaDeviceEnumerator
Info: 10:40:44.1968608 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type DS3DeviceEnumerator
Info: 10:40:44.1968608 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AscomDeviceEnumerator
Info: 10:40:44.1968608 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type FolderMonitorDeviceEnumerator
Info: 10:40:44.1968608 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type FakeDeviceEnumerator
Info: 10:40:44.2905865 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.WheelProxy.ASCOM.WheelFactory
Info: 10:40:44.4936626 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Atik FilterWheel
Info: 10:40:44.5092850 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Atik FilterWheel 2
Info: 10:40:44.5092850 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Filter Wheel Simulator [.Net]
Info: 10:40:44.5092850 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Simulator
Info: 10:40:44.5249052 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.WheelProxy.ZWO.WheelFactory
Info: 10:40:44.6342904 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.WheelProxy.ZWO.ManualWheelFactory
Info: 10:40:44.6342904 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Manual Filter Wheel
Info: 10:40:45.1966225 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Loading Hardware Proxies from SharpCap.MountProxy.ASCOM.MountFactory
Info: 10:40:45.1966225 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device CPWI
Info: 10:40:45.1966225 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Telescope Simulator for .NET
Info: 10:40:45.1966225 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device ASCOM Dome Control
Info: 10:40:45.1966225 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device FocusMax Focuser Hub
Info: 10:40:45.1966225 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device FocusMax Telescope Hub
Info: 10:40:45.1966225 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Generic Hub
Info: 10:40:45.1966225 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Pipe diagnostic tool
Info: 10:40:45.1966225 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device POTH Hub
Info: 10:40:45.1966225 Thread:#1 SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) :: Found device Simulator
Info: 10:40:46.7587532 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: CPU : Intel(R) Core(TM) i5-7260U CPU @ 2.20GHz with 4 cores.
Info: 10:40:51.0702754 Thread:#1 SharpCap.Base.Utilities.Logger.LogStackTrace(LogLevel level, String msg) :: Parent being changed on PreviewPanel
at SharpCap.UI.ScrollZoomForm.OnParentChanged(Object sender, EventArgs eventArgs)

Debug: 10:40:52.1949993 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Ended
Debug: 10:40:53.7987115 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Started
Debug: 10:40:53.8877025 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Ended
Debug: 10:40:53.9501883 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Started
Debug: 10:40:54.2469923 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Timebomb checked
Info: 10:40:54.2626148 Thread:#1 SharpCap.Models.Application.get_Cameras() :: Starting scan for cameras
Debug: 10:40:54.2938927 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Started
Info: 10:40:54.4500707 Thread:#1 SharpCap.SharpCapApp.get_ForceSoftwareRendering() :: WPF Rendering tier is 2
Debug: 10:40:54.7625070 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Ended
Info: 10:40:55.7935075 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: QHYCameraFinder - found 0 cameras
Info: 10:40:55.9028538 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: FindCameras - found 0 cameras
Warning: 10:41:37.6417270 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Exception from fetching menu items from provider : PointGrey Cameras : Invalid Bus Manager object.
Info: 10:41:38.7664615 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Atik Cameras (ASCOM Cameras)
Info: 10:41:38.7664615 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Atik Cameras 2 (ASCOM Cameras)
Info: 10:41:38.7664615 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Camera V2 simulator (ASCOM Cameras)
Info: 10:41:38.7664615 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Folder Monitor Camera (Virtual Cameras)
Debug: 10:41:38.7664615 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Started
Debug: 10:41:38.7664615 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Ended
Info: 10:41:38.7664615 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 1 (Deep Sky) (Test Cameras)
Info: 10:41:38.7664615 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 2 (High Speed) (Test Cameras)
Info: 10:41:38.9539170 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: CameraListUpdated event received in UI thread
Info: 10:41:39.5007002 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:39.5007002 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Info: 10:41:39.5007002 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:39.5007002 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Debug: 10:41:39.7193626 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Docking setup
Debug: 10:41:39.7349842 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Startup scripts (if any) run
Debug: 10:41:39.7349842 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Menu updated
Info: 10:41:44.2964133 Thread:#1 SharpCap.Models.Application.get_Cameras() :: Starting scan for cameras
Debug: 10:41:44.2964133 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Started
Debug: 10:41:44.3120682 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Ended
Info: 10:41:44.4370036 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: QHYCameraFinder - found 0 cameras
Info: 10:41:44.4682523 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: FindCameras - found 0 cameras
Warning: 10:41:44.4682523 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Exception from fetching menu items from provider : PointGrey Cameras : Invalid Bus Manager object.
Info: 10:41:44.5307352 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Atik Cameras (ASCOM Cameras)
Info: 10:41:44.5307352 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Atik Cameras 2 (ASCOM Cameras)
Info: 10:41:44.5307352 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Camera V2 simulator (ASCOM Cameras)
Info: 10:41:44.5307352 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Folder Monitor Camera (Virtual Cameras)
Debug: 10:41:44.5307352 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Started
Debug: 10:41:44.5307352 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Ended
Info: 10:41:44.5307352 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 1 (Deep Sky) (Test Cameras)
Info: 10:41:44.5307352 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 2 (High Speed) (Test Cameras)
Info: 10:41:44.5307352 Thread:#1 SharpCap.Models.Application.get_Cameras() :: Completed scan for cameras
Info: 10:41:44.5307352 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: CameraListUpdated event received in UI thread
Debug: 10:41:45.8116812 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Splash and tips done
Debug: 10:41:45.9366820 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Ended
Info: 10:41:48.8109823 Thread:#1 SharpCap.Models.Application+<>c__DisplayClass39_0.<set_SelectedCamera>b__0() :: Changing camera from none to Atik Cameras
Info: 10:41:48.8734597 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: OpeningDevice event received in UI thread
Debug: 10:41:48.8734597 Thread:#1 SharpCap.MultiCaptureProvider.OpenDevice(DeviceTagData deviceTag) :: Opening device : Atik Cameras (via ASCOM Cameras)
Info: 10:41:48.8891221 Thread:#1 SharpCap.Base.CaptureProviderBase`1.OpenDevice(DeviceTagData dtd) :: Started
Debug: 10:41:48.8891221 Thread:#1 SharpCap.Base.SimpleCaptureProvider.SetupDevice(DeviceTagData dtd) :: Started
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Info: 10:41:50.6699472 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:50.6699472 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Info: 10:41:50.6855345 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:50.6855345 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Debug: 10:41:54.3565473 Thread:#1 SharpCap.Base.SimpleCaptureProvider.SetupDevice(DeviceTagData dtd) :: Ended
Info: 10:41:54.4190298 Thread:#1 SharpCap.Base.CaptureProviderBase`1.CreateCaptureControl() :: Started
Debug: 10:41:54.4190298 Thread:#1 SharpCap.Base.SimpleCaptureProvider.GetControls() :: Started
Error: 10:42:16.8512963 Thread:#1 SharpCap.Cameras.ASCOM.NewCameraProxy.DetermineColourSpaceFromExposure() :: Exception of type COMException from Failed to complete ASCOM exposure to determine colour space - assuming MONO : The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)
Stack Trace: at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)
at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)
at System.Type.InvokeMember(String name, BindingFlags invokeAttr, Binder binder, Object target, Object[] args, CultureInfo culture)
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) in C:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 465
at ASCOM.DriverAccess.Camera.StartExposure(Double Duration, Boolean Light) in C:\ASCOM Build\Export\ASCOM.DriverAccess\Camera.cs:line 593
at SharpCap.Cameras.ASCOM.NewCameraProxy.DetermineColourSpaceFromExposure() in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Cameras.ASCOM\NewCameraProxy.cs:line 382
Error: 10:42:16.8668802 Thread:#1 SharpCap.Models.Camera.OpenDevice() :: Exception of type COMException from Opening Camera : The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)
Stack Trace: at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)
at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)
at System.Type.InvokeMember(String name, BindingFlags invokeAttr, Binder binder, Object target, Object[] args, CultureInfo culture)
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) in C:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 266
at ASCOM.DriverAccess.Camera.get_MaxADU() in C:\ASCOM Build\Export\ASCOM.DriverAccess\Camera.cs:line 446
at SharpCap.Cameras.ASCOM.NewCameraProxy.GetColourSpace() in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Cameras.ASCOM\NewCameraProxy.cs:line 361
at SharpCap.Cameras.ASCOM.AscomColourSpacePropertyControl.DummyColourSpaceFeature..ctor(Func`1 colourSpaceSrc) in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Cameras.ASCOM\AscomColourSpacePropertyControl.cs:line 58
at SharpCap.Cameras.ASCOM.AscomColourSpacePropertyControl..ctor(Func`1 colourSpaceSrc, IPreviewControl previewControl) in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Cameras.ASCOM\AscomColourSpacePropertyControl.cs:line 15
at SharpCap.Cameras.ASCOM.NewCameraProxy.GetVideoControls() in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Cameras.ASCOM\NewCameraProxy.cs:line 151
at SharpCap.Cameras.ASCOM.NewCameraProxy.GetControlsImpl(IPreviewControl previewControl) in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Cameras.ASCOM\NewCameraProxy.cs:line 123
at SharpCap.Base.CameraProxyBase.GetControls(IPreviewControl previewControl) in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Base\CameraProxyBase.cs:line 209
at SharpCap.Base.BaseImageProvider.GetControls(IPreviewControl previewControl) in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Base\BaseImageProvider.cs:line 676
at SharpCap.Base.SimpleCaptureProvider.GetControls() in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Base\SimpleCaptureProvider.cs:line 134
at SharpCap.Base.CaptureProviderBase`1.CreateCaptureControl() in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Base\CaptureProviderBase.cs:line 403
at SharpCap.Base.CaptureProviderBase`1.OpenDevice(DeviceTagData dtd) in C:\Documents\Source Code\SharpCap3.2\src\SharpCap.Base\CaptureProviderBase.cs:line 1046
at SharpCap.MultiCaptureProvider.OpenDevice(DeviceTagData deviceTag) in C:\Documents\Source Code\SharpCap3.2\src\SharpCap\Models\MultiCaptureProvider.cs:line 297
at SharpCap.Models.Camera.OpenDevice() in C:\Documents\Source Code\SharpCap3.2\src\SharpCap\Models\Camera.cs:line 991

Re: Atik Horizon

Posted: Sun Mar 17, 2019 8:37 pm
by admin
Hi,

Actually this part of the log interests me.

Code: Select all

Debug: 10:41:48.8891221 Thread:#1 SharpCap.Base.SimpleCaptureProvider.SetupDevice(DeviceTagData dtd) :: Started
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:50.3887314 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Info: 10:41:50.6699472 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:50.6699472 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Info: 10:41:50.6855345 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Received hardware change event
Info: 10:41:50.6855345 Thread:#1 SharpCap.UI.SharpCapForm.WndProc(Message& m) :: Flagging camera list as invalid
Debug: 10:41:54.3565473 Thread:#1 SharpCap.Base.SimpleCaptureProvider.SetupDevice(DeviceTagData dtd) :: Ended
What's happening here is that SharpCap is starting to set up the camera and suddenly it receives a slew of hardware changed events from Windows. It seems very unlikely that you'd have been unplugging or replugging devices into the computer just at the moment that you selected the camera, so I'm suspicious that the camera is actually disconnecting itself and the computer when SharpCap first tries to access it. That probably leads to the failure to run a simple exposure later in the sequence as a consequential error of this first problem.

Did you hear the noise that Windows makes when USB devices are connected or disconnected at that point in time?

Cheers, Robin

Re: Atik Horizon

Posted: Tue Mar 19, 2019 12:08 am
by Noah4x4
I concur Robin. Tonight, I downloaded a new version of the Atik core software in the hope that the known Atik Horizon OSC ASCOM driver problem was sorted. Now it became very conspicuous that the camera did keep disconnecting and reconnecting for no apparent reason. This occured in both Infinity and SG Pro . I didn't try in Sharcap as I know that there is some wider but unidentified issue. I have no speakers connected to my Intel NUCs so didn't hear the Windows sound.

However, I also had a USB3 port replaced under warranty, so I propose to test if that is an issue. But today, I did get some weird "camera not recognised" exception messages when installing the revised core software so I suspect the ASCOM Driver is at fault. It is now supposed to ask "what camera" to determine if it is to offer Gain functionality. Tomorrow I intend to roll back the drivers to those that worked prior to last week and see where that takes me. But thanks for your interest.

Re: Atik Horizon

Posted: Tue Mar 19, 2019 5:13 pm
by Noah4x4
Robin...

I have now deleted the Atik "Core Software with Dusk" and instead installed the "without Dusk" version.

It now works fine with SharpCap (albeit in daytime test) although I think I have to prior set the Gain in Atik's Infinity and hope that the camera remembers. In SG Pro the ASCOM driver (via Settings) asks which camera and I set (Atik Horizon); Color (yes/no); and Gain (Low, Medium High).

In Sharpcap the software seems to autoscan for camera and SharpCap now offers this in Equipment Profile

Atik Camera
Atik Camera 2
Atik Cameras
Atik Cameras2


The plural (italics) is the two options that I had before. Select either those and it now doesn't work with the Horizon OSC. I guess these are for Atik CCDs. However select Atik Camera (singular) and that now works, and it now defaults to RAW16 under the color profile in SharpCap where previously it offered me only Mono (and this is where I think it was erroring as it couldn't find a mono camera etc).

It could be that this is now working in SharpCap simply because I have prior set Camera = Horizon 29/color/low within SG Pro in the ASCOM Driver and it is being remembered. So we perhaps need somebody not using SG Pro to test this. I have contacted somebody in the Atik Support Forum that has raised this same issue I think he will oblige soon.

Thanks for your help Robin, but I think we are almost there. Just need a clear night to test.

Re: Atik Horizon

Posted: Tue Mar 19, 2019 9:21 pm
by admin
Hi,

Thanks for the update – it does sound like you have 2 versions of the Atik Ascom driver installed which are giving you the 2 different sets of entries in the cameras drop-down. I am a bit surprised that you can't access the same options to configure the camera in SharpCap through the ability to show the camera options from the button in the control panel on the right.
Capture.PNG
Capture.PNG (15.22 KiB) Viewed 667 times
It will be interesting to see what you get when you press that button and how it differs from the configuration you see in the SG Pro application. Please share a screenshot of both if you have a chance.

Cheers, Robin

Re: Atik Horizon

Posted: Wed Mar 20, 2019 8:20 am
by Noah4x4
Hi Robin,

Here are the two dialogues; to the left is that accessed via SharpCap and 'SHOW' optiosn; to the right is that accessed via SG Pro via 'SETTINGS'.

Note that the driver number is the same for each 7.0.8.25151.

The SG Pro version is inviting me to select Colour (or Mono) Camera and also Low, Medium or High Gain. Cooler is handled inside the software.

The SharpCap version offers only Cooler, settings but the software is now defaulting to 'Raw16' rather than 'Mono' (but is that because I had prior responded in S G Pro and that has perhaps set the driver?).

Anyhow I guess that this is helpful as it clearly shows where the issue lies. But does this need a fix in the Atik Driver or in how SharpCap interprets it? Do note that this refers to the (singular) 'Atik Camera' in the list (not Atik Camera2; Atik Cameras or Atik Cameras2 as I am offered four choices).
AtikDriverSettings.JPG
AtikDriverSettings.JPG (252.8 KiB) Viewed 664 times

Re: Atik Horizon

Posted: Wed Mar 20, 2019 1:44 pm
by Noah4x4
Hi Robin,

Vince at Atik Support wants to speak with you to resolve this. Can you please give him a call as he hasn't got an email address or contact number for you.

You can contact him at
Atik Cameras
Unit 8 Lodge Farm Barns
New Road, Norwich NR9 3LZ, UK

For product enquiries and support: support@atik-cameras.com
Phone: +44 (0)1603 740397
Fax: +44(0)1603 340600

Thanks

Phil