Orion Starshoot AutoGuider

User avatar
turfpit
Posts: 766
Joined: Mon Feb 13, 2017 8:13 pm
Location: UK
Contact:

Re: Orion Starshoot AutoGuider

Post by turfpit » Wed Apr 26, 2017 8:31 pm

It turns out that the ZWO 120 in question has an electronic fault and is being returned to the vendor - the owner emailed me (it was in relation to a thread on the Altair Google Group).

Dave

GregL
Posts: 55
Joined: Sun Apr 30, 2017 6:19 pm

Re: Orion Starshoot AutoGuider

Post by GregL » Sun Apr 30, 2017 6:33 pm

I also use the SSAG -- find it a mixed bag. When it works it works well, but sometimes there are connection problems with PHD2 (various errors in connection to the camera). And it only intermittently works with Astrotortilla for plate solving -- mostly I save an image and do a file system read. Host platform is Win7x64 on an older core2 duo Lenovo box. Had tried Win10 but had stability issues. If I connect to the camera directly instead of through the Optec ascom hub it is a bit better behaved -- but then AT cannot connect. Tried polar alignment using it but without success. Am replacing it with a Mallincam AG1.2c.

greg latiak

GaryCurran
Posts: 9
Joined: Sat Apr 22, 2017 3:03 am

Re: Orion Starshoot AutoGuider

Post by GaryCurran » Mon May 01, 2017 11:42 pm

I still haven't had a cloudless night, which for this time of year isn't that unusual for the Pacific Northwest of the U.S., but I'm pretty sure that the beta release is going to work well, Robin. I'm sorry I just haven't had the ability to test it for you on the Polar Alignment.

GregL
Posts: 55
Joined: Sun Apr 30, 2017 6:19 pm

Re: Orion Starshoot AutoGuider

Post by GregL » Tue May 02, 2017 6:21 pm

One followup note. My dome computer has both USB2 and USB3 ports -- and a powered USB2/3 hub that is plugged into a USB2 port. I have discovered that the SSAG driver simply does not behave when connected to a pure USB3 port. Get connection errors - 1167 usually. No idea what it means. But connecting it to the powered hub things work better. No connection errors.

I use an ascom hub for a number of things -- it had been my habit to connect the SSAG to the hub as an ascom guide camera. Not a good idea... if I connect to the driver directly by specifying SSAG in the individual program dialogs and leave the others down things work nicely -- so Sharpcap, PHD2, Astrotortilla... but using the hub things break. I suspect there is some sort of request conflict that is just not handled gracefully by their driver. So, the warning is still valid. But if one assumes that the shareability implied by an ascom hub applies to this camera it appears they would be mistaken. My experience anyhow.

greg latiak
avalon observatory

User avatar
admin
Site Admin
Posts: 2853
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Orion Starshoot AutoGuider

Post by admin » Tue May 02, 2017 9:22 pm

Hi Greg,

all good suggestions - I've also sometimes had success with the use of a hub where a device fails without it (and the other way round too). I think that using a camera via an ASCOM hub is not going to work with SharpCap as SharpCap runs the camera all the time like a video camera, so it is very likely to clash with any other software trying to talk to the camera.

cheers,

Robin

GaryCurran
Posts: 9
Joined: Sat Apr 22, 2017 3:03 am

Re: Orion Starshoot AutoGuider

Post by GaryCurran » Fri May 05, 2017 9:48 pm

Robin, again, spoiled by thunderstorms. :(

Have you added this 'repair' to either one of the last two builds? I haven't downloaded the latest one yet. I should go do that, but I haven't had time to play with it yet.

User avatar
admin
Site Admin
Posts: 2853
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Orion Starshoot AutoGuider

Post by admin » Sat May 06, 2017 7:53 am

Hi Gary,

the fix is in the released builds, so you should be good to test if the clouds ever clear :)

cheers,

Robin

GregL
Posts: 55
Joined: Sun Apr 30, 2017 6:19 pm

Re: Orion Starshoot AutoGuider

Post by GregL » Tue May 09, 2017 5:30 pm

Robin,

I think you are right... I will have to take a look at the ASCOM layout, but connecting to a camera through an ASCOM hub and actually using it are two very different things. I have gotten much more stable results by treating things as non-sharable resources. Now that I have the AG1.2 and v3, should be a new world. Eager to try the direct link to Astrotortilla -- when the sky finally clears.

greg

GaryCurran
Posts: 9
Joined: Sat Apr 22, 2017 3:03 am

Re: Orion Starshoot AutoGuider

Post by GaryCurran » Tue May 09, 2017 10:02 pm

admin wrote:
Sat May 06, 2017 7:53 am
Hi Gary,

the fix is in the released builds, so you should be good to test if the clouds ever clear :)

cheers,

Robin
Hopefully tonight! It's clear and sunny outside right now, but around here, that doesn't mean much!

mhectorgato
Posts: 8
Joined: Thu May 18, 2017 2:48 am

Re: Orion Starshoot AutoGuider

Post by mhectorgato » Thu May 18, 2017 3:01 am

Hi - new user here (Florida, so figure on high humidity and clouds)

Trying to get my SSAG and 3.0.3906.0 working together. My SSAG is plugged directly into my Win 10 home laptop. It's working ok with PHD2, but not showing up in the Cameras menu.

When I start up SharpCap, in the status bar (lower left side) it says "Detecting cameras..." In the Camera drop-down, the options available are : Rescan, the laptop's web-cam, and only the 2 test cameras.

After trying SharpCap, and not seeing the camera, I installed the 2.10 pre-requisites, and still no love.

I installed the Orion softwares from their site.

Here's the Log (nice to see c# being used here :) :
SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type QHYDeviceEnumerator
Info: 22:45:43.6003776 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type ASIDeviceEnumerator
Info: 22:45:43.6003776 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AltairDeviceEnumerator
Info: 22:45:43.8504065 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type PointGreyDeviceEnumerator
Info: 22:45:43.8816618 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type DS3DeviceEnumerator
Info: 22:45:43.8816618 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type SPCLXDeviceEnumerator
Info: 22:45:43.8816618 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AscomDeviceEnumerator
Error: 22:45:44.4285907 Thread:#1 SharpCap.ProxyFinder`1.TryLoadProxy(FileInfo fi) :: Exception from Failed to loaded Hardware Proxy assembly SharpCap.WheelProxy.ASCOM.dll because : Could not load file or assembly 'ASCOM.Utilities, Version=6.0.0.0, Culture=neutral, PublicKeyToken=565de7938946fba7' or one of its dependencies. The system cannot find the file specified. : Could not load file or assembly 'ASCOM.Utilities, Version=6.0.0.0, Culture=neutral, PublicKeyToken=565de7938946fba7' or one of its dependencies. The system cannot find the file specified.
Stack Trace: at SharpCap.WheelProxy.ASCOM.WheelFactory.GetAvailableDevices()
at SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) in C:\Documents\Source Code\SharpCap\src\SharpCap\Utils\ProxyFinder.cs:line 63
at SharpCap.ProxyFinder`1.TryLoadProxy(FileInfo fi) in C:\Documents\Source Code\SharpCap\src\SharpCap\Utils\ProxyFinder.cs:line 43
Extra Info:
Error: 22:45:44.5192067 Thread:#1 SharpCap.FocuserFinder.TryLoadFocuserProxy(FileInfo fi) :: Exception from Failed to loaded FocuserProxy assembly Sharpcap.FocuserProxy.ASCOM.dll because : Exception has been thrown by the target of an invocation. : Exception has been thrown by the target of an invocation.
Stack Trace: at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)
at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
at System.Activator.CreateInstance(Type type, Boolean nonPublic)
at System.Activator.CreateInstance(Type type)
at SharpCap.FocuserFinder.LoadFocusers(Type t) in C:\Documents\Source Code\SharpCap\src\SharpCap\Utils\FocuserFinder.cs:line 116
at SharpCap.FocuserFinder.TryLoadFocuserProxy(FileInfo fi) in C:\Documents\Source Code\SharpCap\src\SharpCap\Utils\FocuserFinder.cs:line 99
Extra Info:
Error: 22:45:44.5192067 Thread:#1 SharpCap.Base.Utilities.Logger.Warn(Exception e, String action, String additionalInfo) :: Inner Exception : System.IO.FileNotFoundException: Could not load file or assembly 'ASCOM.Utilities, Version=6.0.0.0, Culture=neutral, PublicKeyToken=565de7938946fba7' or one of its dependencies. The system cannot find the file specified.
File name: 'ASCOM.Utilities, Version=6.0.0.0, Culture=neutral, PublicKeyToken=565de7938946fba7'
at Sharpcap.FocuserProxy.ASCOM.Factory..ctor()

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Error: 22:45:44.5348045 Thread:#1 SharpCap.ProxyFinder`1.TryLoadProxy(FileInfo fi) :: Exception from Failed to loaded Hardware Proxy assembly SharpCap.MountProxy.ASCOM.dll because : Could not load file or assembly 'ASCOM.Utilities, Version=6.0.0.0, Culture=neutral, PublicKeyToken=565de7938946fba7' or one of its dependencies. The system cannot find the file specified. : Could not load file or assembly 'ASCOM.Utilities, Version=6.0.0.0, Culture=neutral, PublicKeyToken=565de7938946fba7' or one of its dependencies. The system cannot find the file specified.
Stack Trace: at SharpCap.MountProxy.ASCOM.MountFactory.GetAvailableDevices()
at SharpCap.ProxyFinder`1.LoadProxiesForFactoryType(Type t) in C:\Documents\Source Code\SharpCap\src\SharpCap\Utils\ProxyFinder.cs:line 63
at SharpCap.ProxyFinder`1.TryLoadProxy(FileInfo fi) in C:\Documents\Source Code\SharpCap\src\SharpCap\Utils\ProxyFinder.cs:line 43
Extra Info:
Info: 22:45:44.6910687 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: CPU : Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz with 4 cores.

Debug: 22:45:44.9723761 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Ended
Debug: 22:45:45.1197562 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Started
Debug: 22:45:45.1207296 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Ended
Debug: 22:45:45.1872963 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Started
Debug: 22:45:45.2538756 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Timebomb checked
Debug: 22:45:45.2604174 Thread:#1 SharpCap.Cameras.Basler.OldBaslerEnumerator.GetDevices() :: Started
Debug: 22:45:45.5386805 Thread:#1 SharpCap.Cameras.Basler.OldBaslerEnumerator.GetDevices() :: Ended
Debug: 22:45:45.5396836 Thread:#1 SharpCap.Cameras.Basler.OldBaslerEnumerator.GetDevices() :: Started
Debug: 22:45:45.5411911 Thread:#1 SharpCap.Cameras.Basler.OldBaslerEnumerator.GetDevices() :: Ended
Debug: 22:45:45.5426959 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Started
Debug: 22:45:45.5467014 Thread:#1 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Ended
Info: 22:45:45.6845834 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: QHYCameraFinder - found 0 cameras
Info: 22:45:45.7066420 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: FindCameras - found 0 cameras
Debug: 22:45:46.1558391 Thread:#1 SharpCap.Cameras.Ximea.XimeaDeviceEnumerator.GetDevices() :: Started
Info: 22:45:46.1658784 Thread:#1 SharpCap.Cameras.Ximea.XimeaDeviceEnumerator.GetDevices() :: XiCam.GetNumberDevices return 0
Debug: 22:45:46.1658784 Thread:#1 SharpCap.Cameras.Ximea.XimeaDeviceEnumerator.GetDevices() :: Ended
Info: 22:45:46.4567519 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevices>d__19.MoveNext() :: Detected Camera: HP Truevision Full HD (DirectShow Cameras via SharpCap Pipeline)
Warning: 22:45:46.5159092 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevices>d__19.MoveNext() :: Exception fetching menu items from provider : System.IO.FileNotFoundException: Could not load file or assembly 'ASCOM.Utilities, Version=6.0.0.0, Culture=neutral, PublicKeyToken=565de7938946fba7' or one of its dependencies. The system cannot find the file specified.
File name: 'ASCOM.Utilities, Version=6.0.0.0, Culture=neutral, PublicKeyToken=565de7938946fba7'
at SharpCap.Cameras.ASCOM.AscomDeviceEnumerator.GetDevices()
at SharpCap.MultiCaptureProvider.<GetDevices>d__19.MoveNext() in C:\Documents\Source Code\SharpCap\src\SharpCap\Models\MultiCaptureProvider.cs:line 162

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Debug: 22:45:46.5169122 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Started
Debug: 22:45:46.5169122 Thread:#1 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Ended
Info: 22:45:46.5169122 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevices>d__19.MoveNext() :: Detected Camera: Test Camera 1 (Deep Sky) (Test Cameras)
Info: 22:45:46.5169122 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevices>d__19.MoveNext() :: Detected Camera: Test Camera 2 (High Speed) (Test Cameras)
Debug: 22:45:46.6889054 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Docking setup
Debug: 22:45:46.6889054 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Startup scripts (if any) run
Debug: 22:45:46.6889054 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Timer set to activate last camera
Debug: 22:45:46.7045316 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Menu updated
Debug: 22:45:51.2878212 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Splash and tips done
Debug: 22:45:51.2878212 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Ended
Error: 22:45:51.6941166 Thread:#1 SharpCap.LicenseUpdateList.DownloadComplete(Object sender, DownloadStringCompletedEventArgs downloadStringCompletedEventArgs) :: Exception from Downloading license update list : The remote server returned an error: (404) Not Found.
Stack Trace: at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
at System.Net.WebClient.GetWebResponse(WebRequest request, IAsyncResult result)
at System.Net.WebClient.DownloadBitsResponseCallback(IAsyncResult result)
Extra Info:

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest