ZWO ASI120MC-S SCrren only Showing Mono Green

Post Reply
bazza104
Posts: 6
Joined: Mon Jun 04, 2018 12:13 am

ZWO ASI120MC-S SCrren only Showing Mono Green

Post by bazza104 » Mon Jun 04, 2018 6:46 am

<t>My list of ZWO ASI Cameras only shows one selection and that is the ZWO ASI120MC-S I have in the camera list.<br/>
The Camera works in colour in another Capture App but I like SharpCap except it shows the screen and the file catured in Mono green.<br/>
I have replaced the ZWO Drivers and files with the latest from the ZWO Site and Also removed and reinstalled Sharp Cap to the latest 3.1 but the green screen still persists.<br/>
I am sure in the past there was more in the drop down Camera list then the ASI120MC-S and believe it did work in colour.<br/>
<br/>
Using Recent AUSUS 360 Laptop with Latest Windows 10 Operating System. 8 GB ram USB 3.0</t>

User avatar
admin
Site Admin
Posts: 2745
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: ZWO ASI120MC-S SCrren only Showing Mono Green

Post by admin » Mon Jun 04, 2018 4:07 pm

Hi,

can you post a log from SharpCap and also a screenshot showing the problem please.

thanks,

Robin

bazza104
Posts: 6
Joined: Mon Jun 04, 2018 12:13 am

Re: ZWO ASI120MC-S SCrren only Showing Mono Green

Post by bazza104 » Tue Jun 05, 2018 12:14 am

Info: 09:59:32.9091976 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: SharpCap Version 3.1.5193.0
Info: 09:59:32.9091976 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: GC Memory 116Mb
Info: 09:59:32.9091976 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Process Memory 147Mb
Info: 09:59:32.9248200 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Total Physical Memory 8077Mb
Info: 09:59:32.9248200 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Available Physical Memory 5169Mb
Info: 09:59:32.9248200 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: Operating System : Microsoft Windows NT 6.2.9200.0
Debug: 09:59:33.2841101 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Started
Info: 09:59:33.3309744 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type BaslerDeviceEnumerator
Info: 09:59:33.3309744 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type QHYDeviceEnumerator
Info: 09:59:33.3309744 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type ASIDeviceEnumerator
Info: 09:59:33.3309744 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AltairDeviceEnumerator
Warning: 09:59:33.3778371 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Could not load capture provider - SharpCap.Cameras.PointGrey.PointGreyDeviceEnumerator - System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.IO.FileNotFoundException: Could not load file or assembly 'FlyCapture2Managed_v140.dll' or one of its dependencies. The specified module could not be found.
at SharpCap.Cameras.PointGrey.PointGreyDeviceEnumerator..ctor()
--- End of inner exception stack trace ---
at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)
at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)
at System.Activator.CreateInstance[T]()
at SharpCap.MultiCaptureProvider.AddProvider[T]() in C:\Documents\Source Code\SharpCap3.1\src\SharpCap\Models\MultiCaptureProvider.cs:line 509
Info: 09:59:33.3778371 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type SxDeviceEnumerator
Info: 09:59:33.4090807 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type DS3DeviceEnumerator
Info: 09:59:33.4090807 Thread:#1 SharpCap.MultiCaptureProvider.AddProvider() :: Added device enumerator of type AscomDeviceEnumerator
Info: 09:59:33.9717344 Thread:LogInfo Thread#8 SharpCap.LogSystemInfo.ThreadProc() :: CPU : Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz with 4 cores.

Info: 09:59:34.1904327 Thread:#1 SharpCap.Base.Utilities.Logger.LogStackTrace(LogLevel level, String msg) :: Parent being changed on PreviewPanel
at SharpCap.UI.ScrollZoomForm.OnParentChanged(Object sender, EventArgs eventArgs)
at System.EventHandler.Invoke(Object sender, EventArgs e)
Debug: 09:59:34.2529189 Thread:#1 SharpCap.UI.SharpCapForm..ctor() :: Ended
Debug: 09:59:34.5598156 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Started
Debug: 09:59:34.5608128 Thread:#1 SharpCap.UI.SharpCapForm.SharpCapForm_Load(Object sender, EventArgs e) :: Ended
Debug: 09:59:34.5847503 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Started
Debug: 09:59:34.6146690 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Timebomb checked
Debug: 09:59:34.6306260 Thread:#11 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Started
Info: 09:59:34.6515704 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: Found ZWO ASI120MC-S
Info: 09:59:34.6515704 Thread:#1 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: FindCameras - found 1 cameras
Info: 09:59:34.6515704 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: ZWO ASI120MC-S (ZWO ASI Cameras)
Debug: 09:59:34.6545623 Thread:#11 SharpCap.Cameras.Basler.BaslerDeviceEnumerator.GetDevices() :: Ended
Info: 09:59:34.7443224 Thread:#7 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: ASI Camera (1) (ASCOM Cameras)
Info: 09:59:34.7443224 Thread:#7 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: ASI Camera (2) (ASCOM Cameras)
Info: 09:59:34.7453196 Thread:#7 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Camera V2 simulator (ASCOM Cameras)
Debug: 09:59:34.7453196 Thread:#7 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Started
Debug: 09:59:34.7453196 Thread:#7 SharpCap.Cameras.Fake.FakeDeviceEnumerator.GetDevices() :: Ended
Info: 09:59:34.7463168 Thread:#7 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 1 (Deep Sky) (Test Cameras)
Info: 09:59:34.7463168 Thread:#7 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: Test Camera 2 (High Speed) (Test Cameras)
Info: 09:59:34.7702535 Thread:#1 SharpCap.MultiCaptureProvider+<GetDevicesFromEnumerator>d__20.MoveNext() :: Detected Camera: USB2.0 HD UVC WebCam (DirectShow Cameras)
Info: 09:59:34.7911968 Thread:#11 SharpCap.Base.SimpleDeviceEnumerator.GetDevices(Func`1 deviceNameFinder, String infoText, Func`2 fullNameToDispayName, Func`3 tagCreatorFunc) :: QHYCameraFinder - found 0 cameras
Debug: 09:59:34.9866749 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Docking setup
Debug: 09:59:34.9876736 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Startup scripts (if any) run
Debug: 09:59:34.9886693 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Menu updated
Debug: 09:59:40.6119595 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Splash and tips done
Debug: 09:59:40.8618652 Thread:#1 SharpCap.UI.SharpCapForm.SharpCap_Shown(Object sender, EventArgs e) :: Ended
Info: 10:00:01.0338212 Thread:#1 SharpCap.Models.Application+<>c__DisplayClass35_0.<set_SelectedCamera>b__0() :: Changing camera from none to ZWO ASI120MC-S
Info: 10:00:01.0650641 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: OpeningDevice event received in UI thread
Debug: 10:00:01.0650641 Thread:#1 SharpCap.MultiCaptureProvider.OpenDevice(DeviceTagData deviceTag) :: Opening device : ZWO ASI120MC-S (via ZWO ASI Cameras)
Info: 10:00:01.0806877 Thread:#1 SharpCap.Base.CaptureProviderBase`1.OpenDevice(DeviceTagData dtd) :: Started
Debug: 10:00:01.0806877 Thread:#1 SharpCap.Base.SimpleCaptureProvider.SetupDevice(DeviceTagData dtd) :: Started
Debug: 10:00:01.7680314 Thread:#1 SharpCap.Base.SimpleCaptureProvider.SetupDevice(DeviceTagData dtd) :: Ended
Info: 10:00:01.7836486 Thread:#1 SharpCap.Base.CaptureProviderBase`1.CreateCaptureControl() :: Started
Debug: 10:00:01.7836486 Thread:#1 SharpCap.Base.SimpleCaptureProvider.GetControls() :: Started
Debug: 10:00:01.7836486 Thread:#1 SharpCap.Cameras.ASI.ASICameraProxy.GetControlsImpl(IPreviewControl previewControl) :: Started
Info: 10:00:01.8149145 Thread:#1 SharpCap.Base.ColourSpacePropertyControl..ctor(IEnumFeature mainFeature, List`1 colourSpaces, IPreviewControl previewControl) :: Colour space RAW8 is valid.
Info: 10:00:01.8149145 Thread:#1 SharpCap.Base.ColourSpacePropertyControl..ctor(IEnumFeature mainFeature, List`1 colourSpaces, IPreviewControl previewControl) :: Colour space RGB24 is valid.
Info: 10:00:01.8149145 Thread:#1 SharpCap.Base.ColourSpacePropertyControl..ctor(IEnumFeature mainFeature, List`1 colourSpaces, IPreviewControl previewControl) :: Colour space MONO8 is valid.
Info: 10:00:01.8149145 Thread:#1 SharpCap.Base.ColourSpacePropertyControl..ctor(IEnumFeature mainFeature, List`1 colourSpaces, IPreviewControl previewControl) :: Colour space RAW16 is valid.
Debug: 10:00:01.8461325 Thread:#1 SharpCap.Cameras.ASI.ASICameraProxy.GetControlsImpl(IPreviewControl previewControl) :: Ended
Info: 10:00:01.8617534 Thread:#1 SharpCap.Base.CaptureProviderBase`1.CreateCaptureControl() :: Ended
Info: 10:00:01.8617534 Thread:#1 SharpCap.Base.CaptureProviderBase`1.OpenDevice(DeviceTagData dtd) :: Ended
Debug: 10:00:01.8617534 Thread:#1 SharpCap.Models.Camera.ApplyDefaultProfile() :: Started
Debug: 10:00:01.8617534 Thread:#1 SharpCap.Models.Camera.ApplyDefaultProfile() :: Ended (No default defined for this camera)
Info: 10:00:01.8617534 Thread:#1 SharpCap.MultiCaptureProvider.StartPreview() :: Starting preview on ZWO ASI120MC-S
Info: 10:00:01.8732360 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StartPreview() :: Started
Info: 10:00:01.8802194 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StartPreview() :: Starting Preview on ZWO ASI120MC-S, 1280x960, Bayer_GRBG, 8bits
Debug: 10:00:01.8852352 Thread:#1 SharpCap.Base.BaseImageProvider.Start() :: Started
Debug: 10:00:01.8902230 Thread:#1 SharpCap.Base.CameraProxyBase.StartPreview() :: Started
Debug: 10:00:01.8921865 Thread:Grab Thread#13 SharpCap.Base.CameraProxyBase.GrabThreadProc() :: Started
Debug: 10:00:01.9021606 Thread:ASI Grab Thread#3 SharpCap.Cameras.ASI.ASICameraProxy.MyGrabThreadProc() :: Started
Info: 10:00:01.9081430 Thread:#1 SharpCap.Base.Memory.Allocator.NumberOfMegabytesToMap() :: Paged memory check based on total memory of 8077Mb, available of 5188Mb
Info: 10:00:01.9081430 Thread:#1 SharpCap.Base.Memory.Allocator.NumberOfMegabytesToMap() :: Paged memory enabled at 1024Mb for Frame Cache and 1024Mb for LiveStack/Misc on 64 bit system.
Info: 10:00:01.9081430 Thread:#1 SharpCap.Base.Memory.Allocator..cctor() :: Assigning 1024Mb to non-pool memory and 1024Mb to the frame pool.
Debug: 10:00:01.9470407 Thread:#1 SharpCap.Base.CameraProxyBase.StartPreview() :: Ended
Debug: 10:00:01.9470407 Thread:#1 SharpCap.Base.BaseImageProvider.Start() :: Ended
Info: 10:00:01.9510279 Thread:#1 SharpCap.MultiCaptureProvider.SendCaptureEvent(Object sender, CaptureEventArgs e) :: Capture Event : StartPreview
Debug: 10:00:01.9540542 Thread:#1 SharpCap.UI.WPFControlForm.InitControls(CaptureControl captureControl, String deviceName) :: Started
Debug: 10:00:01.9819775 Thread:#1 SharpCap.UI.WPFControlForm.InitControls(CaptureControl captureControl, String deviceName) :: Ended
Info: 10:00:02.0298491 Thread:#1 SharpCap.Models.Transforms.set_SelectedTransform(Transform value) :: Selecting transform None
Info: 10:00:02.0338065 Thread:#1 SharpCap.ViewModels.SharpCapViewModel.appModel_OnCaptureEvent(Object sender, CaptureEventArgs e) :: StartPreview event received in UI thread
Info: 10:00:02.0348309 Thread:#1 SharpCap.ImageProcessing.AstroTortillaPlateSolver.IsAvailable() :: Plate solver not available
Info: 10:00:02.0358012 Thread:#1 SharpCap.Base.CaptureProviderBase`1.StartPreview() :: Ended
Debug: 10:00:32.1844488 Thread:#1 SharpCap.UI.SharpCapForm.CommandToolStripItem_Click(Object sender, EventArgs e) :: Button Pressed toolStripButton1
Info: 10:00:32.1854192 Thread:#1 SharpCap.Models.Transforms.set_SelectedTransform(Transform value) :: Selecting transform Histogram
Info: 10:00:32.1973606 Thread:#1 SharpCap.CameraAnalysis.SensorLibrary.LoadImpl(Object normalizeCameraName, String colourSpace) :: Loading library sensor characteristics from C:\Program Files (x86)\SharpCap 3.1\SensorLibrary\ZWO ASI120MC~RAW8.json
Debug: 10:00:39.2100858 Thread:#1 SharpCap.UI.SharpCapForm.CommandToolStripItem_Click(Object sender, EventArgs e) :: Button Pressed toolStripButton1
Info: 10:00:39.2100858 Thread:#1 SharpCap.Models.Transforms.set_SelectedTransform(Transform value) :: Selecting transform
Info: 10:00:56.2835989 Thread:#1 SharpCap.ViewModels.PlateSolveSettingsViewModel..ctor(Application app) :: Using plate solver at None found

bazza104
Posts: 6
Joined: Mon Jun 04, 2018 12:13 am

Re: ZWO ASI120MC-S SCrren only Showing Mono Green

Post by bazza104 » Tue Jun 05, 2018 12:44 am

Image
2018-06-05 (1).png
Screen shot showing active camera and list with live video background Mono Green
2018-06-05 (1).png (137.57 KiB) Viewed 742 times

User avatar
admin
Site Admin
Posts: 2745
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: ZWO ASI120MC-S SCrren only Showing Mono Green

Post by admin » Tue Jun 05, 2018 7:02 am

Ok, nothing badly wrong in the log, but I can see that your red and blue white balance controls are turned a long way down which may explain the green. Does the image go dark if you cover the sensor with something to stop light from getting to it? If so then it's probable that all is working as it should and you just need to tweak the red/blue white balance controls and then get focus sorted out.

cheers,

Robin

bazza104
Posts: 6
Joined: Mon Jun 04, 2018 12:13 am

Re: ZWO ASI120MC-S SCrren only Showing Mono Green

Post by bazza104 » Tue Jun 05, 2018 11:56 pm

Seems the Green Mono display and capture file problem has been resolved.
Both White Balance (R) and White Balance (B) were set to minimum on the scales slider from installation of 3.1. (Don't recall using them).
Both were set to Auto and now have a white RGB daylight screen.

Thank you.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests