ZWO ASI294MM Pro SDK Update

neverfox
Posts: 12
Joined: Fri Feb 05, 2021 6:39 pm

Re: ZWO ASI294MM Pro SDK Update

Post by neverfox »

Thanks for adding that!! But It looks like the frames taken by SCP in 11 Megapixel, bin 1 mode come out as 4844x2816 (saved as FITS) (not the case when taken in other software).
User avatar
admin
Site Admin
Posts: 6658
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: ZWO ASI294MM Pro SDK Update

Post by admin »

Hi,

as opposed to 4844 x 2822?

There are some complex rules about allowable image widths/heights for the ZWO cameras and they also interact with the binning setting. I suspect that SharpCap is internally rounding the height down to the multiple of 16 (probably incorrectly).

I'm kind of reluctant to tinker with this further since I don't have a camera to test with. 6 pixels out isn't a big deal and if I get something wrong while trying to fix that I could break something important.

cheers,

Robin
neverfox
Posts: 12
Joined: Fri Feb 05, 2021 6:39 pm

Re: ZWO ASI294MM Pro SDK Update

Post by neverfox »

Right, as opposed to 4844x2822. Ran into the issue when I tried to take some test flats. It was only a big deal because they wouldn't align with images taken in other software (like my darks library). Happy to help with any testing, if you like.
User avatar
admin
Site Admin
Posts: 6658
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: ZWO ASI294MM Pro SDK Update

Post by admin »

Hi,

if you have some time, can you try the following please:

1) before opening the camera, go to the settings and turn on additonal logging of 'Camera hardware connection'
2) Toggle SharpCap out of live mode (click the live mode button under the file menu to deselect it if selected)
3) Open the camera
4) Go into 47Mp mode and snapshot a single frame
5) Go into 11Mp mode and snapshot a single frame

after doing all that, please send the entire SharpCap log to me - should be quite lengthy with lots of detailed info about the calls SharpCap has made to the ZWO SDK. With a bit of luck I will be able to work out what is going wrong.

Cheers,

Robin
neverfox
Posts: 12
Joined: Fri Feb 05, 2021 6:39 pm

Re: ZWO ASI294MM Pro SDK Update

Post by neverfox »

Where do actually find thee log file to send?

Another thing: when switching from 46 to 11, it will bump the Resolution down. But when switching back to 46, the resolution stays at 4144x2822 and has to be changed manually.
User avatar
admin
Site Admin
Posts: 6658
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: ZWO ASI294MM Pro SDK Update

Post by admin »

Hi,

go to the 'Help' menu then choose 'Show Log'.

The box will contain the log from the current run of SharpCap.

Click the 'Locate on Disk' button to open the folder with all the log files from previous runs.

cheers,

Robin
neverfox
Posts: 12
Joined: Fri Feb 05, 2021 6:39 pm

Re: ZWO ASI294MM Pro SDK Update

Post by neverfox »

One more thing I'm seeing that's a bit problematic with these cameras that have high conversion gain modes. I set the Brain to target "Maximum Dynamic Range" but there are two gains where that's achieved on this camera: 0 and 120.
Screenshot 2021-05-08 090139.png
Screenshot 2021-05-08 090139.png (48.59 KiB) Viewed 447 times
120 gain is where HCG kicks in and dramatically reduces read noise. But depending on the Brain's "mood" (for lack of a better term), I sometimes get recommended 120 (or rather 121 because of the increments used) and sometimes 0. When it's 0, I'm sure the software is just doing what it's told to do and that it's the "right" answer. Thing is though, 0 isn't a reasonable recommendation for me. There's no way I want to operate this camera outside of HCG territory except for very niche applications (like getting short star exposures for HDR purposes). Setting it to target "Unity gain" isn't a way out because unity gain is actually just on the bad side of HCG for this camera too. What would be helpful then would be a way to tell the Brain a minimum gain value to consider (120, in this case). Is that a possibility?
User avatar
admin
Site Admin
Posts: 6658
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: ZWO ASI294MM Pro SDK Update

Post by admin »

Hi,

an indirect approach would be to set the maximum exposure time to a lower value - the gain=0 solution will require longer exposures, so by a careful choice of max exposure time you can exclude this from the brain results.

Another choice is to read off the suggestions manually from the brain graph - click at any point on the graph at the bottom of the brain window and it will show you the gain and recommended exposure for that gain.

cheers,

Robin
Lulu105
Posts: 4
Joined: Sat May 09, 2020 10:30 am

Re: ZWO ASI294MM Pro SDK Update

Post by Lulu105 »

hello

I just got my ASI294mm pro and manage the analysis with sharpcap 3.2 soft

Like many of you it seams that HGC is not properly running above 120 gain and to be honnest I'm bit lost between old and young binx1.

Would you soon upgrade the version?

thanks for your support!
User avatar
admin
Site Admin
Posts: 6658
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: ZWO ASI294MM Pro SDK Update

Post by admin »

Hi,

as far as I am aware, this mono version of the sensor is unable to operate properly (unable to produce saturated images) in HCG mode with a total gain of less than about 9.0x (about 200 in ZWO gain values). This is not something that can be fixed by a software update - it is a limitation of the sensor itself. I have seen the data sheet for the colour version and it clearly states this limitation in the documentation, although I have heard reports that the problem only shows up in the mono version of the sensor for ZWO cameras.

The best thing to do is to avoid gain values between 120 and ~200.

thanks,

Robin
Post Reply