Page 1 of 1

Point Grey CM3-U3-50S5C not available when using latest SharpCap builds

Posted: Tue May 12, 2020 1:53 pm
by holidayboy
Hi everybody,

I'm seeing an issue with all SharpCap builds newer than v3.2.6281 - my PTGrey Chameleon3 USB camera is not recognised at all!

I can use any version of SharpCap up to and including 3.2.6281 and everything is fine but all later builds are unable to "see" my camera at all.

So far I have tried:
  • Multiple reboots
  • Plugging the camera into a different USB port
  • Running SharpCap as Administrator
  • Running Flycap and resetting everything there before starting ShapCap
This isn't a huge problem for me - I just happened to see the newer builds while I was browsing the site.

I just wondered if this is expected behaviour, or possibly an issue with a recent code change in SharpCap perhaps?

Does anybody else have any issues with PTGrey cameras and the newer builds?

I'm using SharpCap Pro if that makes any difference...

I've attached screenshots of the issue:

version 3.2.6281.PNG
version 3.2.6281.PNG (147.81 KiB) Viewed 2106 times
version 3.2.6317.PNG
version 3.2.6317.PNG (73.83 KiB) Viewed 2106 times

Many thanks.

Rob.

Re: Point Grey CM3-U3-50S5C not available when using latest SharpCap builds

Posted: Tue May 12, 2020 5:48 pm
by admin
Hi,

Thanks for the report – I think I can see what happened in that I took out some files from the install pack related to Atik cameras after 6281 because they were necessary (they would have been on the users computer already from installing the Atik software). Unfortunately one of those files was shared and used by Point Grey cameras as well and I didn't notice that.

I will put it back in the next update.

Cheers, Robin

Re: Point Grey CM3-U3-50S5C not available when using latest SharpCap builds

Posted: Tue May 12, 2020 6:30 pm
by holidayboy
Thanks for the quick reply!

I noticed that the "FlyCapture2_v140.dll" file was not present in the SharpCap 3.2 Directory on the newer builds so I copied it across manually for a test and the newer builds work OK now.

Is that a silly thing to do, or am I OK to leave it that way for now?

Thanks again.

Rob.

Re: Point Grey CM3-U3-50S5C not available when using latest SharpCap builds

Posted: Wed May 13, 2020 6:16 pm
by admin
Hi Rob,

No, that's exactly the right fix and what I have done for future builds.

Cheers, Robin

Re: Point Grey CM3-U3-50S5C not available when using latest SharpCap builds

Posted: Sat May 16, 2020 1:41 pm
by holidayboy
Great, thanks very much.

Rob.