Basler daA1280-54um only in DirectShow in older systems

Post Reply
RTZ
Posts: 4
Joined: Mon Nov 05, 2018 3:36 pm

Basler daA1280-54um only in DirectShow in older systems

Post by RTZ » Mon Nov 05, 2018 4:49 pm

Hi, I have been using a Basler dart USB 3.0 camera (da1280-54um) for some time in a non-astronomical application connected to a Fujitsu Lifebook U747 (Win 10) and using SharpCap 3.1; the camera was properly recognized by the software allowing full control over exposure, frame rate, etc. However, recently the circumstances changed and it turned out that a different computer is needed to do the task and that's when the problems began. An older laptop was brought back from retirement (Fujitsu Lifebook E751 Win 7 Ultimate), which nominally has a USB 3.0 port. The camera was not recognized properly as on the newer laptop and when clicked on "Basler GenlCam Source" option that appeared instead of proper camera label in the Camera tab, a 'Performance warning' message appeared just as described by the user morinmau in this section of the forum. If this option is used, then of course, full functionality is lost, which renders the camera practically unusable. Initially, I thought that the problem was in the operating system which behaved in a sluggish and sometimes strange way before the laptop was retired. Therefore, I brought the laptop to a shop; they completely reformatted the hard drive and did a fresh clean install of Win 10 pro. The laptop became much more responsive and agile, but the problem with the Basler camera and SharpCap remained. The next hypothesis was that it was that the problem is in the USB 3.0 connection. A closer look at USB ports with USBview revealed one interesting difference between the older and the newer laptop: on the older one, the USB port that the camera connected to is not "debug capable", while on the newer one it is. Of course, because the USB controllers on the two laptops are from different generations, they appear slightly differently in Device Manager; not sure if this has anything to do with the "debug capable" option. To test if this problem was limited to Fujitsu laptops, I hooked the camera to a borrowed Dell OptiPlex 7020 (Win 7 Enterprise) and it showed the same problem as on the old laptop, and, again, USBview showed that the port was not debug capable.
Now the question is what to do next as using the new laptop is not an option anymore. The problem is complicated by the fact that very few (if any) manufacturers reveal what USB controllers are used in their computer and whether the USB ports are debug capable or not. One possibility is to use a desktop and a USB card with a known controller which guarantees USB port debug capability, but i am open and would appreciate any other advice too.

User avatar
admin
Site Admin
Posts: 2088
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Basler daA1280-54um only in DirectShow in older systems

Post by admin » Mon Nov 05, 2018 7:39 pm

Hi,

So first I am assuming that the camera works (just without many controls) with the 'GeniCam' option. That means we have to concentrate on why it is not showing under the Basler option and that is most likely a software rather than a hardware issue.

If you are using SharpCap 3.1 then you need to make sure you install the SharpCap Pre-requisites 'extra installer' on your new machine - that may help. 3.2 does not require this.

It would certainly be worth checking what version of the Basler Pylon install you have on the old computer and see if you have the same version on the new - also make sure that you have the same choices (at least) from the pylon installer selected.

If none of that helps, please post a SharpCap log here which will hopefully have some sort of useful error message.

cheers,

Robin

RTZ
Posts: 4
Joined: Mon Nov 05, 2018 3:36 pm

Re: Basler daA1280-54um only in DirectShow in older systems

Post by RTZ » Mon Nov 05, 2018 9:57 pm

Hi Robin,
Thanks for the prompt reply and sorry for the brevity in my post, which have resulted in confusion and misunderstanding. Let me clarify what software is on each system:
On the old laptop (E751), SharpCap 3.2.5865 was installed, together with Pylon Viewer 5.1 (as part of Pylon 5.1.0.12681 Camera Software Suite for Windows); also installed Redistributables-pylon 5-runtime (v.5.1.0).
On the new laptop (U757), SharpCap 3.1.5219.0 was installed and I must have installed also the SharpCap Pre-requisites, although no clear memory of that exists. Pylon Viewer 5.0 (as p[art of Pylon 5.0.12.11830 Camera Software Suite for Windows] was installed too as well as Basler Video Recording Software 1.3.
As to whether the camera woks under the GeniCam option in the old laptop, the answer is “yes”, but in a very, very limited way. The screen shows an image and recoding can be done, but any attempt to change the fps for example, would lead to a crash. Surprisingly, if one opens the Video Capture filter, the camera is identified properly in the Selected Camera window.
Earlier today, in an attempt to equalize the conditions on both machines, I uninstalled SharCap 3.2 and installed exactly the same version of SharpCap as on the newer laptop (3.1.5219.0) + SharpCap Pre-requisites; however, that did not solve the problem.
Will try to extract and send a log tomorrow.
Regards,
R.T.

RTZ
Posts: 4
Joined: Mon Nov 05, 2018 3:36 pm

Re: Basler daA1280-54um only in DirectShow in older systems

Post by RTZ » Tue Nov 06, 2018 7:26 pm

...and here is the log.
Regards, R.T.
SharpCap log_11062018_#2.txt
(25.66 KiB) Downloaded 5 times

HC1492
Site Admin
Posts: 4
Joined: Sat Nov 18, 2017 3:30 pm

Re: Basler daA1280-54um only in DirectShow in older systems

Post by HC1492 » Tue Nov 06, 2018 7:53 pm

There is nothing obviously bad in that log but I would try putting exactly the same set up that worked on the old laptop on the new laptop.
Heather

RTZ
Posts: 4
Joined: Mon Nov 05, 2018 3:36 pm

Re: Basler daA1280-54um only in DirectShow in older systems

Post by RTZ » Thu Nov 08, 2018 1:07 pm

Hi Heather/Robin,

I made sure yesterday that exactly the same software resides on both machines. However, the problem remained. Called Fujitsu technical support and, although they could not tell me what USB3.0 chipsets are used in both machines, they acknowledged that the USB 3.0 port on the older laptop may not cover all USB 3.0 specifications and, thus, may not be truly/fully complaint with the USB 3.0 industrial standard, including the USB3 Vision Standard and GenICam.
Therefore, I will be looking now to a different solution; will let you know how it goes.
Regards, R.T.

User avatar
turfpit
Posts: 488
Joined: Mon Feb 13, 2017 8:13 pm
Location: UK
Contact:

Re: Basler daA1280-54um only in DirectShow in older systems

Post by turfpit » Thu Nov 08, 2018 1:15 pm

If you download and run https://www.uwe-sieber.de/usbtreeview_e.html we can soon find out the USB chipsets in the machines. Post back the graphic image in the left hand pane of the application for both machines.

Dave

User avatar
admin
Site Admin
Posts: 2088
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Basler daA1280-54um only in DirectShow in older systems

Post by admin » Thu Nov 08, 2018 3:53 pm

Hi,

The fact that the camera works under the genicam option makes me suspect it's not a pure USB problem. If it was a pure USB problem the camera wouldn't work at all. One trick is to try using a USB 2 cable even though it's a USB 3 camera sometimes that helps. It would also be interesting to see a sharpcap 3.2 log from the problem laptop comma just to see if there's anything interesting in that that is different from the 3.1 log.

Cheers, Robin

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest