Saving changes within profile

Anything that doesn't fit into any of the other forums
User avatar
admin
Site Admin
Posts: 7392
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Saving changes within profile

Post by admin »

Hi,

thanks for taking the time to create the logs again - everything is there this time, so I can see that the 'Deep Sky 294MC' profile is loading and certainly sets the camera into RAW16 mode correctly.

Now I can see the full log, I am wondering if this could be down to the 'auto output format' option in the settings - see https://docs.sharpcap.co.uk/4.0/#Start% ... t%20format . (Note that this option has moved to a separate 'Saving' page of the settings in the latest SharpCap 4.0).

I believe that this option being set will override any settings in the loaded profile, which may be incorrect behaviour now I think about it. Can you test with this option turned off and see if it resolves your problem, and I will consider whether the default behaviour with it turned on needs to be changed.

thanks,

Robin
Ddaniel84
Posts: 47
Joined: Sun Apr 26, 2020 1:31 pm

Re: Saving changes within profile

Post by Ddaniel84 »

Thanks Robin

I will go to verify that on the PC used with the telescope.
Until now, in general settings, we have the choice to specify the format for video (.SER in my case) and another one for photo (I specified .FITS)
MAy be the problem would be in "video mode" as default.. How to specify the "photo" mode as default?

Dominique
From France (84)
CGX and Evolution mounts
C8 XLT - Celestron motor focus
ZWO ASI 294 MC pro - ZWO ASI 224 MCS
CPWI -PHD2 - Sharpcap - Siril - Stellarium - NINA
User avatar
admin
Site Admin
Posts: 7392
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Saving changes within profile

Post by admin »

Hi,

since I posted I have gone through the code and discovered that save/reload of profile settings does not work correctly for properties that show as dropdown lists and can be in 'auto' mode - altough the correct value is set, the auto on/off flag is not saved or restored.

I have corrected this in the code now and will release a new SharpCap next Monday with the fix. In the meantime, disabling the option I mentioned should work around the problem.

thanks,

Robin
Ddaniel84
Posts: 47
Joined: Sun Apr 26, 2020 1:31 pm

Re: Saving changes within profile

Post by Ddaniel84 »

Cool.. good news!
I'll say you next week-end.
Dominique
From France (84)
CGX and Evolution mounts
C8 XLT - Celestron motor focus
ZWO ASI 294 MC pro - ZWO ASI 224 MCS
CPWI -PHD2 - Sharpcap - Siril - Stellarium - NINA
Ddaniel84
Posts: 47
Joined: Sun Apr 26, 2020 1:31 pm

Re: Saving changes within profile

Post by Ddaniel84 »

Hi Robin
have you posted this last version solving the issue ? I don't find it...
Dominique
From France (84)
CGX and Evolution mounts
C8 XLT - Celestron motor focus
ZWO ASI 294 MC pro - ZWO ASI 224 MCS
CPWI -PHD2 - Sharpcap - Siril - Stellarium - NINA
Ddaniel84
Posts: 47
Joined: Sun Apr 26, 2020 1:31 pm

Re: Saving changes within profile

Post by Ddaniel84 »

Sorry, I just find it.. and good news: the problem is solved. Profiles are loaded correctly.
Thanks a lot.
Dominique
From France (84)
CGX and Evolution mounts
C8 XLT - Celestron motor focus
ZWO ASI 294 MC pro - ZWO ASI 224 MCS
CPWI -PHD2 - Sharpcap - Siril - Stellarium - NINA
Post Reply