Strange behaviour

Anything that doesn't fit into any of the other forums
Post Reply
Astropetev
Posts: 4
Joined: Sat Jun 08, 2019 12:27 am

Strange behaviour

Post by Astropetev » Sat Jun 08, 2019 12:34 am

I recently installed version2.9.3086.0 (the latest version of 2.9) to try out the polar alignment feature. I went for that version because my observatory computer is Windows XP, and version 3 won't run on it. It happily worked with my Altair GPCAM2.

I used it last night (first clear night for ages!) and it worked beautifully and was very straightforward.

BUT . . . . .

When messages came up on the screen overlaying the plate solved stars, all that text was mirror imaged (and I think upside down)! Very difficult to read, although it didn't prevent me completing the alignment. The text in the lower section of the screen was ok. Has anyone else experienced this - maybe there is a fix for it?

Cheers,

Peter

User avatar
admin
Site Admin
Posts: 3084
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Strange behaviour

Post by admin » Sun Jun 09, 2019 8:20 pm

Hi,

I'm afraid the version 2.9 is no longer supported or updated. In fact only version 3.2 is receiving updates and bug fixes.

Cheers, Robin

Astropetev
Posts: 4
Joined: Sat Jun 08, 2019 12:27 am

Re: Strange behaviour

Post by Astropetev » Sun Jun 09, 2019 11:41 pm

Thanks, Robin,

I appreciate that 2.9 is now a greybeard (like me!) and now unsupported. But I've experimented with a different camera on a Windows 7 desktop and the problem was the same, so seems to be within the program.

I've been out again tonight (another reasonably clear sky) and attach a screenshot. Again on an XP computer using an Altair GPCAM2. I wonder if it would be worth trying an earlier version of 2.9?

Added a little later. On playing with the attached image in Photoshop, I realise that the active part of the screen is flipped vertically. I wonder if there is a command to do this, thereby correcting the print (no good if it's within the camera driver). Maybe a script, although I wouldn't know where to start :-(

Cheers,
Peter.
Attachments
Sharpcap screenshot.jpg
Sharpcap screenshot.jpg (250.02 KiB) Viewed 255 times

User avatar
admin
Site Admin
Posts: 3084
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Strange behaviour

Post by admin » Mon Jun 10, 2019 6:45 pm

Hi,

I think it's to do with the fact that you are using the WebCam driver for that camera. Some WebCam drivers give images that are upside down for some reason and I'm guessing that this is one of those cameras. It looks like the old version of SharpCap doesn't deal with that situation and therefore ends up drawing on the image the wrong way up.

Cheers, Robin

Astropetev
Posts: 4
Joined: Sat Jun 08, 2019 12:27 am

Re: Strange behaviour

Post by Astropetev » Mon Jun 10, 2019 7:56 pm

Sorry, Robin, but I don't think that's it.

I used a Logitech webcam to test on my W7 desktop, getting a star field from Skymap Pro. The camera image is the same when viewed in Sharpcap and other programs, and is the correct way up. The screen shot is from my Observatory XP computer using an Altair GPCAM2, again the image is the same on another program (Altair Capture). So different drivers, different cameras and different operating systems. In both cases the image from the camera is not flipped. I tried 'mirroring' the webcam image, but it made no difference to the print overlay.

Strange that this never showed up over the various versions of 2.9. (I tried a few older versions - made no difference.) Fortunately it doesn't stop me polar aligning :-)

Cheers,

Peter

Astropetev
Posts: 4
Joined: Sat Jun 08, 2019 12:27 am

Re: Strange behaviour

Post by Astropetev » Wed Jun 12, 2019 1:21 pm

Hi again, Robin,

I know nothing can be done to correct the 2.9 problem, but just to clarify the situation, I have now installed version 3.2 on my W7 desktop, and tested the polar align program as far as I can without purchasing the license. And the screen overlay text is correctly printed. Comparison Screenshots below, versions 2.9 and 3.2, using the same Logitech webcam for both, and as you can see the text is inverted in 2.9 as before. No stars on the screen because I was hand holding the webcam in front of a star field from Skymap Pro, and had to put it down to save the screen image ;-) So that confirms that the problem is within version 2.9

But as I said before it's not a major problem - I can still polar align with 2.9 using my XP machines, just have to ignore the screen text. Thanks for your attention to this thread.

Cheers,

Peter
Attachments
Version2point9.jpg
Version2point9.jpg (161.01 KiB) Viewed 216 times
Version3point2.jpg
Version3point2.jpg (170.67 KiB) Viewed 216 times

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests