GPCAM2 290C Dropping Frames

Discussion of features and issues relating to Altair Astro Cameras
spica
Posts: 2
Joined: Sun Apr 11, 2021 5:33 am

Re: GPCAM2 290C Dropping Frames

Post by spica »

thanks Dave for your kind reply. You doc is very well done but I had already read it.
Unfortunately it is of little help in the matter.

I tried today with a desktop computer and the camera works percectly with no dropping frame at all in PHD2 and Sharpcap. At 10ms exposure time in Sharcap, with usb2 port and whaterver the usb speed setting is, 0 dropped frame out of 1000, even in bin 1 mono12.

So definitely a trick with laptops, much likely about battery power or life saving, or crap USB management, which I have not yet found. As it is for use in my observatory, I can afford giving up with my laptops.

Thanks again for your attempt of help.

Clear skies.

Laurent
User avatar
turfpit
Posts: 1443
Joined: Mon Feb 13, 2017 8:13 pm
Location: UK
Contact:

Re: GPCAM2 290C Dropping Frames

Post by turfpit »

Laurent

The aggressive power savings schemes in modern Windows can cause havoc with USB performance. This is always worse in laptops. Try disabling power saving and see what happens.

Dave
MillHeyAstro
Posts: 2
Joined: Wed Apr 14, 2021 10:04 pm

Re: GPCAM2 290C Dropping Frames

Post by MillHeyAstro »

Hi Laurent,

It is a very frustrating problem and I think must be a problem with the GPCAM2 firmware as it seems to occur in all multiple capture programmes and also in Linux. The one thing I have found that seems to solve the problem is to disable C-states as mentioned further up the discussion. The problem with this is that it has to be done in BIOS (unless somebody knows of an App that can do this once booted into Windows 10). Not all Laptops have the facility to disable C-states in the BIOS. I have a Dell laptop that allows me to do this - the camera works fine now on that machine, giving 17.5 fps with 8-bit raws and around 8 fps with 12-bit raws and no dropped frames or hanging. I also have an HP laptop which does not have an option to disable c-states in the BIOS - the best I have managed to achieve with this is by setting up a power scheme that causes the processor to run at 100% speed all the time, but it is still far from perfect.
Smapo
Posts: 9
Joined: Tue Aug 27, 2019 6:40 pm

Re: GPCAM2 290C Dropping Frames

Post by Smapo »

It's interesting to see that this problem is being reported by several other people with a similar set up (GPCAM 290C, modern Laptop, windows 10). At one point I thought it was only me.

The only solution (and believe me I have tried everything) is to disable "CPU C-States" in the Laptop BIOS. The windows/USB power savings modes/options/schemes make no difference.

This "fix" was originally identified by the Altair Tech support guys but unfortunately it is not really a fix for me as my main imaging Laptop (an Acer) does not have this option in the BIOS (a borrowed modern Dell Laptop does have the option and by disabling/enabling I have confirmed the fix beyond any doubt.).

So, in my case, I had a choice - buy a new Laptop (£££s) with the C-State BIOS option; or buy a new camera (£s) that doesn't suffer from the frame freeze problem.

No brainer unfortunately, I bought a new camera.

I'm happy to report that my other Altair camera (a 183C Hypercam) has never had this problem and continues to give superb service. Just a shame about the GPCAM 290C (it's in a box on the shelf!).
MillHeyAstro
Posts: 2
Joined: Wed Apr 14, 2021 10:04 pm

Re: GPCAM2 290C Dropping Frames

Post by MillHeyAstro »

Hi Smapo,
Good to hear that about the 183C Hypercam as that was on my upgrade pathway until I became aware of the bug with my 290.
Post Reply