Page 3 of 4

Re: Brightness and White Balance Adjustments after Smart Histogram Brain

Posted: Fri Nov 09, 2018 8:35 am
by turfpit
Good luck Mark.

Systematic testing and subsequent evaluation will be time well spent.

Dave

Re: Brightness and White Balance Adjustments after Smart Histogram Brain

Posted: Sat Apr 27, 2019 10:29 pm
by poolemarkw
Hello Again!

I just performed the Bias tests on a new ZWO ASI071MC Pro camera and found that it took a Brightess/Offset setting of 55 (max is 80) to center the data at only a Gain of 100. Moving to a Gain of 125 took required a Brightness of 70, and at a Gain of 150 I ran out of Brightness to center the Bias histogram. The Gain can go as high as 500 on this camera. What am I missing?

Thanks,

Mark

Re: Brightness and White Balance Adjustments after Smart Histogram Brain

Posted: Sun Apr 28, 2019 9:57 am
by turfpit
Mark

To assist with this can you post camera settings file(s), screen dump(s) with histogram(s) plus the FITS liberator display for the settings mentioned.

Dave

Re: Brightness and White Balance Adjustments after Smart Histogram Brain

Posted: Thu May 02, 2019 7:37 pm
by poolemarkw
Hi Dave,

I've attached two files: The first shows the FITS histogram that was generated with a snapshot, showing the histogram too far to the left. The second is the SharpCap settings that generated it. I had a gain of 200 and brightness at 80, the maximum. I can't increase the gain anymore to move the histogram to the right to be centered.

Thanks

Mark
FITS_Gain200_Brightness80.JPG
FITS_Gain200_Brightness80.JPG (153.72 KiB) Viewed 382 times
SC_Gain200_Brightness80.JPG
SC_Gain200_Brightness80.JPG (168.76 KiB) Viewed 382 times

Re: Brightness and White Balance Adjustments after Smart Histogram Brain

Posted: Thu May 02, 2019 8:59 pm
by turfpit
Mark

I found https://astronomy-imaging-camera.com/tu ... river.html. The article uses the ASCOM driver which exposes Predefined Settings of HDR, UG and LRN. Are these visible in the SC Camera Control Panel?

One of Sam's (ZWO) comments is "A proper offset value won’t cause any problem, so just forget offset with these Pro cameras, you can use unity gain in most cases".

This was also in the same article comments "Yes, we set a static value for offest, much easy for users. Because someone doesn’t understand offest and usually set a wrong value in photography."

Something going on here? I suggest waiting to see what Robin says before heading off to the ZWO Support Forum at https://bbs.astronomy-imaging-camera.com/

Dave

Re: Brightness and White Balance Adjustments after Smart Histogram Brain

Posted: Thu May 02, 2019 10:06 pm
by poolemarkw
Hi Dave,

No, I believe the presets are available when you set up the camera with an ASCOM connection rather than controlling it directly from SharpCap. I've never seen that setup driver screen.

Mark

Re: Brightness and White Balance Adjustments after Smart Histogram Brain

Posted: Fri May 03, 2019 6:17 am
by turfpit
Mark

Maybe try the ASCOM driver as a camera selection (after installing the ASCOM platform), then use the Show button in the Camera Control Panel to get to this screen (for an ASI 120MC).
ZWO-ASCOM.JPG
ZWO-ASCOM.JPG (29.91 KiB) Viewed 368 times
This leaves only exposure & gain as the controls to adjust (no Brightness/offset available). Maybe that is the way ZWO intend people to use the camera after re-reading the forum link above?

Dave

Re: Brightness and White Balance Adjustments after Smart Histogram Brain

Posted: Fri May 03, 2019 1:43 pm
by poolemarkw
Hi Dave,

I did as you suggested and when I clicked on "Show" it was configured in the "manual" setting value. I also noticed that when I selected an ASCOM Camera (AS1) from the SharpCap Camera selection list, the Brightness slider was no longer available.

As you may remember, I initially did this Bias testing to determine proper Brightness/Offset values for an ASI294 and it worked great. All I've done differently (that I can tell) is to now use the ASI071 camera.

Mark

Re: Brightness and White Balance Adjustments after Smart Histogram Brain

Posted: Fri May 03, 2019 1:51 pm
by turfpit
Mark

That fits in with the ZWO forum post. I think the latest SharpCap has an updated ZWO SDK. I can't really offer any more on this other than try the settings suggested by ZWO in the forum post. Take a bias frame for each of the 3 settings and see how it looks in FITS Liberator.

I use an old Atik CCD - it only has exposure to change. have a look at the bias frame in my post here
viewtopic.php?f=16&t=1607. I get the correct shape for no effort (same with a Canon DSLR, which only offers exposure and ISO).

Dave

Re: Brightness and White Balance Adjustments after Smart Histogram Brain

Posted: Fri May 03, 2019 3:38 pm
by admin
Hi,

The lack of the brightness setting in the Ascom driver is expected, since Ascom doesn't provide a way for SharpCap to control that aspect of the camera directly. The only way that you would get that sort of control with an Ascom driver is if the manufacturer of the camera put that control in the Ascom driver setup dialog.

I must admit having read through this thread I am struggling to understand where the problem is. Having just tested with my ZWO ASI 071 MC, if I set the brightness to the maximum value of 80 I can see that I get the histogram fairly well separated from the left-hand side at all gain values. There are a small number of pixels where the pixel value is cropped at zero (mainly in the blue channel by the look of things) at some gain values, but the count of these pixels is typically in the hundreds or low thousands out of 15 million, so the practical effect on final image quality is going to be incredibly small.

Cheers, Robin