Plate solving when mount is "parked"

Somewhere to share your expertise in using SharpCap
Post Reply
Posts: 33
Joined: Mon Feb 19, 2018 1:47 am

Plate solving when mount is "parked"

Post by nm1213 » Thu Mar 15, 2018 12:26 am


I was trying to build a new scope computer, and part of this involved configuring AstroTortilla and Sharpcap to work with each other for plate solving. Everything works fine on my existing machine, and plate solving in Sharpcap is a fantastic feature. However, I couldn't get the plate solve button to start solving on the new machine.

1. I tried to natively solve the m42_dim image in AstroTortilla, and that worked (although didn't solve because the FOV is different than my camera... which is fine).
2. I tried invoking plate solving through the Tools menu in Sharpcap instead of pressing the button. That brought up the plate solving ribbon and it attempted to solve.
3. I checked the sharpcap log file, and could see that the plate solver was being called by cygwin.

However, the plate solving button simply didn't do anything, and the usual status ribbon did not appear. Note: I was not connecting to my mount, rather to the ASCOM mount simulator.

I then noticed that the "park" checkbox in the sharpcap telescope control GUI was ticked on. I unticked this, and tried the plate solving button again. This now started working as expected, and brought up the status ribbon. I suspect that the plate solving button does not work when a mount is parked. Perhaps there should be a pop-up or status message warning when the solving button is pressed while in park? It would have saved about an hour of re-installing and troubleshooting effort.



User avatar
Site Admin
Posts: 4519
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK

Re: Plate solving when mount is "parked"

Post by admin » Thu Mar 15, 2018 7:58 pm


actually, when the mount is parked, all the movement related buttons are disabled so they can't be clicked on. I guess the problem is that they keep the black text/graphics rather than going grey as buttons normally do when disabled. Will look into changing that.



Post Reply