Fix for CPU usage goes to 100% while running SharpCap if you have PointGrey/Flir/Atik GP Camera

Somewhere to share your expertise in using SharpCap
Post Reply
User avatar
admin
Site Admin
Posts: 6973
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Fix for CPU usage goes to 100% while running SharpCap if you have PointGrey/Flir/Atik GP Camera

Post by admin »

Hi,

if you have a PointGrey/Flir camera or an Atik GP Cam (which is actaully PGR/Flir), you may encounter the task manager CPU level going to 100% while SharpCap is running, even if nothing is really doing anything on your PC. This is caused by the PointGrey driver disabling the normal speed control of your CPU while software that talks to the camera is open. What's worse, sometimes the CPU can be stuck this way even after closing SharpCap.

You can disable this annoyance by editing some PGR settings in the registry. Set

EnhancedHaltStateDisable to 0 in both

HKEY_LOCAL_MACHINE\SOFTWARE\Point Grey Research, Inc
and
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Point Grey Research, Inc.

If your CPU is already stuck at reporting 100% load without SharpCap running then try the following two commands in a Windows command prompt :

Code: Select all

PowerCfg /SETACVALUEINDEX SCHEME_CURRENT SUB_PROCESSOR IDLEDISABLE 000
PowerCfg /SETACTIVE SCHEME_CURRENT
running these should bring the CPU readout back to normal levels.

Note that the reading of 100% CPU usage when this issue happens is false - nothing is using all your CPU, it's just that task manager gets confused by the disabling of idle states.

Robin
Post Reply