Help with my saved files

Discussions of Electronically Assisted Astronomy using the Live Stacking feature.
Post Reply
orion.arcturus
Posts: 3
Joined: Tue Oct 09, 2018 3:15 am

Help with my saved files

Post by orion.arcturus » Tue Oct 09, 2018 3:39 am

So I noticed that the frames I take in live-stack saved to a folder time-stamped for that date. Well everything went fine up until 12:00 when the destination folder changed. What was then saved seems to be a 15GB .avi folder instead of the .fits files it was taking instead.
This is the folder where everything saved. '04_45_25' seems to be the folder it wanted to save into but instead is just a blank 'camera settings' text file.
The first .avi file (04_48_28) is the last 100 seconds chopped off from the stack it was taking as it switched from 11:59 to 12:00.
These are the folders where my .fits files saved properly, before the date change.

So my question is; is there anything I can do to retrieve my data?

The attachment 2.jpg is no longer available
1.jpg
1.jpg (18.61 KiB) Viewed 262 times

User avatar
admin
Site Admin
Posts: 2078
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Help with my saved files

Post by admin » Tue Oct 09, 2018 7:14 am

Hi,

please can you send the SharpCap log file for this imaging session - you will find the log file in the folder

Code: Select all

C:\Users\<your user name>\AppData\Local\SharpCap\logs
Please check the time stamp of the files to select the right one.

I would have thought it was impossible to get an AVI or SER file to save while live stacking, so would like to work out how it happened.

If the video files are viewable with correct looking images you may be able to process them to the desired format using PIPP.

cheers,

Robin

orion.arcturus
Posts: 3
Joined: Tue Oct 09, 2018 3:15 am

Re: Help with my saved files

Post by orion.arcturus » Tue Oct 09, 2018 2:41 pm

Here's the link to my log files:
https://drive.google.com/open?id=1WRhZ- ... 92v8TEhHpb

And what do you mean by "If your video files are viewable with correct looking images"?
Thanks for the reply.

User avatar
admin
Site Admin
Posts: 2078
Joined: Sat Feb 11, 2017 3:52 pm
Location: Vale of the White Horse, UK
Contact:

Re: Help with my saved files

Post by admin » Tue Oct 09, 2018 6:01 pm

Hi,

thank you for uploading the logs. I can see two times in the logs where saving to an AVI file is started

I can see some odd things -

1) you are capturing darks while live stacking. The fact that you are able to do this is a bug since all capturing should be disabled while live stacking is enabled, but I didn't think of the capture dark/capture flat options.

2) The fact that the capture dark/capture flat function has been used led to the 'start capture' and other capture buttons being enabled while live stacking - this is also incorrect.

I can see an AVI capture starting at 04:48:28 from the quick capture menu. I suspect that the AVI format is chosen because the 'Start cameras with auto output format' option is checked (see https://docs.sharpcap.co.uk/3.2/#Saving%20Options) and the exposure is <5s, which means a video format is selected.

It's difficult to be sure if any of the other file name issues would happen without the use of capture during live stacking - I will make sure that is fully disabled in SharpCap 3.2 and I will also keep trying to work out why the capture folder would change at midnight for existing captures already in progress.

cheers,

Robin

PS. About the AVI - I was unsure if the AVI would be corrupted or not as at the time I did not understand how it came to be saved. Seeing your logs I think it should be OK and you can likely convert it to an alternate file format using a tool like PIPP.

orion.arcturus
Posts: 3
Joined: Tue Oct 09, 2018 3:15 am

Re: Help with my saved files

Post by orion.arcturus » Tue Oct 09, 2018 7:28 pm

Thanks Robin, all of that info really helped. I do see I have the auto-output box checked to .avi, how that suddenly came into effect I'm not sure but I'll be sure to keep note of it for future sessions.
I'm going to try to retrieve the format with PIPP, I really hope you're right on that one! :D

User avatar
turfpit
Posts: 484
Joined: Mon Feb 13, 2017 8:13 pm
Location: UK
Contact:

Re: Help with my saved files

Post by turfpit » Tue Oct 09, 2018 8:15 pm

PIPP will work, just drag and drop the .avi onto PIPP. In the 'Output Options' tab select FITS (or whatever format you require). Next the 'Do Processing' tab and 'Start processing'.

I have recently done this for a .ser file.

Dave

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest